summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-12 17:21:02 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-12 17:21:02 +0100
commit1bf725d053524be5f3c8d2ac2a560a40705881d4 (patch)
treefb405acb0ada0d70b656bab1f7c33d20b650b025
parentf1ef54c499f1c634d90d6f634442aee908892b01 (diff)
php-tecnickcom-tc-lib-unicode-data: 1.6.5
-rw-r--r--php-tecnickcom-tc-lib-unicode-data/composer.json14
-rw-r--r--php-tecnickcom-tc-lib-unicode-data/php-tecnickcom-tc-lib-unicode-data.spec16
2 files changed, 19 insertions, 11 deletions
diff --git a/php-tecnickcom-tc-lib-unicode-data/composer.json b/php-tecnickcom-tc-lib-unicode-data/composer.json
index e5af406..b543798 100644
--- a/php-tecnickcom-tc-lib-unicode-data/composer.json
+++ b/php-tecnickcom-tc-lib-unicode-data/composer.json
@@ -17,13 +17,13 @@
},
"require-dev": {
"apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.0",
- "pdepend/pdepend" : "^2.2.2",
- "phploc/phploc" : "^2.1.5|^3.0.0",
- "phpmd/phpmd" : "^2.3.2",
- "phpunit/phpunit": "4.8.19|^5.0.0",
- "sebastian/phpcpd" : "^2.0.2",
- "squizlabs/php_codesniffer": "^2.5.0|^3.0.0"
+ "bartlett/php-compatinfo" : "^5.0.4",
+ "pdepend/pdepend" : "^2.5.0",
+ "phploc/phploc" : "^2.1.5 || ^3.0.1",
+ "phpmd/phpmd" : "^2.6.0",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
+ "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
+ "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
},
"autoload": {
"psr-4":{
diff --git a/php-tecnickcom-tc-lib-unicode-data/php-tecnickcom-tc-lib-unicode-data.spec b/php-tecnickcom-tc-lib-unicode-data/php-tecnickcom-tc-lib-unicode-data.spec
index a176c8b..0ce6160 100644
--- a/php-tecnickcom-tc-lib-unicode-data/php-tecnickcom-tc-lib-unicode-data.spec
+++ b/php-tecnickcom-tc-lib-unicode-data/php-tecnickcom-tc-lib-unicode-data.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit ac065f9ad2964b660fb8d5e7deda59049d6e44b0
+%global gh_commit f401208fc32b2856ecf21b666cc221c847019f78
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.6.4
+Version: 1.6.5
Release: 1%{?dist}
Summary: PHP library containing UTF-8 font definitions
@@ -80,9 +80,14 @@ require '%{buildroot}%{php_project}/autoload.php';
EOF
ret=0
-for cmd in php56 php70 php71 php; do
+for cmd in php56 php; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+ $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
+ fi
+done
+for cmd in php70 php71; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -108,6 +113,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Feb 12 2017 Remi Collet <remi@remirepo.net> - 1.6.5-1
+- update to 1.6.5 (no change)
+
* Mon Feb 6 2017 Remi Collet <remi@remirepo.net> - 1.6.4-1
- update to 1.6.4 (no change)