summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-24 10:26:07 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-24 10:26:07 +0100
commit37c7d18a85254e069cc12d6dce24e3e1fcd45eb4 (patch)
tree11845a3a08de2ead4c6b9596149d4916cab56bff
parent98e414be9cdb96e2597eab98991c99fcf13cb1f3 (diff)
php/tecnick/php-tecnickcom-tc-lib-barcode moved to git.remirepo.net
-rw-r--r--php-tecnickcom-tc-lib-barcode/Makefile4
-rw-r--r--php-tecnickcom-tc-lib-barcode/composer.json49
-rw-r--r--php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec271
3 files changed, 0 insertions, 324 deletions
diff --git a/php-tecnickcom-tc-lib-barcode/Makefile b/php-tecnickcom-tc-lib-barcode/Makefile
deleted file mode 100644
index 13af741..0000000
--- a/php-tecnickcom-tc-lib-barcode/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-SRCDIR := $(shell pwd)
-NAME := $(shell basename $(SRCDIR))
-include ../../../common/Makefile
-
diff --git a/php-tecnickcom-tc-lib-barcode/composer.json b/php-tecnickcom-tc-lib-barcode/composer.json
deleted file mode 100644
index 05d4df6..0000000
--- a/php-tecnickcom-tc-lib-barcode/composer.json
+++ /dev/null
@@ -1,49 +0,0 @@
-{
- "name": "tecnickcom/tc-lib-barcode",
- "description": "PHP library to generate linear and bidimensional barcodes",
- "type": "library",
- "homepage": "http://www.tecnick.com",
- "license": "LGPL-3.0",
- "keywords": ["tc-lib-barcode", "barcode", "CODE 39", "ANSI MH10.8M-1983", "USD-3", "3 of 9", "CODE 93", "USS-93", "Standard 2 of 5", "Interleaved 2 of 5", "CODE 128 A B C", "UPC", "EAN 8", "EAN 13", "UPC-A", "UPC-E", "MSI", "POSTNET", "PLANET", "RMS4CC", "Royal Mail", "CBC", "KIX", "Klant", "Intelligent Mail Barcode", "Onecode", "USPS-B-3200", "CODABAR", "CODE 11", "PHARMACODE", "PHARMACODE TWO-TRACKS", "Datamatrix", "ECC200", "QR-Code", "PDF417"],
- "authors": [
- {
- "name": "Nicola Asuni",
- "email": "info@tecnick.com",
- "role": "lead"
- }
- ],
- "require": {
- "php": ">=5.4",
- "ext-bcmath": "*",
- "ext-date": "*",
- "ext-gd": "*",
- "ext-pcre": "*",
- "tecnickcom/tc-lib-color": "^1.12.6"
- },
- "require-dev": {
- "apigen/apigen" : "^4.1.2",
- "bartlett/php-compatinfo" : "^5.0.4",
- "pdepend/pdepend" : "^2.5.0",
- "phploc/phploc" : "^2.1.5 || ^3.0.1",
- "phpmd/phpmd" : "^2.6.0",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0",
- "sebastian/phpcpd" : "^2.0.4 || 3.0.0",
- "squizlabs/php_codesniffer": "^2.8.0 || ^3.0.0"
- },
- "autoload": {
- "psr-4":{
- "Com\\Tecnick\\Barcode\\": "src"
- }
- },
- "autoload-dev": {
- "psr-4":{
- "Test\\": "test"
- }
- },
- "repositories": [
- {
- "type": "vcs",
- "url": "git@github.com:tecnickcom/tc-lib-color.git"
- }
- ]
-}
diff --git a/php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec b/php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec
deleted file mode 100644
index 74e8fb0..0000000
--- a/php-tecnickcom-tc-lib-barcode/php-tecnickcom-tc-lib-barcode.spec
+++ /dev/null
@@ -1,271 +0,0 @@
-# remirepo/fedora spec file for php-tecnickcom-tc-lib-barcode
-#
-# Copyright (c) 2015-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%global gh_commit 18b8b9224c995cd9d7518e8551be833cbc31b323
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global c_vendor tecnickcom
-%global gh_owner tecnickcom
-%global gh_project tc-lib-barcode
-%global php_project %{_datadir}/php/Com/Tecnick/Barcode
-%global with_tests 0%{!?_without_tests:1}
-
-Name: php-%{gh_owner}-%{gh_project}
-Version: 1.15.6
-Release: 1%{?dist}
-Summary: PHP library to generate linear and bidimensional barcodes
-
-Group: Development/Libraries
-License: LGPLv3+
-URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildArch: noarch
-%if %{with_tests}
-# For tests
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
-%global phpunit %{_bindir}/phpunit
-%endif
-BuildRequires: %{phpunit}
-BuildRequires: php(language) >= 5.4
-BuildRequires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1
-BuildRequires: php-bcmath
-BuildRequires: php-date
-BuildRequires: php-gd
-BuildRequires: php-pcre
-# Optional but required for test
-BuildRequires: php-pecl-imagick
-%endif
-
-# From composer.json, "require": {
-# "php": ">=5.4"
-# "ext-bcmath": "*",
-# "ext-date": "*",
-# "ext-gd": "*",
-# "ext-pcre": "*",
-# "tecnickcom/tc-lib-color": "^1.12.4"
-Requires: php(language) >= 5.4
-Requires: php-bcmath
-Requires: php-date
-Requires: php-gd
-Requires: php-pcre
-Requires: php-composer(%{c_vendor}/tc-lib-color) >= 1.12.1
-Requires: php-composer(%{c_vendor}/tc-lib-color) < 2
-# From phpcompatinfo report for version 1.15.5
-# none
-
-# Composer
-Provides: php-composer(%{c_vendor}/%{gh_project}) = %{version}
-# Upstream package name
-Provides: php-%{gh_project} = %{version}
-
-
-%description
-Provides tc-lib-barcode: PHP classes to generate linear and bidimensional
-barcodes: CODE 39, ANSI MH10.8M-1983, USD-3, 3 of 9, CODE 93, USS-93,
-Standard 2 of 5, Interleaved 2 of 5, CODE 128 A/B/C, 2 and 5 Digits
-UPC-Based Extension, EAN 8, EAN 13, UPC-A, UPC-E, MSI, POSTNET, PLANET,
-RMS4CC (Royal Mail 4-state Customer Code), CBC (Customer Bar Code),
-KIX (Klant index - Customer index), Intelligent Mail Barcode, Onecode,
-USPS-B-3200, CODABAR, CODE 11, PHARMACODE, PHARMACODE TWO-TRACKS, Datamatrix
-ECC200, QR-Code, PDF417.
-
-Optional dependency: php-pecl-imagick
-
-
-%prep
-%setup -q -n %{gh_project}-%{gh_commit}
-
-: Sanity check
-grep -q '^%{version}$' VERSION
-
-: Fix the examples
-sed -e 's:^require:////require:' \
- -e 's:^//require:require:' \
- -i example/*php
-
-
-%build
-# Empty build section, most likely nothing required.
-
-
-%install
-rm -rf %{buildroot}
-mkdir -p $(dirname %{buildroot}%{php_project})
-cp -pr src %{buildroot}%{php_project}
-cp -p resources/autoload.php \
- %{buildroot}%{php_project}/autoload.php
-
-
-%check
-%if %{with_tests}
-mkdir vendor
-cat <<EOF | tee vendor/autoload.php
-<?php
-require '%{buildroot}%{php_project}/autoload.php';
-require '%{php_project}/../Color/autoload.php';
-require __DIR__ . '/../test/TestStrings.php';
-EOF
-
-%{phpunit} --no-coverage --verbose
-
-#remirepo:12
-ret=0
-for cmd in php56; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
- fi
-done
-for cmd in php70 php71; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
- fi
-done
-exit $ret
-%else
-: Test suite disabled
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{!?_licensedir:%global license %%doc}
-%license LICENSE
-%doc composer.json
-%doc README.md example
-%{php_project}
-
-
-%changelog
-* Sun Feb 12 2017 Remi Collet <remi@remirepo.net.org> - 1.15.6-1
-- update to 1.15.6 (no change)
-- use phpunit6 on F26+
-
-* Mon Feb 6 2017 Remi Collet <remi@fedoraproject.org> - 1.15.5-1
-- update to 1.15.5 (no change)
-
-* Fri Nov 18 2016 Remi Collet <remi@fedoraproject.org> - 1.15.4-1
-- update to 1.15.4
-
-* Fri Oct 14 2016 Remi Collet <remi@fedoraproject.org> - 1.15.2-1
-- update to 1.15.2
-
-* Mon Sep 5 2016 Remi Collet <remi@fedoraproject.org> - 1.15.0-1
-- update to 1.15.0
-
-* Fri Sep 2 2016 Remi Collet <remi@fedoraproject.org> - 1.14.0-1
-- update to 1.14.0
-- raise dependency on tecnickcom/tc-lib-color >= 1.12.1
-
-* Mon Jul 11 2016 Remi Collet <remi@fedoraproject.org> - 1.9.2-1
-- update to 1.9.2
-
-* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 1.9.0-1
-- update to 1.9.0 (no change)
-
-* Thu Mar 10 2016 Remi Collet <remi@fedoraproject.org> - 1.8.0-1
-- update to 1.8.0
-- raise dependency on tecnickcom/tc-lib-color >= 1.10.0
-
-* Fri Mar 4 2016 Remi Collet <remi@fedoraproject.org> - 1.7.3-1
-- update to 1.7.3
-
-* Mon Feb 29 2016 Remi Collet <remi@fedoraproject.org> - 1.7.2-1
-- update to 1.7.2
-
-* Tue Dec 15 2015 Remi Collet <remi@fedoraproject.org> - 1.7.1-1
-- update to 1.7.1 (no change)
-
-* Fri Dec 11 2015 Remi Collet <remi@fedoraproject.org> - 1.7.0-1
-- update to 1.7.0 (no change)
-- raise dependency on php >= 5.4
-- raise dependency on tecnickcom/tc-lib-color ^1.8.0
-
-* Fri Dec 11 2015 Remi Collet <remi@fedoraproject.org> - 1.6.8-1
-- update to 1.6.8 (no change)
-
-* Tue Dec 8 2015 Remi Collet <remi@fedoraproject.org> - 1.6.6-1
-- update to 1.6.6 (no change)
-
-* Mon Dec 7 2015 Remi Collet <remi@fedoraproject.org> - 1.6.5-1
-- update to 1.6.5 (no change)
-
-* Thu Dec 3 2015 Remi Collet <remi@fedoraproject.org> - 1.6.3-1
-- update to 1.6.3 (no change)
-
-* Fri Nov 27 2015 Remi Collet <remi@fedoraproject.org> - 1.6.1-1
-- update to 1.6.1 (no change)
-
-* Wed Nov 25 2015 Remi Collet <remi@fedoraproject.org> - 1.6.0-1
-- update to 1.6.0
-
-* Fri Nov 20 2015 Remi Collet <remi@fedoraproject.org> - 1.5.6-1
-- update to 1.5.6 (no change)
-
-* Fri Nov 20 2015 Remi Collet <remi@fedoraproject.org> - 1.5.4-1
-- update to 1.5.4 (no change)
-
-* Wed Nov 18 2015 Remi Collet <remi@fedoraproject.org> - 1.5.2-1
-- update to 1.5.2 (no change)
-- run test suite with both PHP 5 and 7 when available
-
-* Wed Nov 4 2015 Remi Collet <remi@fedoraproject.org> - 1.5.0-1
-- update to 1.5.0
-
-* Tue Oct 20 2015 Remi Collet <remi@fedoraproject.org> - 1.4.7-1
-- update to 1.4.7 (no change)
-
-* Fri Sep 25 2015 Remi Collet <remi@fedoraproject.org> - 1.4.6-1
-- update to 1.4.6 (no change)
-
-* Sun Sep 13 2015 Remi Collet <remi@fedoraproject.org> - 1.4.3-1
-- update to 1.4.3
-- provide php-composer(tecnickcom/tc-lib-barcode)
-
-* Thu Aug 27 2015 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
-- update to 1.4.2
-
-* Tue Aug 25 2015 Remi Collet <remi@fedoraproject.org> - 1.4.1-3
-- add patch for PHP 5.3
- https://github.com/tecnickcom/tc-lib-barcode/pull/7
-
-* Wed Aug 12 2015 Remi Collet <remi@fedoraproject.org> - 1.4.1-2
-- fix package summary
-
-* Tue Aug 11 2015 Remi Collet <remi@fedoraproject.org> - 1.4.1-1
-- update to 1.4.1
-
-* Tue Aug 11 2015 Remi Collet <remi@fedoraproject.org> - 1.4.0-1
-- update to 1.4.0
-
-* Sat Aug 8 2015 Remi Collet <remi@fedoraproject.org> - 1.3.1-1
-- update to 1.3.1
-
-* Thu Aug 6 2015 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
-- update to 1.3.0
-
-* Fri Jul 24 2015 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
-- update to 1.2.1 (no change)
-
-* Thu Jul 2 2015 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
-- update to 1.2.0
-
-* Wed Jul 1 2015 Remi Collet <remi@fedoraproject.org> - 1.1.3-1
-- update to 1.1.3
-- drop patch merged upstream
-
-* Wed Jul 1 2015 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
-- initial package, version 1.1.2
-- open https://github.com/tecnickcom/tc-lib-barcode/pull/2
- PHP < 5.5 compatibility