summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-06 18:25:41 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-06 18:25:41 +0200
commitb9690c2d783c42d08b5ce9afe153017181ec3144 (patch)
treed1780dd9927425ccc51d36086e6d69cebd4d28a0
parent17ca0508094f6e9c9def0dedcebb4a028510211e (diff)
php-symfony2-Routing: sync with rawhide
-rw-r--r--php-symfony2-Routing.spec93
1 files changed, 65 insertions, 28 deletions
diff --git a/php-symfony2-Routing.spec b/php-symfony2-Routing.spec
index 5a915af..2e3b3c2 100644
--- a/php-symfony2-Routing.spec
+++ b/php-symfony2-Routing.spec
@@ -1,19 +1,17 @@
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_channel pear.symfony.com
-%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
+%global pear_name Routing
%global php_min_ver 5.3.3
-# Requires HttpKernel to run tests, but this package's build order is before
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
-Name: php-symfony2-Routing
+Name: php-symfony2-%{pear_name}
Version: 2.2.0
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
Group: Development/Libraries
License: MIT
-URL: http://symfony.com/doc/current/components/routing.html
+URL: http://symfony.com/doc/current/components/routing/index.html
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -21,38 +19,42 @@ BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
-%if %{with_tests}
-# Test requires
+# For tests
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
BuildRequires: php-pear(%{pear_channel}/Config) >= 2.2.0
-BuildRequires: php-pear(%{pear_channel}/HttpKernel) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/Config) < 2.3.0
BuildRequires: php-pear(%{pear_channel}/Yaml) >= 2.2.0
-# Test requires: phpci
+BuildRequires: php-pear(%{pear_channel}/Yaml) < 2.3.0
+BuildRequires: php-pear(pear.doctrine-project.org/DoctrineCommon) >= 2.2.0
+BuildRequires: php-pear(pear.doctrine-project.org/DoctrineCommon) < 3.0.0
+BuildRequires: php-PsrLog >= 1.0
+BuildRequires: php-PsrLog < 2.0
+# For tests: phpci
BuildRequires: php-dom
-BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
BuildRequires: php-tokenizer
-%endif
Requires: php(language) >= %{php_min_ver}
Requires: php-pear(PEAR)
Requires: php-channel(%{pear_channel})
Requires(post): %{__pear}
Requires(postun): %{__pear}
-# phpci requires
+# phpci
Requires: php-dom
-Requires: php-libxml
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
Requires: php-tokenizer
-# Optional requires
+# Optional
Requires: php-pear(%{pear_channel}/Config) >= 2.2.0
+Requires: php-pear(%{pear_channel}/Config) < 2.3.0
Requires: php-pear(%{pear_channel}/Yaml) >= 2.2.0
-# TODO: Add DoctrineCommon (>=2.2,<2.4-dev) when available
+Requires: php-pear(%{pear_channel}/Yaml) < 2.3.0
+Requires: php-pear(pear.doctrine-project.org/DoctrineCommon) >= 2.2.0
+Requires: php-pear(pear.doctrine-project.org/DoctrineCommon) < 3.0.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -65,15 +67,46 @@ Optional dependency: DoctrineCommon
%prep
%setup -q -c
+# Create PHPUnit autoloader
+( cat <<'PHPUNIT_AUTOLOADER'
+<?php
+
+# This file was created by RPM packaging and is not part of the original
+# Symfony2 %{pear_name} PEAR package.
+
+set_include_path(
+ '%{pear_phpdir}'.PATH_SEPARATOR.
+ '%{pear_testdir}/%{pear_name}'.PATH_SEPARATOR.
+ get_include_path()
+);
+
+spl_autoload_register(function ($class) {
+ if ('\\' == $class[0]) {
+ $class = substr($class, 1);
+ }
+
+ $file = str_replace('\\', '/', $class).'.php';
+ @include $file;
+});
+PHPUNIT_AUTOLOADER
+) > phpunit.autoloader.php
+
+# Update PHPUnit config
+sed -e 's#vendor/autoload.php#./phpunit.autoloader.php#' \
+ -i %{pear_name}-%{version}/Symfony/Component/%{pear_name}/phpunit.xml.dist
+
# Modify PEAR package.xml file:
+# - Remove .gitattributes file
# - Remove .gitignore file
# - Change role from "php" to "doc" for CHANGELOG.md file
# - Change role from "php" to "test" for all test files
-# - Remove md5sum from bootsrap.php file since it was patched
-sed -e '/\.gitignore/d' \
+# - Remove md5sum from phpunit.xml.dist file since it was updated
+sed -e '/\.gitattributes/d' \
+ -e '/\.gitignore/d' \
-e '/CHANGELOG.md/s/role="php"/role="doc"/' \
- -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
+ -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
+ -e '/phpunit.xml.dist/s/md5sum="[^"]*"\s*//' \
-i package.xml
# package.xml is version 2.0
@@ -95,20 +128,17 @@ rm -rf %{buildroot}%{pear_metadir}/.??*
mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
-sed -e '/bootstrap/s:vendor/autoload.php:%{pear_phpdir}/Symfony/Component/%{pear_name}/autoloader.php:' \
- %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml.dist \
- > %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml
+# Install PHPUnit autoloader
+install -pm 0644 ../phpunit.autoloader.php \
+ %{buildroot}/%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/
%check
-%if %{with_tests}
cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
-sed -e '/bootstrap/s:vendor/autoload.php:autoloader.php:' \
- phpunit.xml.dist > phpunit.xml
-%{_bindir}/phpunit -d date.timezone=UTC
-%else
-: Tests skipped, missing '--with tests' option
-%endif
+
+sed 's#./phpunit.autoloader.php#./autoloader.php#' -i phpunit.xml.dist
+
+%{_bindir}/phpunit -d date.timezone="UTC"
%post
@@ -132,6 +162,13 @@ fi
%changelog
+* Wed Mar 13 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 2.2.0-1
+- Updated to 2.2.0
+- Removed tests' bootstrap patch
+- Added php-PsrLog build require
+- Added php-pear(pear.doctrine-project.org/DoctrineCommon) require
+- Removed php-libxml require
+
* Wed Mar 06 2013 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
- Update to 2.2.0