summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-06 10:36:16 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-06 10:36:16 +0100
commit17ca0508094f6e9c9def0dedcebb4a028510211e (patch)
tree4cdcdae6df4af42316c58503db423a40bf27357f
parent3d97f14ef111c904da19d6f06f44995018726a11 (diff)
php-symfony2-Routing: 2.2.0
-rw-r--r--php-symfony2-Routing-tests-bootstrap.patch24
-rw-r--r--php-symfony2-Routing.spec32
2 files changed, 17 insertions, 39 deletions
diff --git a/php-symfony2-Routing-tests-bootstrap.patch b/php-symfony2-Routing-tests-bootstrap.patch
deleted file mode 100644
index d828fed..0000000
--- a/php-symfony2-Routing-tests-bootstrap.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- Symfony/Component/Routing/Tests/bootstrap.php 2012-09-20 03:42:17.000000000 -0400
-+++ Symfony/Component/Routing/Tests/bootstrap.php 2012-10-23 20:45:45.429166397 -0400
-@@ -10,9 +10,18 @@
- */
-
- spl_autoload_register(function ($class) {
-- if (0 === strpos(ltrim($class, '/'), 'Symfony\Component\Routing')) {
-- if (file_exists($file = __DIR__.'/../'.substr(str_replace('\\', '/', $class), strlen('Symfony\Component\Routing')).'.php')) {
-- require_once $file;
-+ if (0 === strpos(ltrim($class, '/'), 'Symfony\Component')) {
-+ $file = substr(str_replace('\\', '/', $class), strlen('Symfony\Component')).'.php';
-+ if (file_exists(__DIR__.'/../..'.$file)) {
-+ // Load from source tree
-+ require_once __DIR__.'/../..'.$file;
-+ } else {
-+ try {
-+ // Try loading from incude path
-+ require_once 'Symfony/Component'.$file;
-+ } catch (Exception $e) {
-+ // Fail silently so class not found fatal error still raised
-+ }
- }
- }
- });
diff --git a/php-symfony2-Routing.spec b/php-symfony2-Routing.spec
index dfaf52c..5a915af 100644
--- a/php-symfony2-Routing.spec
+++ b/php-symfony2-Routing.spec
@@ -7,7 +7,7 @@
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
Name: php-symfony2-Routing
-Version: 2.1.8
+Version: 2.2.0
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
@@ -15,7 +15,6 @@ Group: Development/Libraries
License: MIT
URL: http://symfony.com/doc/current/components/routing.html
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
-Patch0: %{name}-tests-bootstrap.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -26,9 +25,9 @@ BuildRequires: php-channel(%{pear_channel})
# Test requires
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
-BuildRequires: php-pear(%{pear_channel}/Config) >= 2.1.0
-BuildRequires: php-pear(%{pear_channel}/HttpKernel) >= 2.1.0
-BuildRequires: php-pear(%{pear_channel}/Yaml) >= 2.1.0
+BuildRequires: php-pear(%{pear_channel}/Config) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/HttpKernel) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/Yaml) >= 2.2.0
# Test requires: phpci
BuildRequires: php-dom
BuildRequires: php-libxml
@@ -51,8 +50,8 @@ Requires: php-reflection
Requires: php-spl
Requires: php-tokenizer
# Optional requires
-Requires: php-pear(%{pear_channel}/Config) >= 2.1.0
-Requires: php-pear(%{pear_channel}/Yaml) >= 2.1.0
+Requires: php-pear(%{pear_channel}/Config) >= 2.2.0
+Requires: php-pear(%{pear_channel}/Yaml) >= 2.2.0
# TODO: Add DoctrineCommon (>=2.2,<2.4-dev) when available
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -66,11 +65,6 @@ Optional dependency: DoctrineCommon
%prep
%setup -q -c
-# Patches
-cd %{pear_name}-%{version}
-%patch0 -p0
-cd ..
-
# Modify PEAR package.xml file:
# - Remove .gitignore file
# - Change role from "php" to "doc" for CHANGELOG.md file
@@ -80,7 +74,6 @@ sed -e '/\.gitignore/d' \
-e '/CHANGELOG.md/s/role="php"/role="doc"/' \
-e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
- -e '/bootstrap.php/s/md5sum="[^"]*"\s*//' \
-i package.xml
# package.xml is version 2.0
@@ -102,11 +95,17 @@ rm -rf %{buildroot}%{pear_metadir}/.??*
mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+sed -e '/bootstrap/s:vendor/autoload.php:%{pear_phpdir}/Symfony/Component/%{pear_name}/autoloader.php:' \
+ %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml.dist \
+ > %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml
+
%check
%if %{with_tests}
- cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
- %{_bindir}/phpunit
+cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
+sed -e '/bootstrap/s:vendor/autoload.php:autoloader.php:' \
+ phpunit.xml.dist > phpunit.xml
+%{_bindir}/phpunit -d date.timezone=UTC
%else
: Tests skipped, missing '--with tests' option
%endif
@@ -133,6 +132,9 @@ fi
%changelog
+* Wed Mar 06 2013 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
+- Update to 2.2.0
+
* Wed Feb 27 2013 Remi Collet <remi@fedoraproject.org> - 2.1.8-1
- Update to 2.1.8