summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 13af741..63d3b51 100644
--- a/Makefile
+++ b/Makefile
@@ -2,3 +2,11 @@ SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
include ../../../common/Makefile
+composer:
+ tar xf $(shell spectool -l $(NAME).spec | head -n 1 | sed -e 's:.* ::' | sed -e 's:.*/::') --strip-components=1 '*/composer.json'
+ test -d Cache && mv Cache/composer.json src/Cache && rmdir Cache
+ test -d EventDispatcher && mv EventDispatcher/composer.json src/EventDispatcher && rmdir EventDispatcher
+ test -d HttpClient && mv HttpClient/composer.json src/HttpClient && rmdir HttpClient
+ test -d Service && mv Service/composer.json src/Service && rmdir Service
+ test -d Translation && mv Translation/composer.json src/Translation && rmdir Translation
+