summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile8
-rw-r--r--php-symfony-contracts.spec7
2 files changed, 13 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 13af741..63d3b51 100644
--- a/Makefile
+++ b/Makefile
@@ -2,3 +2,11 @@ SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
include ../../../common/Makefile
+composer:
+ tar xf $(shell spectool -l $(NAME).spec | head -n 1 | sed -e 's:.* ::' | sed -e 's:.*/::') --strip-components=1 '*/composer.json'
+ test -d Cache && mv Cache/composer.json src/Cache && rmdir Cache
+ test -d EventDispatcher && mv EventDispatcher/composer.json src/EventDispatcher && rmdir EventDispatcher
+ test -d HttpClient && mv HttpClient/composer.json src/HttpClient && rmdir HttpClient
+ test -d Service && mv Service/composer.json src/Service && rmdir Service
+ test -d Translation && mv Translation/composer.json src/Translation && rmdir Translation
+
diff --git a/php-symfony-contracts.spec b/php-symfony-contracts.spec
index ca0917a..496df07 100644
--- a/php-symfony-contracts.spec
+++ b/php-symfony-contracts.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit b6e291a08e6b002fb56aa6f3e2a2beb6674d2b2f
+%global gh_commit 2d19b12caccbd80cf0c85624dc87b7021a0df1d5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner symfony
%global gh_project contracts
@@ -21,7 +21,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.1.2
+Version: 1.1.3
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A set of abstractions extracted out of the Symfony
@@ -165,6 +165,9 @@ exit $ret
%changelog
+* Thu Jun 6 2019 Remi Collet <remi@remirepo.net> - 1.1.3-1
+- update to 1.1.3
+
* Mon Jun 3 2019 Remi Collet <remi@remirepo.net> - 1.1.2-1
- update to 1.1.2 (no change)