summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-04 12:17:09 +0200
committerRemi Collet <remi@remirepo.net>2017-09-04 12:17:09 +0200
commitbb75b4f31ad4a479dc1b0eb6beb09f831116b6bb (patch)
treeadd28e3d6b842ad932fd95054667d12ea0e51d6b
parent921540db12178adf5eeb77a9b2d45fa53b46312a (diff)
backport
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json40
-rwxr-xr-xphp-simplesamlphp-saml2_3-get-source.sh4
-rw-r--r--php-simplesamlphp-saml2_3.spec1
5 files changed, 55 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..6046563
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,40 @@
+{
+ "name": "simplesamlphp/saml2",
+ "description": "SAML2 PHP library from SimpleSAMLphp",
+ "license": "LGPL-2.1",
+ "authors": [
+ {
+ "name": "Andreas Åkre Solberg",
+ "email": "andreas.solberg@uninett.no"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.3",
+ "ext-openssl": "*",
+ "ext-dom": "*",
+ "ext-zlib": "*",
+
+ "simplesamlphp/xmlseclibs": "^2.0|^3.0",
+ "psr/log": "~1.0"
+ },
+ "require-dev": {
+ "squizlabs/php_codesniffer": "~1.4",
+ "phpmd/phpmd": "~1.5",
+ "sensiolabs/security-checker": "~1.1",
+ "phpunit/phpunit": "~3.7",
+ "satooshi/php-coveralls": "~0.6.1",
+ "sebastian/phpcpd": "~1.4",
+ "mockery/mockery": "~0.9"
+ },
+ "autoload": {
+ "psr-0": {
+ "SAML2\\": "src/"
+ },
+ "files": ["src/_autoload.php"]
+ },
+ "autoload-dev": {
+ "psr-0": {
+ "SAML2\\": "tests/"
+ }
+ }
+}
diff --git a/php-simplesamlphp-saml2_3-get-source.sh b/php-simplesamlphp-saml2_3-get-source.sh
index ba71f5d..4ad1051 100755
--- a/php-simplesamlphp-saml2_3-get-source.sh
+++ b/php-simplesamlphp-saml2_3-get-source.sh
@@ -43,6 +43,8 @@ print "GIT_REPO = $GIT_REPO"
print "GIT_DIR = $GIT_DIR"
TEMP_DIR=$(mktemp --dir)
+TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+CMP_FILE=$PWD/composer.json
pushd $TEMP_DIR
print "Cloning git repo..."
@@ -51,6 +53,7 @@ pushd $TEMP_DIR
pushd $GIT_DIR
print "Checking out commit..."
$GIT checkout $GIT_COMMIT
+ cp composer.json $CMP_FILE
popd
TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
@@ -58,7 +61,6 @@ pushd $TEMP_DIR
mv $GIT_DIR $TAR_DIR
- TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
print "TAR_FILE = $TAR_FILE"
[ -e $TAR_FILE ] && rm -f $TAR_FILE
diff --git a/php-simplesamlphp-saml2_3.spec b/php-simplesamlphp-saml2_3.spec
index e90f0b8..42b4bad 100644
--- a/php-simplesamlphp-saml2_3.spec
+++ b/php-simplesamlphp-saml2_3.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-simplesamlphp-saml2_3
#
# Fedora spec file for php-simplesamlphp-saml2_3
#