summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-04 12:14:38 +0200
committerRemi Collet <remi@remirepo.net>2017-09-04 12:14:38 +0200
commit921540db12178adf5eeb77a9b2d45fa53b46312a (patch)
tree70ef45a61119b1597329493d45319297e5591def
import from Fedora
-rwxr-xr-xphp-simplesamlphp-saml2_3-get-source.sh69
-rw-r--r--php-simplesamlphp-saml2_3.spec191
2 files changed, 260 insertions, 0 deletions
diff --git a/php-simplesamlphp-saml2_3-get-source.sh b/php-simplesamlphp-saml2_3-get-source.sh
new file mode 100755
index 0000000..ba71f5d
--- /dev/null
+++ b/php-simplesamlphp-saml2_3-get-source.sh
@@ -0,0 +1,69 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-simplesamlphp-saml2_3.spec b/php-simplesamlphp-saml2_3.spec
new file mode 100644
index 0000000..e90f0b8
--- /dev/null
+++ b/php-simplesamlphp-saml2_3.spec
@@ -0,0 +1,191 @@
+#
+# Fedora spec file for php-simplesamlphp-saml2_3
+#
+# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve the changelog entries
+#
+
+%global github_owner simplesamlphp
+%global github_name saml2
+%global github_version 3.0.2
+%global github_commit bacad25473258cfefb7a7fd418cc5f8a22cda0a1
+
+%global composer_vendor simplesamlphp
+%global composer_project saml2
+
+# "php": ">=5.3.3"
+%global php_min_ver 5.3.3
+# "mockery/mockery": "~0.9"
+%global mockery_min_ver 0.9
+%global mockery_max_ver 1.0
+# "psr/log": "~1.0"
+# NOTE: Min version not 1.0 because autoloader required
+%global psr_log_min_ver 1.0.1
+%global psr_log_max_ver 2.0
+# "simplesamlphp/xmlseclibs": "^2.0|^3.0"
+#
+# https://github.com/simplesamlphp/xmlseclibs
+# Micro-fork of xmlseclibs, sole difference is restore of PHP 5.4 compatibility
+#
+# Using robrichards/xmlseclibs instead of simplesamlphp/xmlseclibs because
+# they use the same namespace, the only difference is PHP version compatibility,
+# and tests pass.
+#
+# NOTE: Min version not 2.0 to force version 3.0 and remove build dependency php-mcrypt
+%global xmlseclibs_min_ver 3.0
+%global xmlseclibs_max_ver 4.0
+
+# Build using "--without tests" to disable tests
+%global with_tests 0%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_vendor}-%{composer_project}_3
+Version: %{github_version}
+Release: 3%{?github_release}%{?dist}
+Summary: SAML2 PHP library from SimpleSAMLphp (version 3)
+
+Group: Development/Libraries
+License: LGPLv2
+URL: https://github.com/%{github_owner}/%{github_name}
+
+# GitHub export does not include tests.
+# Run php-simplesamlphp-saml2_3-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(mockery/mockery) < %{mockery_max_ver}
+BuildRequires: php-composer(mockery/mockery) >= %{mockery_min_ver}
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php-composer(psr/log) < %{psr_log_max_ver}
+BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
+BuildRequires: php-composer(robrichards/xmlseclibs) < %{xmlseclibs_max_ver}
+BuildRequires: php-composer(robrichards/xmlseclibs) >= %{xmlseclibs_min_ver}
+BuildRequires: php-dom
+BuildRequires: php-openssl
+BuildRequires: php-zlib
+## phpcompatinfo (computed from version 3.0.2)
+BuildRequires: php-date
+BuildRequires: php-libxml
+BuildRequires: php-pcre
+BuildRequires: php-soap
+BuildRequires: php-spl
+%endif
+## Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+Requires: php-composer(psr/log) < %{psr_log_max_ver}
+Requires: php-composer(psr/log) >= %{psr_log_min_ver}
+Requires: php-composer(robrichards/xmlseclibs) < %{xmlseclibs_max_ver}
+Requires: php-composer(robrichards/xmlseclibs) >= %{xmlseclibs_min_ver}
+Requires: php-dom
+Requires: php-openssl
+Requires: php-zlib
+# phpcompatinfo (computed from version 3.0.2)
+Requires: php-date
+Requires: php-libxml
+Requires: php-pcre
+Requires: php-soap
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+
+%description
+A PHP library for SAML2 related functionality. Extracted from SimpleSAMLphp [1],
+used by OpenConext [2]. This library started as a collaboration between
+UNINETT [3] and SURFnet [4] but everyone is invited to contribute.
+
+Autoloader: %{phpdir}/SAML2_3/autoload.php
+
+[1] https://www.simplesamlphp.org/
+[2] https://www.openconext.org/
+[3] https://www.uninett.no/
+[4] https://www.surfnet.nl/
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+: Create autoloader
+%{_bindir}/phpab --template fedora --output src/SAML2/autoload.php src/SAML2
+cat <<'AUTOLOAD' >> src/SAML2/autoload.php
+
+class_alias('\\SAML2\\Constants', 'SAML2_Const');
+
+\Fedora\Autoloader\Dependencies::required(array(
+ '%{phpdir}/Psr/Log/autoload.php',
+ '%{phpdir}/RobRichards/XMLSecLibs3/autoload.php',
+));
+AUTOLOAD
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}
+cp -rp src/SAML2 %{buildroot}%{phpdir}/SAML2_3
+
+
+%check
+%if %{with_tests}
+: Create pseudo Composer autoloader
+mkdir vendor
+%{_bindir}/phpab --template fedora --output vendor/autoload.php tests
+cat <<'AUTOLOAD' | tee -a vendor/autoload.php
+require_once '%{buildroot}%{phpdir}/SAML2_3/autoload.php';
+require_once '%{phpdir}/Mockery/autoload.php';
+AUTOLOAD
+
+: Skip test known to fail
+sed 's/function testToString/function SKIP_testToString/' \
+ -i tests/SAML2/XML/saml/NameIDTest.php
+
+: Upstream tests
+RETURN_CODE=0
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
+ if [ "php" = "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --configuration=tools/phpunit --verbose || RETURN_CODE=1
+ fi
+done
+exit $RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{phpdir}/SAML2_3
+
+
+%changelog
+* Wed Aug 30 2017 Shawn Iwinski <shawn@iwin.ski> - 3.0.2-3
+- Drop support for simplesamlphp/xmlseclibs v2
+
+* Tue Aug 22 2017 Shawn Iwinski <shawn@iwin.ski> - 3.0.2-2
+- Build require mcrypt for robrichards/xmlseclibs version 2
+
+* Sun Aug 20 2017 Shawn Iwinski <shawn@iwin.ski> - 3.0.2-1
+- Update to 3.0.2
+
+* Wed Jul 12 2017 Shawn Iwinski <shawn@iwin.ski> - 3.0.0-1
+- Initial package