summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-16 06:46:30 +0100
committerRemi Collet <remi@remirepo.net>2020-12-16 06:46:30 +0100
commit30eff58807838d9670fbff41530ec2af51bf61e4 (patch)
tree17bddaf0b4e6fa8bf81ea6645a1f043748191a4c
parent776f5c735ad18e9eb7b866b071209acef594e506 (diff)
update to 1.0.4HEADmaster
-rw-r--r--.gitignore9
-rw-r--r--composer.json9
-rw-r--r--php-seld-cli-prompt.spec23
3 files changed, 27 insertions, 14 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index e366437..fa1d0d3 100644
--- a/composer.json
+++ b/composer.json
@@ -22,5 +22,14 @@
"branch-alias": {
"dev-master": "1.x-dev"
}
+ },
+ "require-dev": {
+ "phpstan/phpstan": "^0.12.63"
+ },
+ "scripts": {
+ "phpstan": "vendor/bin/phpstan analyse"
+ },
+ "config": {
+ "lock": false
}
}
diff --git a/php-seld-cli-prompt.spec b/php-seld-cli-prompt.spec
index b0168b2..de34438 100644
--- a/php-seld-cli-prompt.spec
+++ b/php-seld-cli-prompt.spec
@@ -1,30 +1,28 @@
# remirepo/fedora spec file for php-seld-cli-prompt
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit a19a7376a4689d4d94cab66ab4f3c816019ba8dd
+%global gh_commit b8dfcf02094b8c03b40322c229493bb2884423c5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Seldaek
%global gh_project cli-prompt
Name: php-seld-cli-prompt
-Version: 1.0.3
+Version: 1.0.4
Release: 1%{?dist}
Summary: Allows you to prompt for user input on the command line
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
# Autoloader
Source1: %{gh_project}-autoload.php
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3
# For test
@@ -50,8 +48,7 @@ need to prompt for sensitive information. In these cases, the characters typed
in by the user should not be directly visible, and this is quite a pain to do
in a cross-platform way.
-To use this library, you just have to add, in your project:
- require_once '%{_datadir}/php/Seld/CliPrompt/autoload.php';
+Autoloader: %{_datadir}/php/Seld/CliPrompt/autoload.php
%prep
@@ -65,7 +62,6 @@ cp %{SOURCE1} src/autoload.php
%install
-rm -rf %{buildroot}
# Restore PSR-0 tree
mkdir -p %{buildroot}%{_datadir}/php/Seld/CliPrompt
cp -pr src/* %{buildroot}%{_datadir}/php/Seld/CliPrompt/
@@ -81,12 +77,8 @@ exit(0);
'
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md composer.json res/example.php
@@ -94,6 +86,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Dec 16 2020 Remi Collet <remi@remirepo.net> - 1.0.4-1
+- update to 1.0.4
+
* Mon Mar 20 2017 Remi Collet <remi@remirepo.net> - 1.0.3-1
- Update to 1.0.3