summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-28 11:30:22 +0200
committerRemi Collet <remi@remirepo.net>2020-09-28 11:30:22 +0200
commit585cae1d931f877858bee945144f681f7d7cef04 (patch)
tree6561a296bca3dc3bbc792a8f13092a7029a51403
parent571080115f3a7daf75d4b64f04fd3b40ba848c97 (diff)
update to 1.0.1
-rw-r--r--composer.json4
-rw-r--r--php-sebastian-lines-of-code.spec20
2 files changed, 12 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 87f39ca..95bb9e3 100644
--- a/composer.json
+++ b/composer.json
@@ -16,11 +16,11 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.3 || ^8.0",
+ "php": ">=7.3",
"nikic/php-parser": "^4.6"
},
"require-dev": {
- "phpunit/phpunit": "^9.2"
+ "phpunit/phpunit": "^9.3"
},
"config": {
"platform": {
diff --git a/php-sebastian-lines-of-code.spec b/php-sebastian-lines-of-code.spec
index e0bd659..88f3465 100644
--- a/php-sebastian-lines-of-code.spec
+++ b/php-sebastian-lines-of-code.spec
@@ -6,14 +6,11 @@
#
# Please, preserve the changelog entries
#
-%bcond_with bootstrap
-%if %{with bootstrap}
-%bcond_with tests
-%else
+
%bcond_without tests
-%endif
+
# github
-%global gh_commit e02bf626f404b5daec382a7b8a6a4456e49017e5
+%global gh_commit 6514b8f21906b8b46f520d1fbd17a4523fa59a54
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project lines-of-code
@@ -27,7 +24,7 @@
%global ns_project LinesOfCode
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.0.0
+Version: 1.0.1
Release: 1%{?dist}
Summary: Counting the lines of code in PHP source code
@@ -51,12 +48,12 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.2"
-BuildRequires: phpunit9 >= 9.2
+# "phpunit/phpunit": "^9.3"
+BuildRequires: phpunit9 >= 9.3
%endif
# from composer.json, "require": {
-# "php": "^7.3 || ^8.0",
+# "php": ">=7.3",
# "nikic/php-parser": "^4.6"
Requires: php(language) >= 7.3
# remirepo:1
@@ -128,5 +125,8 @@ exit $ret
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- update to 1.0.1
+
* Mon Aug 10 2020 Remi Collet <remi@remirepo.net> - 1.0.0-1
- initial package