summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-10 14:53:53 +0200
committerRemi Collet <remi@remirepo.net>2020-08-10 14:53:53 +0200
commit571080115f3a7daf75d4b64f04fd3b40ba848c97 (patch)
treed83eaee4ec672a42fb31e9f15513df677bfe1996
new package
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json42
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-sebastian-lines-of-code.spec132
5 files changed, 214 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..87f39ca
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,42 @@
+{
+ "name": "sebastian/lines-of-code",
+ "description": "Library for counting the lines of code in PHP source code",
+ "type": "library",
+ "homepage": "https://github.com/sebastianbergmann/lines-of-code",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de",
+ "role": "lead"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/lines-of-code/issues"
+ },
+ "prefer-stable": true,
+ "require": {
+ "php": "^7.3 || ^8.0",
+ "nikic/php-parser": "^4.6"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^9.2"
+ },
+ "config": {
+ "platform": {
+ "php": "7.3.0"
+ },
+ "optimize-autoloader": true,
+ "sort-packages": true
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0-dev"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..4190c13
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-sebastian-lines-of-code.spec b/php-sebastian-lines-of-code.spec
new file mode 100644
index 0000000..e0bd659
--- /dev/null
+++ b/php-sebastian-lines-of-code.spec
@@ -0,0 +1,132 @@
+# remirepo/fedora spec file for php-sebastian-lines-of-code
+#
+# Copyright (c) 2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%bcond_with bootstrap
+%if %{with bootstrap}
+%bcond_with tests
+%else
+%bcond_without tests
+%endif
+# github
+%global gh_commit e02bf626f404b5daec382a7b8a6a4456e49017e5
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sebastianbergmann
+%global gh_project lines-of-code
+# packagist
+%global pk_vendor sebastian
+%global pk_project %{gh_project}
+%global major %nil
+# namespace
+%global php_home %{_datadir}/php
+%global ns_vendor SebastianBergmann
+%global ns_project LinesOfCode
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Counting the lines of code in PHP source code
+
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+# git snapshot to retrieve test suite
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+BuildRequires: php(language) >= 7.3
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(nikic/php-parser) >= 4.6 with php-composer(nikic/php-parser) < 5)
+# remirepo:3
+%else
+BuildRequires: php-nikic-php-parser4 >= 4.6
+%endif
+BuildRequires: php-spl
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel >= 1.0.0
+%if %{with tests}
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "^9.2"
+BuildRequires: phpunit9 >= 9.2
+%endif
+
+# from composer.json, "require": {
+# "php": "^7.3 || ^8.0",
+# "nikic/php-parser": "^4.6"
+Requires: php(language) >= 7.3
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(nikic/php-parser) >= 4.6 with php-composer(nikic/php-parser) < 5)
+# remirepo:3
+%else
+Requires: php-nikic-php-parser4 >= 4.6
+%endif
+# from phpcompatinfo report for version 1.0.0
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Library for counting the lines of code in PHP source code.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Generate the Autoloader
+phpab --template fedora --output src/autoload.php src
+
+cat <<EOF | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/PhpParser4/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with tests}
+mkdir vendor
+touch vendor/autoload.php
+
+: Run upstream test suite
+ret=0
+for cmd in php php73 php74 php80; do
+ if which $cmd; then
+ $cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
+ %{_bindir}/phpunit9 --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Mon Aug 10 2020 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package