summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-23 14:25:51 +0200
committerRemi Collet <remi@php.net>2023-08-23 14:25:51 +0200
commit3eac4073cfd1b77f496750fb8995cb16d26d5fce (patch)
treef25fd519a18f7050c17888b5471727880a51a31f
parent4727810387005869d9b1838493a5fff5b71dc190 (diff)
Enable test suite
-rw-r--r--php-sebastian-complexity3.spec16
1 files changed, 11 insertions, 5 deletions
diff --git a/php-sebastian-complexity3.spec b/php-sebastian-complexity3.spec
index d75120f..8357afc 100644
--- a/php-sebastian-complexity3.spec
+++ b/php-sebastian-complexity3.spec
@@ -7,8 +7,7 @@
# Please, preserve the changelog entries
#
-# disabled until phpunit10 available
-%bcond_with tests
+%bcond_without tests
# github
%global gh_commit e67d240970c9dc7ea7b2123a6d520e334dd61dc6
@@ -26,8 +25,8 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 3.0.0
-Release: 1%{?dist}
-Summary: Calculating the complexity of PHP code units
+Release: 3%{?dist}
+Summary: Calculating the complexity of PHP code units, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -74,6 +73,10 @@ Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
%description
Library for calculating the complexity of PHP code units.
+This package provides version %{major} of %{pk_vendor}/%{pk_project} library.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
@@ -102,7 +105,7 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php81 php82; do
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit10 || ret=1
@@ -125,6 +128,9 @@ exit $ret
%changelog
+* Wed Aug 23 2023 Remi Collet <remi@remirepo.net> - 3.0.0-3
+- Enable test suite
+
* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 3.0.0-1
- update to 3.0.0
- raise dependency on PHP 8.1