summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-code-coverage10.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-07 14:58:03 +0100
committerRemi Collet <remi@php.net>2023-02-07 14:58:03 +0100
commit7d8c8a5aab415d08387a0753fe58758114fb95d0 (patch)
treec58b39edf1ec452e477b03dab65ed254e773512d /php-phpunit-php-code-coverage10.spec
parent31ab3925ffd11d52a59240057436a9268ebd23a0 (diff)
cleanup
Diffstat (limited to 'php-phpunit-php-code-coverage10.spec')
-rw-r--r--php-phpunit-php-code-coverage10.spec5
1 files changed, 4 insertions, 1 deletions
diff --git a/php-phpunit-php-code-coverage10.spec b/php-phpunit-php-code-coverage10.spec
index f59e33b..29716d1 100644
--- a/php-phpunit-php-code-coverage10.spec
+++ b/php-phpunit-php-code-coverage10.spec
@@ -197,12 +197,15 @@ define('TEST_FILES_PATH', __DIR__ . '/_files/');
EOF
ret=0
+# testCanBeCreatedFromDefaults rely on git layout
+
for cmd in php php81 php82; do
if which $cmd; then
$cmd $EXT \
-d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}/autoload.php \
%{_bindir}/phpunit10 \
- --verbose || ret=1
+ --filter "^((?!(testCanBeCreatedFromDefaults)).)*$" \
+ || ret=1
fi
done
exit $ret