summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-phpunit-php-code-coverage10.spec5
1 files changed, 4 insertions, 1 deletions
diff --git a/php-phpunit-php-code-coverage10.spec b/php-phpunit-php-code-coverage10.spec
index f59e33b..29716d1 100644
--- a/php-phpunit-php-code-coverage10.spec
+++ b/php-phpunit-php-code-coverage10.spec
@@ -197,12 +197,15 @@ define('TEST_FILES_PATH', __DIR__ . '/_files/');
EOF
ret=0
+# testCanBeCreatedFromDefaults rely on git layout
+
for cmd in php php81 php82; do
if which $cmd; then
$cmd $EXT \
-d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}/autoload.php \
%{_bindir}/phpunit10 \
- --verbose || ret=1
+ --filter "^((?!(testCanBeCreatedFromDefaults)).)*$" \
+ || ret=1
fi
done
exit $ret