summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-11 14:35:56 +0200
committerRemi Collet <remi@remirepo.net>2020-05-11 14:35:56 +0200
commit4ca2120ed076e159f0385c62c38889bdbd0763f9 (patch)
treeac3eabaad4f44d923cdccc2931384e05d6b815a2
parent232b1b425ee3d0285704b9bd6db530914049962e (diff)
update to 2.2.1
-rw-r--r--composer.json20
-rw-r--r--php-sabre-xml2.spec15
2 files changed, 26 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 2af0dd4..40abe14 100644
--- a/composer.json
+++ b/composer.json
@@ -45,9 +45,23 @@
},
"require-dev": {
"friendsofphp/php-cs-fixer": "~2.16.1",
- "phpunit/phpunit" : "^7 || ^8"
+ "phpstan/phpstan": "^0.12",
+ "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0"
},
- "config" : {
- "bin-dir" : "bin/"
+ "scripts": {
+ "phpstan": [
+ "phpstan analyse lib tests"
+ ],
+ "cs-fixer": [
+ "php-cs-fixer fix"
+ ],
+ "phpunit": [
+ "phpunit --configuration tests/phpunit.xml"
+ ],
+ "test": [
+ "composer phpstan",
+ "composer cs-fixer",
+ "composer phpunit"
+ ]
}
}
diff --git a/php-sabre-xml2.spec b/php-sabre-xml2.spec
index 1808f3b..37dcf1c 100644
--- a/php-sabre-xml2.spec
+++ b/php-sabre-xml2.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# Github
-%global gh_commit 705f5cbf7f4fb1e3dd47173e3f026892818c8d46
+%global gh_commit 41c6ba148966b10cafd31d1a4e5feb1e2138d95c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project xml
@@ -22,7 +22,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: XML library that you may not hate
-Version: 2.2.0
+Version: 2.2.1
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -48,9 +48,9 @@ BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "friendsofphp/php-cs-fixer": "~2.16.1",
-# "phpunit/phpunit" : "^7 || ^8"
-BuildRequires: phpunit8
+# "phpstan/phpstan": "^0.12",
+# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0"
+BuildRequires: phpunit8 >= 8.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -134,7 +134,7 @@ cd tests
: Run upstream test suite against installed library
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd %{_bindir}/phpunit8 || ret=1
fi
@@ -155,6 +155,9 @@ exit $ret
%changelog
+* Mon May 11 2020 Remi Collet <remi@remirepo.net> - 2.2.1-1
+- update to 2.2.1
+
* Sat Feb 1 2020 Remi Collet <remi@remirepo.net> - 2.2.0-1
- update to 2.2.0
- raise dependency on PHP 7.1