summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-01 07:52:42 +0100
committerRemi Collet <remi@remirepo.net>2020-02-01 07:52:42 +0100
commit232b1b425ee3d0285704b9bd6db530914049962e (patch)
treec825d1a1c659b667178296d642db39a195802fc9
parent41f1320a00ccd7c85d8a7cce6e6f3f2ce161d9dd (diff)
update to 2.2.0
raise dependency on PHP 7.1 switch to phpunit8
-rw-r--r--composer.json5
-rw-r--r--php-sabre-xml2.spec26
2 files changed, 19 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index c782dbc..2af0dd4 100644
--- a/composer.json
+++ b/composer.json
@@ -5,7 +5,7 @@
"homepage" : "https://sabre.io/xml/",
"license" : "BSD-3-Clause",
"require" : {
- "php" : ">=7.0",
+ "php" : "^7.1",
"ext-xmlwriter" : "*",
"ext-xmlreader" : "*",
"ext-dom" : "*",
@@ -44,7 +44,8 @@
}
},
"require-dev": {
- "phpunit/phpunit" : "^6"
+ "friendsofphp/php-cs-fixer": "~2.16.1",
+ "phpunit/phpunit" : "^7 || ^8"
},
"config" : {
"bin-dir" : "bin/"
diff --git a/php-sabre-xml2.spec b/php-sabre-xml2.spec
index 8ff8234..1808f3b 100644
--- a/php-sabre-xml2.spec
+++ b/php-sabre-xml2.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-sabre-xml2
#
-# Copyright (c) 2016-2019 Remi Collet
+# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
# Github
-%global gh_commit f08a58f57e2b0d7df769a432756aa371417ab9eb
+%global gh_commit 705f5cbf7f4fb1e3dd47173e3f026892818c8d46
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project xml
@@ -22,7 +22,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: XML library that you may not hate
-Version: 2.1.3
+Version: 2.2.0
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -33,7 +33,7 @@ Source1: makesrc.sh
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php(language) >= 7.0
+BuildRequires: php(language) >= 7.1
BuildRequires: php-xmlwriter
BuildRequires: php-xmlreader
BuildRequires: php-dom
@@ -48,20 +48,21 @@ BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit" : "^6"
-BuildRequires: phpunit6
+# "friendsofphp/php-cs-fixer": "~2.16.1",
+# "phpunit/phpunit" : "^7 || ^8"
+BuildRequires: phpunit8
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require" : {
-# "php" : ">=7.0",
+# "php" : "^7.1",
# "ext-xmlwriter" : "*",
# "ext-xmlreader" : "*",
# "ext-dom" : "*",
# "lib-libxml" : ">=2.6.20",
# "sabre/uri" : ">=1.0,<3.0.0"
-Requires: php(language) >= 7.0
+Requires: php(language) >= 7.1
Requires: php-xmlwriter
Requires: php-xmlreader
Requires: php-dom
@@ -133,9 +134,9 @@ cd tests
: Run upstream test suite against installed library
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 || ret=1
+ $cmd %{_bindir}/phpunit8 || ret=1
fi
done
exit $ret
@@ -154,6 +155,11 @@ exit $ret
%changelog
+* Sat Feb 1 2020 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+- raise dependency on PHP 7.1
+- switch to phpunit8
+
* Mon Aug 19 2019 Remi Collet <remi@remirepo.net> - 2.1.3-1
- update to 2.1.3