summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-14 07:46:38 +0200
committerRemi Collet <remi@remirepo.net>2020-07-14 07:46:38 +0200
commitaacba7b7358b3e1d2c67b13689741de1e58f516d (patch)
treefdc93fda615d962ab9f3b4f676ef94e77150cdeb
parent362f3891a697ff58a7160abaf19c38474f471408 (diff)
update to 4.1.1
-rw-r--r--composer.json2
-rw-r--r--php-sabre-dav4.spec19
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index f0fbf7a..d4190ae 100644
--- a/composer.json
+++ b/composer.json
@@ -33,7 +33,7 @@
"ext-json": "*"
},
"require-dev" : {
- "friendsofphp/php-cs-fixer": "~2.16.1",
+ "friendsofphp/php-cs-fixer": "^2.16.3",
"phpstan/phpstan": "^0.12",
"phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0",
"evert/phpdoc-md" : "~0.1.0",
diff --git a/php-sabre-dav4.spec b/php-sabre-dav4.spec
index 25efa3b..5144fb8 100644
--- a/php-sabre-dav4.spec
+++ b/php-sabre-dav4.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# Github
-%global gh_commit 8f6f4d272504ee8424e1d0a47d6efc7772de2270
+%global gh_commit 5736f943c90d8d73d04cd8944d8c913811dc7360
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project dav
@@ -18,11 +18,11 @@
%global ns_vendor Sabre
%global ns_project DAV
%global major 4
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: WebDAV Framework for PHP
-Version: 4.1.0
+Version: 4.1.1
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -35,7 +35,7 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
Patch0: %{name}-autoload.patch
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
BuildRequires: php(language) >= 7.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -76,7 +76,7 @@ BuildRequires: php-json
# "evert/phpdoc-md" : "~0.1.0",
# "squizlabs/php_codesniffer": "~1.5.3"
# "monolog/monolog": "^1.18"
-BuildRequires: phpunit7 >= 7.5
+BuildRequires: phpunit8 >= 8.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -206,7 +206,7 @@ cp -pr lib %{buildroot}%{_datadir}/php/%{ns_vendor}
%check
-%if %{with_tests}
+%if %{with tests}
: Fix bootstrap
cd tests
sed -e 's:@BUILDROOT@:%{buildroot}:' -i bootstrap.php
@@ -215,9 +215,9 @@ sed -e 's:@BUILDROOT@:%{buildroot}:' -i bootstrap.php
: Run upstream test suite against installed library
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit7 \
+ $cmd %{_bindir}/phpunit8 \
--filter '^((?!(testDeliverInsignificantRequest)).)*$' \
|| ret=1
fi
@@ -242,6 +242,9 @@ exit $ret
%changelog
+* Tue Jul 14 2020 Remi Collet <remi@remirepo.net> - 4.1.1-1
+- update to 4.1.1
+
* Fri Mar 20 2020 Remi Collet <remi@remirepo.net> - 4.1.0-1
- update to 4.1.0
- raise dependency on PHP 7.1