summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-20 16:50:57 +0100
committerRemi Collet <remi@remirepo.net>2020-03-20 16:50:57 +0100
commit362f3891a697ff58a7160abaf19c38474f471408 (patch)
tree6bb659a1cca12f81bbf6a45457560e9b2ceb4d32
parent008e0997591872de01f73b5a525303c301ab6a53 (diff)
update to 4.1.0HEADmaster
raise dependency on PHP 7.1 raise dependency on sabre/vobject 4.2.1 raise dependency on sabre/http 5.0.5 switch to phpunit7
-rw-r--r--composer.json38
-rw-r--r--php-sabre-dav4.spec47
2 files changed, 60 insertions, 25 deletions
diff --git a/composer.json b/composer.json
index 226b2cb..f0fbf7a 100644
--- a/composer.json
+++ b/composer.json
@@ -14,11 +14,11 @@
}
],
"require": {
- "php": ">=7.0.0",
- "sabre/vobject": "^4.2.0-alpha1",
+ "php": "^7.1.0",
+ "sabre/vobject": "^4.2.1",
"sabre/event" : "^5.0",
"sabre/xml" : "^2.0.1",
- "sabre/http" : "^5.0",
+ "sabre/http" : "^5.0.5",
"sabre/uri" : "^2.0",
"ext-dom": "*",
"ext-pcre": "*",
@@ -33,7 +33,9 @@
"ext-json": "*"
},
"require-dev" : {
- "phpunit/phpunit" : "^6",
+ "friendsofphp/php-cs-fixer": "~2.16.1",
+ "phpstan/phpstan": "^0.12",
+ "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0",
"evert/phpdoc-md" : "~0.1.0",
"monolog/monolog": "^1.18"
},
@@ -50,6 +52,17 @@
"Sabre\\CardDAV\\" : "lib/CardDAV/"
}
},
+ "autoload-dev" : {
+ "psr-4" : {
+ "Sabre\\" : "tests/Sabre/",
+ "Sabre\\CalDAV\\" : "tests/Sabre/CalDAV",
+ "Sabre\\CardDAV\\" : "tests/Sabre/CardDAV",
+ "Sabre\\DAV\\" : "tests/Sabre/DAV",
+ "Sabre\\DAV\\Property\\" : "tests/Sabre/DAV/Xml/Property",
+ "Sabre\\DAVACL\\" : "tests/Sabre/DAVACL",
+ "Sabre\\HTTP\\" : "tests/Sabre/HTTP"
+ }
+ },
"support" : {
"forum" : "https://groups.google.com/group/sabredav-discuss",
"source" : "https://github.com/fruux/sabre-dav"
@@ -58,7 +71,20 @@
"bin/sabredav",
"bin/naturalselection"
],
- "config" : {
- "bin-dir" : "./bin"
+ "scripts": {
+ "phpstan": [
+ "phpstan analyse lib tests"
+ ],
+ "cs-fixer": [
+ "php-cs-fixer fix"
+ ],
+ "phpunit": [
+ "phpunit --configuration tests/phpunit.xml"
+ ],
+ "test": [
+ "composer phpstan",
+ "composer cs-fixer",
+ "composer phpunit"
+ ]
}
}
diff --git a/php-sabre-dav4.spec b/php-sabre-dav4.spec
index db2738f..25efa3b 100644
--- a/php-sabre-dav4.spec
+++ b/php-sabre-dav4.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# Github
-%global gh_commit b793fb4ce27cf0f981b540ad771281c430ffe818
+%global gh_commit 8f6f4d272504ee8424e1d0a47d6efc7772de2270
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project dav
@@ -22,7 +22,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: WebDAV Framework for PHP
-Version: 4.0.3
+Version: 4.1.0
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -36,21 +36,21 @@ Patch0: %{name}-autoload.patch
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php(language) >= 7.0
+BuildRequires: php(language) >= 7.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(sabre/vobject) >= 4.2 with php-composer(sabre/vobject) < 5)
+BuildRequires: (php-composer(sabre/vobject) >= 4.2.1 with php-composer(sabre/vobject) < 5)
BuildRequires: (php-composer(sabre/event) >= 5.0 with php-composer(sabre/event) < 6)
BuildRequires: (php-composer(sabre/xml) >= 2.0.1 with php-composer(sabre/xml) < 3)
-BuildRequires: (php-composer(sabre/http) >= 5.0 with php-composer(sabre/http) < 6)
+BuildRequires: (php-composer(sabre/http) >= 5.0.5 with php-composer(sabre/http) < 6)
BuildRequires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 3)
BuildRequires: (php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 2)
BuildRequires: (php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 2)
BuildRequires: (php-composer(monolog/monolog) >= 1.18 with php-composer(monolog/monolog) < 2)
# remirepo:9
%else
-BuildRequires: php-sabre-vobject4 >= 4.2
-BuildRequires: php-sabre-event5 >= 5.0
+BuildRequires: php-sabre-vobject4 >= 4.2.1
+BuildRequires: php-sabre-event5 >= 5.0.5
BuildRequires: php-sabre-xml2 >= 2.0.1
BuildRequires: php-sabre-http5 >= 5.0
BuildRequires: php-sabre-uri2 >= 2.0
@@ -70,22 +70,24 @@ BuildRequires: php-curl
BuildRequires: php-pdo
BuildRequires: php-json
# From composer.json, "require-dev" : {
-# "phpunit/phpunit" : "^6",
+# "friendsofphp/php-cs-fixer": "~2.16.1",
+# "phpstan/phpstan": "^0.12",
+# "phpunit/phpunit" : "^7.5 || ^8.5 || ^9.0",
# "evert/phpdoc-md" : "~0.1.0",
# "squizlabs/php_codesniffer": "~1.5.3"
# "monolog/monolog": "^1.18"
-BuildRequires: phpunit6
+BuildRequires: phpunit7 >= 7.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
BuildRequires: php-pdo_sqlite
# From composer.json, "require": {
-# "php": ">=7.0.0",
-# "sabre/vobject": "^4.2.0-alpha1",
+# "php": ">=7.1.0",
+# "sabre/vobject": "^4.2.1",
# "sabre/event" : "^5.0",
# "sabre/xml" : "^2.0.1",
-# "sabre/http" : "^5.0",
+# "sabre/http" : "^5.0.5",
# "sabre/uri" : "^2.0",
# "ext-dom": "*",
# "ext-pcre": "*",
@@ -98,19 +100,19 @@ BuildRequires: php-pdo_sqlite
# "lib-libxml" : ">=2.7.0",
# "psr/log": "^1.0",
# "ext-json": "*"
-Requires: php(language) >= 7.0
+Requires: php(language) >= 7.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(sabre/vobject) >= 4.2 with php-composer(sabre/vobject) < 5)
+Requires: (php-composer(sabre/vobject) >= 4.2.1 with php-composer(sabre/vobject) < 5)
Requires: (php-composer(sabre/event) >= 5.0 with php-composer(sabre/event) < 6)
Requires: (php-composer(sabre/xml) >= 2.0.1 with php-composer(sabre/xml) < 3)
-Requires: (php-composer(sabre/http) >= 5.0.0 with php-composer(sabre/http) < 6)
+Requires: (php-composer(sabre/http) >= 5.0.5 with php-composer(sabre/http) < 6)
Requires: (php-composer(sabre/uri) >= 2.0 with php-composer(sabre/uri) < 3)
Requires: (php-composer(psr/log) >= 1.0.1 with php-composer(psr/log) < 2)
# remirepo:8
%else
-Requires: php-sabre-vobject4 >= 4.2
-Requires: php-sabre-event5 >= 5.0
+Requires: php-sabre-vobject4 >= 4.2.1
+Requires: php-sabre-event5 >= 5.0.5
Requires: php-sabre-xml2 >= 2.0.1
Requires: php-sabre-http5 >= 5.0
Requires: php-sabre-uri2 >= 2.0
@@ -213,9 +215,9 @@ sed -e 's:@BUILDROOT@:%{buildroot}:' -i bootstrap.php
: Run upstream test suite against installed library
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 \
+ $cmd %{_bindir}/phpunit7 \
--filter '^((?!(testDeliverInsignificantRequest)).)*$' \
|| ret=1
fi
@@ -240,6 +242,13 @@ exit $ret
%changelog
+* Fri Mar 20 2020 Remi Collet <remi@remirepo.net> - 4.1.0-1
+- update to 4.1.0
+- raise dependency on PHP 7.1
+- raise dependency on sabre/vobject 4.2.1
+- raise dependency on sabre/http 5.0.5
+- switch to phpunit7
+
* Fri Jan 10 2020 Remi Collet <remi@remirepo.net> - 4.0.3-1
- update to 4.0.3