summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-05 10:35:03 +0200
committerRemi Collet <remi@remirepo.net>2020-10-05 10:35:03 +0200
commit4b1d24fb87eee3bac18dfd18c5a4cd5018484a4d (patch)
tree1bc35285a6cd499f3e33921b973a83e6b6344ced
parentaacba7b7358b3e1d2c67b13689741de1e58f516d (diff)
update to 4.1.2
switch to phpunit9
-rw-r--r--composer.json2
-rw-r--r--php-sabre-dav4.spec29
2 files changed, 22 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index d4190ae..ec623f2 100644
--- a/composer.json
+++ b/composer.json
@@ -14,7 +14,7 @@
}
],
"require": {
- "php": "^7.1.0",
+ "php": "^7.1.0 || ^8.0",
"sabre/vobject": "^4.2.1",
"sabre/event" : "^5.0",
"sabre/xml" : "^2.0.1",
diff --git a/php-sabre-dav4.spec b/php-sabre-dav4.spec
index 5144fb8..67f17a9 100644
--- a/php-sabre-dav4.spec
+++ b/php-sabre-dav4.spec
@@ -6,8 +6,11 @@
#
# Please, preserve the changelog entries
#
+
+%bcond_without tests
+
# Github
-%global gh_commit 5736f943c90d8d73d04cd8944d8c913811dc7360
+%global gh_commit e1f617a4112da461bfc31aa4e87e0e6ac0bd6ed0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sabre-io
%global gh_project dav
@@ -18,11 +21,10 @@
%global ns_vendor Sabre
%global ns_project DAV
%global major 4
-%bcond_without tests
Name: php-%{pk_vendor}-%{pk_project}%{major}
Summary: WebDAV Framework for PHP
-Version: 4.1.1
+Version: 4.1.2
Release: 1%{?dist}
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -76,14 +78,20 @@ BuildRequires: php-json
# "evert/phpdoc-md" : "~0.1.0",
# "squizlabs/php_codesniffer": "~1.5.3"
# "monolog/monolog": "^1.18"
-BuildRequires: phpunit8 >= 8.5
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
+BuildRequires: phpunit9
+%global phpunit %{_bindir}/phpunit9
+%else
+BuildRequires: phpunit8
+%global phpunit %{_bindir}/phpunit8
+%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
BuildRequires: php-pdo_sqlite
# From composer.json, "require": {
-# "php": ">=7.1.0",
+# "php": ">=7.1.0 || ^8.0",
# "sabre/vobject": "^4.2.1",
# "sabre/event" : "^5.0",
# "sabre/xml" : "^2.0.1",
@@ -215,9 +223,10 @@ sed -e 's:@BUILDROOT@:%{buildroot}:' -i bootstrap.php
: Run upstream test suite against installed library
ret=0
-for cmd in php php72 php73 php74 php80; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit8 \
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit9} \
--filter '^((?!(testDeliverInsignificantRequest)).)*$' \
|| ret=1
fi
@@ -242,6 +251,10 @@ exit $ret
%changelog
+* Mon Oct 5 2020 Remi Collet <remi@remirepo.net> - 4.1.2-1
+- update to 4.1.2
+- switch to phpunit9
+
* Tue Jul 14 2020 Remi Collet <remi@remirepo.net> - 4.1.1-1
- update to 4.1.1