summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-02 14:33:10 +0200
committerRemi Collet <remi@remirepo.net>2018-05-02 14:33:10 +0200
commit4045c228ae86f0efab7df47c1a918464c5783563 (patch)
tree83e04a8426e2947007deaa9246e28e461b5c8301
parent316b7c69720766f64ebffdc43b31c47b52235383 (diff)
backport stuff
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--php-ringcentral-psr7.spec3
3 files changed, 15 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..6f69818
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-ringcentral-psr7.spec b/php-ringcentral-psr7.spec
index a0374da..9a4a96a 100644
--- a/php-ringcentral-psr7.spec
+++ b/php-ringcentral-psr7.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-ringcentral-psr7, from:
#
# Fedora spec file for php-ringcentral-psr7
#
@@ -126,7 +127,7 @@ ln -s %{buildroot}%{phpdir}/RingCentral/Psr7/autoload.php vendor/autoload.php
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in php %{?rhel:php54 php55 php56} php70 php71 php72; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose || RETURN_CODE=1
fi