summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-11 14:20:39 +0100
committerRemi Collet <remi@php.net>2022-02-11 14:20:39 +0100
commit07d485b85e57f98f231394b1d465ea304ccbd001 (patch)
treeccda316a2edc7a480281331ff4df5d9ac28bd5a9
parent4a5e9c0cbfe97371940ee2e9ae79f76c602d84f5 (diff)
update to 2.9.0HEADmaster
Use PHPUnit 9
-rw-r--r--composer.json23
-rw-r--r--php-react-promise.spec16
2 files changed, 31 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index b3e723a..f933f15 100644
--- a/composer.json
+++ b/composer.json
@@ -3,13 +3,32 @@
"description": "A lightweight implementation of CommonJS Promises/A for PHP",
"license": "MIT",
"authors": [
- {"name": "Jan Sorgalla", "email": "jsorgalla@gmail.com"}
+ {
+ "name": "Jan Sorgalla",
+ "homepage": "https://sorgalla.com/",
+ "email": "jsorgalla@gmail.com"
+ },
+ {
+ "name": "Christian Lück",
+ "homepage": "https://clue.engineering/",
+ "email": "christian@clue.engineering"
+ },
+ {
+ "name": "Cees-Jan Kiewiet",
+ "homepage": "https://wyrihaximus.net/",
+ "email": "reactphp@ceesjankiewiet.nl"
+ },
+ {
+ "name": "Chris Boden",
+ "homepage": "https://cboden.dev/",
+ "email": "cboden@gmail.com"
+ }
],
"require": {
"php": ">=5.4.0"
},
"require-dev": {
- "phpunit/phpunit": "^7.0 || ^6.5 || ^5.7 || ^4.8.36"
+ "phpunit/phpunit": "^9.3 || ^5.7 || ^4.8.36"
},
"autoload": {
"psr-4": {
diff --git a/php-react-promise.spec b/php-react-promise.spec
index c3d7da5..9b0cd9e 100644
--- a/php-react-promise.spec
+++ b/php-react-promise.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-promise
#
-# Copyright (c) 2014-2020 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2014-2022 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name promise
-%global github_version 2.8.0
-%global github_commit f3cff96a19736714524ca0dd1d4130de73dbbbc4
+%global github_version 2.9.0
+%global github_commit 234f8fd1023c9158e2314fa9d7d0e6a83db42910
%global composer_vendor react
%global composer_project promise
@@ -42,7 +42,7 @@ Source1: %{name}-get-source.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: phpunit7
+BuildRequires: phpunit9
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
## phpcompatinfo (computed from version 2.8.0)
@@ -114,8 +114,8 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit7)
-for PHP_EXEC in "" php72 php73 php74 php80; do
+PHPUNIT=$(which phpunit9)
+for PHP_EXEC in "" php74 php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -137,6 +137,10 @@ exit $RETURN_CODE
%changelog
+* Fri Feb 11 2022 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- Use PHPUnit 9
+
* Sat Jun 06 2020 Shawn Iwinski <shawn@iwin.ski> - 2.8.0-1
- Update to 2.8.0 (RHBZ #1835048)
- Use PHPUnit 7