summaryrefslogtreecommitdiffstats
path: root/php-react-promise.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-react-promise.spec')
-rw-r--r--php-react-promise.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/php-react-promise.spec b/php-react-promise.spec
index c3d7da5..9b0cd9e 100644
--- a/php-react-promise.spec
+++ b/php-react-promise.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-promise
#
-# Copyright (c) 2014-2020 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2014-2022 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name promise
-%global github_version 2.8.0
-%global github_commit f3cff96a19736714524ca0dd1d4130de73dbbbc4
+%global github_version 2.9.0
+%global github_commit 234f8fd1023c9158e2314fa9d7d0e6a83db42910
%global composer_vendor react
%global composer_project promise
@@ -42,7 +42,7 @@ Source1: %{name}-get-source.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: phpunit7
+BuildRequires: phpunit9
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
## phpcompatinfo (computed from version 2.8.0)
@@ -114,8 +114,8 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit7)
-for PHP_EXEC in "" php72 php73 php74 php80; do
+PHPUNIT=$(which phpunit9)
+for PHP_EXEC in "" php74 php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -137,6 +137,10 @@ exit $RETURN_CODE
%changelog
+* Fri Feb 11 2022 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- Use PHPUnit 9
+
* Sat Jun 06 2020 Shawn Iwinski <shawn@iwin.ski> - 2.8.0-1
- Update to 2.8.0 (RHBZ #1835048)
- Use PHPUnit 7