summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-16 15:56:08 +0100
committerRemi Collet <remi@remirepo.net>2019-12-16 15:56:08 +0100
commit6d42b3c05fa8e5927aa9a17242fb8bd1a6a6b2e8 (patch)
tree98dcce87b27e4b9d8cd517f02617a6cd5801edce
parent7d1c2d3e8cd495959e89807ecb571c16f682db12 (diff)
v0.8.5 from Fedora
-rw-r--r--php-react-http.spec40
1 files changed, 19 insertions, 21 deletions
diff --git a/php-react-http.spec b/php-react-http.spec
index d07a952..b9023da 100644
--- a/php-react-http.spec
+++ b/php-react-http.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-http
#
-# Copyright (c) 2017-2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name http
-%global github_version 0.8.3
-%global github_commit f8bcdab2dc0ecd94f35ff9657a263028b96f0c46
+%global github_version 0.8.5
+%global github_commit 5f2ce4da6d30779ab1e6b95a0afac3e0e5595f64
%global composer_vendor react
%global composer_project http
@@ -24,24 +24,20 @@
%global clue_block_react_min_ver 1.1
%global clue_block_react_max_ver 2.0
# "evenement/evenement": "^3.0 || ^2.0 || ^1.0"
-# NOTE: Restricting to one major version
-%global evenement_min_ver 2.0
-%global evenement_max_ver 3.0
+%global evenement_min_ver 1.0
+%global evenement_max_ver 4.0
# "react/promise": "^2.3 || ^1.2.1"
-# NOTE: Restricting to one major version
-%global react_promise_min_ver 2.3
+%global react_promise_min_ver 1.2.1
%global react_promise_max_ver 3.0
# "react/promise-stream": "^1.1"
%global react_promise_stream_min_ver 1.1
%global react_promise_stream_max_ver 2.0
# "react/socket": "^1.0 || ^0.8.3"
-# NOTE: Restricting to one major version
%global react_socket_min_ver 0.8.3
-%global react_socket_max_ver 1.0
+%global react_socket_max_ver 2.0
# "react/stream": "^1.0 || ^0.7.1"
-# NOTE: Restricting to one major version
%global react_stream_min_ver 0.7.1
-%global react_stream_max_ver 1.0
+%global react_stream_max_ver 2.0
# "ringcentral/psr7": "^1.2"
%global ringcentral_psr7_min_ver 1.2
%global ringcentral_psr7_max_ver 2.0
@@ -56,7 +52,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: Library for building an evented http server
-Group: Development/Libraries
License: MIT
URL: https://reactphp.org/http/
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -66,7 +61,7 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: phpunit6
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(clue/block-react) >= %{clue_block_react_min_ver} with php-composer(clue/block-react) < %{clue_block_react_max_ver})
BuildRequires: (php-composer(evenement/evenement) >= %{evenement_min_ver} with php-composer(evenement/evenement) < %{evenement_max_ver})
@@ -91,8 +86,9 @@ BuildRequires: php-composer(react/stream) >= %{react_stream_min_ver}
BuildRequires: php-composer(ringcentral/psr7) < %{ringcentral_psr7_max_ver}
BuildRequires: php-composer(ringcentral/psr7) >= %{ringcentral_psr7_min_ver}
%endif
-## phpcompatinfo (computed from version 0.8.3)
+## phpcompatinfo (computed from version 0.8.5)
BuildRequires: php-date
+BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
## Autoloader
@@ -122,7 +118,7 @@ Requires: php-composer(react/stream) >= %{react_stream_min_ver}
Requires: php-composer(ringcentral/psr7) < %{ringcentral_psr7_max_ver}
Requires: php-composer(ringcentral/psr7) >= %{ringcentral_psr7_min_ver}
%endif
-# phpcompatinfo (computed from version 0.8.3)
+# phpcompatinfo (computed from version 0.8.5)
Requires: php-date
Requires: php-pcre
Requires: php-spl
@@ -196,12 +192,10 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php70 php71 php72 php73; do
+PHPUNIT=$(which phpunit6)
+for PHP_EXEC in "" php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose \
- --filter '^((?!(testSecureHttps)).)*$' \
- --bootstrap bootstrap.php \
+ $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -220,6 +214,10 @@ exit $RETURN_CODE
%changelog
+* Sat Dec 14 2019 Shawn Iwinski <shawn@iwin.ski> - 0.8.5-1
+- Update to 0.8.5 (RHBZ #1767189)
+- Use PHPUnit 6
+
* Mon Jul 02 2018 Shawn Iwinski <shawn@iwin.ski> - 0.8.3-1
- Update to 0.8.3 (RHBZ #1421136)
- Add range version dependencies for Fedora >= 27 || RHEL >= 8