summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-08 14:16:57 +0200
committerRemi Collet <remi@remirepo.net>2020-06-08 14:16:57 +0200
commitd7847cc32f608b4f0d100f22b526940ba7dcc60e (patch)
tree4359ec920a9f80902c4c36c537b7512b73e26018
parentb1cddceca8fdf80d2153b69bafb91e7649611a25 (diff)
v0.5.10 from Fedora
-rw-r--r--composer.json7
-rw-r--r--php-react-http-client.spec35
2 files changed, 31 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 4cd9d7f..9207639 100644
--- a/composer.json
+++ b/composer.json
@@ -14,12 +14,17 @@
},
"require-dev": {
"clue/block-react": "^1.2",
- "phpunit/phpunit": "^6.4 || ^5.7 || ^4.8.35",
+ "phpunit/phpunit": "^7.0 || ^6.4 || ^5.7 || ^4.8.35",
"react/promise-stream": "^1.1"
},
"autoload": {
"psr-4": {
"React\\HttpClient\\": "src"
}
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "React\\Tests\\HttpClient\\": "tests"
+ }
}
}
diff --git a/php-react-http-client.spec b/php-react-http-client.spec
index 885d0b9..66956eb 100644
--- a/php-react-http-client.spec
+++ b/php-react-http-client.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-http-client
#
-# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2020 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name http-client
-%global github_version 0.5.9
-%global github_commit f8e81a022b61938e0b37c94c6351fc170b7d87f6
+%global github_version 0.5.10
+%global github_commit f16ab55150ec369f8f9b5db64972f248691093b0
%global composer_vendor react
%global composer_project http-client
@@ -48,24 +48,35 @@
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
+# Range dependencies supported?
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%global with_range_dependencies 1
+%else
+%global with_range_dependencies 0
+%endif
+
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 5%{?github_release}%{?dist}
+Release: 6%{?github_release}%{?dist}
Summary: Asynchronous HTTP client library
License: MIT
URL: https://reactphp.org/http-client/
-Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+# GitHub export does not include tests
+# Run php-react-http-client-get-source.sh to create full source
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
BuildArch: noarch
# Tests
%if %{with_tests}
## composer.json
Requires: php(language) >= %{php_min_ver}
-BuildRequires: phpunit6
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: phpunit7
+%if %{with_range_dependencies}
BuildRequires: (php-composer(clue/block-react) >= %{clue_block_react_min_ver} with php-composer(clue/block-react) < %{clue_block_react_max_ver})
BuildRequires: (php-composer(evenement/evenement) >= %{evenement_min_ver} with php-composer(evenement/evenement) < %{evenement_max_ver})
BuildRequires: (php-composer(react/event-loop) >= %{react_event_loop_min_ver} with php-composer(react/event-loop) < %{react_event_loop_max_ver})
@@ -101,7 +112,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if %{with_range_dependencies}
Requires: (php-composer(evenement/evenement) >= %{evenement_min_ver} with php-composer(evenement/evenement) < %{evenement_max_ver})
Requires: (php-composer(react/event-loop) >= %{react_event_loop_min_ver} with php-composer(react/event-loop) < %{react_event_loop_max_ver})
Requires: (php-composer(react/promise) >= %{react_promise_min_ver} with php-composer(react/promise) < %{react_promise_max_ver})
@@ -188,8 +199,8 @@ rm -f tests/FunctionalIntegrationTest.php
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit6)
-for PHP_EXEC in "" php71 php72 php73 php74; do
+PHPUNIT=$(which phpunit7)
+for PHP_EXEC in "" php72 php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -210,6 +221,10 @@ exit $RETURN_CODE
%changelog
+* Sat Jun 06 2020 Shawn Iwinski <shawn@iwin.ski> - 0.5.10-1
+- Update to 0.5.10 (RHBZ #1791054)
+- Use PHPUnit 7
+
* Sun Dec 15 2019 Shawn Iwinski <shawn@iwin.ski> - 0.5.9-5
- Loosen dependency versions to allow for updated dependencies
- Use PHPUnit 6