summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-16 16:17:55 +0100
committerRemi Collet <remi@remirepo.net>2019-12-16 16:17:55 +0100
commitb1cddceca8fdf80d2153b69bafb91e7649611a25 (patch)
treee881e695bc4fe4d3c647e8d791482a4da6a2fec5
parent0e88c98897757ff0b198b951143f727652a1d7d9 (diff)
sync with Fedora
-rw-r--r--php-react-http-client.spec34
1 files changed, 16 insertions, 18 deletions
diff --git a/php-react-http-client.spec b/php-react-http-client.spec
index afe1500..885d0b9 100644
--- a/php-react-http-client.spec
+++ b/php-react-http-client.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-http-client
#
-# Copyright (c) 2017-2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -24,31 +24,26 @@
%global clue_block_react_min_ver 1.2
%global clue_block_react_max_ver 2.0
# "evenement/evenement": "^3.0 || ^2.0 || ^1.0"
-# NOTE: Restricting to one major version
-%global evenement_min_ver 2.0
-%global evenement_max_ver 3.0
+%global evenement_min_ver 1.0
+%global evenement_max_ver 4.0
# "ringcentral/psr7": "^1.2"
%global ringcentral_psr7_min_ver 1.2
%global ringcentral_psr7_max_ver 2.0
# "react/event-loop": "^1.0 || ^0.5 || ^0.4 || ^0.3"
-# NOTE: Restricting to one major version
-%global react_event_loop_min_ver 0.5
-%global react_event_loop_max_ver 1.0
+%global react_event_loop_min_ver 0.3
+%global react_event_loop_max_ver 2.0
# "react/promise": "^2.1 || ^1.2.1"
-# NOTE: Restricting to one major version
-%global react_promise_min_ver 2.1
+%global react_promise_min_ver 1.2.1
%global react_promise_max_ver 3.0
# "react/promise-stream": "^1.1"
%global react_promise_stream_min_ver 1.1
%global react_promise_stream_max_ver 2.0
# "react/socket": "^1.0 || ^0.8.4"
-# NOTE: Restricting to one major version
%global react_socket_min_ver 0.8.4
-%global react_socket_max_ver 1.0
+%global react_socket_max_ver 2.0
# "react/stream": "^1.0 || ^0.7.1"
-# NOTE: Restricting to one major version
%global react_stream_min_ver 0.7.1
-%global react_stream_max_ver 1.0
+%global react_stream_max_ver 2.0
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -57,10 +52,9 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 5%{?github_release}%{?dist}
Summary: Asynchronous HTTP client library
-Group: Development/Libraries
License: MIT
URL: https://reactphp.org/http-client/
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -70,7 +64,7 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
Requires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: phpunit6
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(clue/block-react) >= %{clue_block_react_min_ver} with php-composer(clue/block-react) < %{clue_block_react_max_ver})
BuildRequires: (php-composer(evenement/evenement) >= %{evenement_min_ver} with php-composer(evenement/evenement) < %{evenement_max_ver})
@@ -194,8 +188,8 @@ rm -f tests/FunctionalIntegrationTest.php
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php70 php71 php72 php73; do
+PHPUNIT=$(which phpunit6)
+for PHP_EXEC in "" php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -216,6 +210,10 @@ exit $RETURN_CODE
%changelog
+* Sun Dec 15 2019 Shawn Iwinski <shawn@iwin.ski> - 0.5.9-5
+- Loosen dependency versions to allow for updated dependencies
+- Use PHPUnit 6
+
* Mon Jul 02 2018 Shawn Iwinski <shawn@iwin.ski> - 0.5.9-1
- Update to 0.5.9 (RHBZ #1454517)
- Add range version dependencies for Fedora >= 27 || RHEL >= 8