summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-16 15:09:28 +0100
committerRemi Collet <remi@remirepo.net>2019-12-16 15:09:28 +0100
commit3e9e16cbf1dc6b56405c37fddf5e83ce41d0ccb9 (patch)
treeccd2867d3de0969f4eeb08d79dbabd8fd57d86f4
parenta0080c0a825a9598348ce879c8317dddd7f4d316 (diff)
v1.1.0 from Fedora
-rw-r--r--composer.json10
-rw-r--r--php-react-event-loop.spec26
2 files changed, 23 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 24974ec..cc6abf0 100644
--- a/composer.json
+++ b/composer.json
@@ -7,15 +7,21 @@
"php": ">=5.3.0"
},
"require-dev": {
- "phpunit/phpunit": "~4.8.35 || ^5.7 || ^6.4"
+ "phpunit/phpunit": "^7.0 || ^6.4 || ^5.7 || ^4.8.35"
},
"suggest": {
"ext-event": "~1.0 for ExtEventLoop",
- "ext-pcntl": "For signal handling support when using the StreamSelectLoop"
+ "ext-pcntl": "For signal handling support when using the StreamSelectLoop",
+ "ext-uv": "* for ExtUvLoop"
},
"autoload": {
"psr-4": {
"React\\EventLoop\\": "src"
}
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "React\\Tests\\EventLoop\\": "tests"
+ }
}
}
diff --git a/php-react-event-loop.spec b/php-react-event-loop.spec
index 4be2004..ae3f2b6 100644
--- a/php-react-event-loop.spec
+++ b/php-react-event-loop.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-event-loop
#
-# Copyright (c) 2017-2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name event-loop
-%global github_version 0.5.2
-%global github_commit e94985d93c689c554265b01014f8c3064921ca27
+%global github_version 1.1.0
+%global github_commit a0ecac955c67b57c40fe4a1b88a7cca1b58c982d
%global composer_vendor react
%global composer_project event-loop
@@ -31,7 +31,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: Event loop abstraction layer that libraries can use for evented I/O
-Group: Development/Libraries
License: MIT
URL: https://reactphp.org/event-loop/
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -41,20 +40,19 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 0.5.2)
+BuildRequires: phpunit7
+## phpcompatinfo (computed from version 1.1.0)
BuildRequires: php-date
BuildRequires: php-pcntl
BuildRequires: php-posix
BuildRequires: php-spl
-
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 0.5.2)
+# phpcompatinfo (computed from version 1.1.0)
Requires: php-pcntl
Requires: php-spl
# Autoloader
@@ -127,9 +125,11 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php %{?rhel:php55 php56} php70 php71 php72 php73; do
- if [ "php" = "$PHP_EXEC" ] || which $PHP_EXEC; then
- $SCL %{_bindir}/phpunit --verbose --bootstrap bootstrap.php || RETURN_CODE=1
+PHPUNIT=$(which phpunit7)
+for PHP_EXEC in "" php71 php72 php73 php74; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
+ || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -148,6 +148,10 @@ exit $RETURN_CODE
%changelog
+* Sat Dec 14 2019 Shawn Iwinski <shawn@iwin.ski> - 1.1.0-1
+- Update to 1.1.0 (RHBZ #1599719)
+- Use PHPUnit 7
+
* Sun Jul 01 2018 Shawn Iwinski <shawn@iwin.ski> - 0.5.2-1
- Update to 0.5.2 (RHBZ #1564315)
- Add range version dependencies for Fedora >= 27 || RHEL >= 8