summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-03 10:40:50 +0200
committerRemi Collet <remi@remirepo.net>2018-07-03 10:40:50 +0200
commita0080c0a825a9598348ce879c8317dddd7f4d316 (patch)
tree93922da8c01abce34594bde0e0cbe475deb0022e
parentcd9866bd7354b8065e920a9f8d3e0f746a1a9a00 (diff)
v0.5.2 from Fedora
* Sun Jul 01 2018 Shawn Iwinski <shawn@iwin.ski> - 0.5.2-1 - Update to 0.5.2 (RHBZ #1564315) - Add range version dependencies for Fedora >= 27 || RHEL >= 8 - Add composer.json to repo
-rw-r--r--composer.json17
-rw-r--r--php-react-event-loop.spec23
2 files changed, 22 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index f252275..24974ec 100644
--- a/composer.json
+++ b/composer.json
@@ -1,24 +1,21 @@
{
"name": "react/event-loop",
- "description": "Event loop abstraction layer that libraries can use for evented I/O.",
+ "description": "ReactPHP's core reactor event loop that libraries can use for evented I/O.",
"keywords": ["event-loop", "asynchronous"],
"license": "MIT",
"require": {
- "php": ">=5.4.0"
+ "php": ">=5.3.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~4.8.35 || ^5.7 || ^6.4"
},
"suggest": {
- "ext-libevent": ">=0.1.0",
- "ext-event": "~1.0",
- "ext-libev": "*"
+ "ext-event": "~1.0 for ExtEventLoop",
+ "ext-pcntl": "For signal handling support when using the StreamSelectLoop"
},
"autoload": {
"psr-4": {
"React\\EventLoop\\": "src"
}
- },
- "extra": {
- "branch-alias": {
- "dev-master": "0.5-dev"
- }
}
}
diff --git a/php-react-event-loop.spec b/php-react-event-loop.spec
index d4a3a33..4be2004 100644
--- a/php-react-event-loop.spec
+++ b/php-react-event-loop.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-event-loop
#
-# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2018 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name event-loop
-%global github_version 0.4.3
-%global github_commit 8bde03488ee897dc6bb3d91e4e17c353f9c5252f
+%global github_version 0.5.2
+%global github_commit e94985d93c689c554265b01014f8c3064921ca27
%global composer_vendor react
%global composer_project event-loop
@@ -33,8 +33,8 @@ Summary: Event loop abstraction layer that libraries can use for evented I
Group: Development/Libraries
License: MIT
-URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+URL: https://reactphp.org/event-loop/
+Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
BuildArch: noarch
# Tests
@@ -42,7 +42,8 @@ BuildArch: noarch
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 0.4.3)
+## phpcompatinfo (computed from version 0.5.2)
+BuildRequires: php-date
BuildRequires: php-pcntl
BuildRequires: php-posix
BuildRequires: php-spl
@@ -53,7 +54,8 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 0.4.3)
+# phpcompatinfo (computed from version 0.5.2)
+Requires: php-pcntl
Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -125,7 +127,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php %{?rhel:php55} php56 php70 php71 php72; do
+for PHP_EXEC in php %{?rhel:php55 php56} php70 php71 php72 php73; do
if [ "php" = "$PHP_EXEC" ] || which $PHP_EXEC; then
$SCL %{_bindir}/phpunit --verbose --bootstrap bootstrap.php || RETURN_CODE=1
fi
@@ -146,6 +148,11 @@ exit $RETURN_CODE
%changelog
+* Sun Jul 01 2018 Shawn Iwinski <shawn@iwin.ski> - 0.5.2-1
+- Update to 0.5.2 (RHBZ #1564315)
+- Add range version dependencies for Fedora >= 27 || RHEL >= 8
+- Add composer.json to repo
+
* Sat Apr 29 2017 Shawn Iwinski <shawn@iwin.ski> - 0.4.3-1
- Update to 0.4.3 (RHBZ #1446188)