summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-16 15:13:08 +0100
committerRemi Collet <remi@remirepo.net>2019-12-16 15:13:08 +0100
commit2364fc9cd539f2625775f8782281cea4acb9d6ce (patch)
treeebd0473efe4a849436422d79a51828b4684577f5
parent8cad272c357291e87a46889e9513ba55ce4aab34 (diff)
v1.0.0 from Fedora
-rw-r--r--php-react-cache.spec24
1 files changed, 13 insertions, 11 deletions
diff --git a/php-react-cache.spec b/php-react-cache.spec
index 6115c61..731be9f 100644
--- a/php-react-cache.spec
+++ b/php-react-cache.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-cache
#
-# Copyright (c) 2017-2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name cache
-%global github_version 0.5.0
-%global github_commit 7d7da7fb7574d471904ba357b39bbf110ccdbf66
+%global github_version 1.0.0
+%global github_commit aa10d63a1b40a36a486bdf527f28bac607ee6466
%global composer_vendor react
%global composer_project cache
@@ -21,8 +21,7 @@
# "php": ">=5.3.0",
%global php_min_ver 5.3.0
# "react/promise": "~2.0|~1.1"
-# NOTE: Min version not 1.1 to restrict to one major version
-%global react_promise_min_ver 2.0
+%global react_promise_min_ver 1.1
%global react_promise_max_ver 3.0
# Build using "--without tests" to disable tests
@@ -35,7 +34,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: Async caching
-Group: Development/Libraries
License: MIT
URL: https://reactphp.org/cache/
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -45,14 +43,14 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: phpunit6
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(react/promise) >= %{react_promise_min_ver} with php-composer(react/promise) < %{react_promise_max_ver})
%else
BuildRequires: php-composer(react/promise) < %{react_promise_max_ver}
BuildRequires: php-composer(react/promise) >= %{react_promise_min_ver}
%endif
-## phpcompatinfo (computed from version 0.5.0)
+## phpcompatinfo (computed from version 1.0.0)
# <none>
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -66,7 +64,7 @@ Requires: (php-composer(react/promise) >= %{react_promise_min_ver} with php
Requires: php-composer(react/promise) < %{react_promise_max_ver}
Requires: php-composer(react/promise) >= %{react_promise_min_ver}
%endif
-# phpcompatinfo (computed from version 0.5.0)
+# phpcompatinfo (computed from version 1.0.0)
# <none>
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -122,8 +120,8 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php70 php71 php72 php73; do
+PHPUNIT=$(which phpunit6)
+for PHP_EXEC in "" php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -144,6 +142,10 @@ exit $RETURN_CODE
%changelog
+* Sat Dec 14 2019 Shawn Iwinski <shawn@iwin.ski> - 1.0.0-1
+- Update to 1.0.0 (RHBZ #1727191)
+- Use PHPUnit 6
+
* Sun Jul 01 2018 Shawn Iwinski <shawn@iwin.ski> - 0.5.0-1
- Update to 0.5.0 (RHBZ #1528619)
- Add range version dependencies for Fedora >= 27 || RHEL >= 8