summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-03 10:14:08 +0200
committerRemi Collet <remi@remirepo.net>2018-07-03 10:14:08 +0200
commit8cad272c357291e87a46889e9513ba55ce4aab34 (patch)
tree110c2c5ae784569bbad97f70efa974e6e455c4b7
parent426188fc2dcde4a022014181afbb3ddfef0a9344 (diff)
v0.5.0 from Fedora:
* Sun Jul 01 2018 Shawn Iwinski <shawn@iwin.ski> - 0.5.0-1 - Update to 0.5.0 (RHBZ #1528619) - Add range version dependencies for Fedora >= 27 || RHEL >= 8 - Add composer.json to repo
-rw-r--r--.gitignore8
-rw-r--r--composer.json11
-rw-r--r--php-react-cache.spec44
3 files changed, 43 insertions, 20 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 238b40c..51573b6 100644
--- a/composer.json
+++ b/composer.json
@@ -1,16 +1,19 @@
{
"name": "react/cache",
- "description": "Async caching.",
- "keywords": ["cache"],
+ "description": "Async, Promise-based cache interface for ReactPHP",
+ "keywords": ["cache", "caching", "promise", "ReactPHP"],
"license": "MIT",
"require": {
"php": ">=5.3.0",
"react/promise": "~2.0|~1.1"
},
"autoload": {
- "psr-4": { "React\\Cache\\": "src\\" }
+ "psr-4": { "React\\Cache\\": "src/" }
},
"autoload-dev": {
- "psr-4": { "React\\Tests\\Cache\\": "tests\\" }
+ "psr-4": { "React\\Tests\\Cache\\": "tests/" }
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^6.4 || ^5.7 || ^4.8.35"
}
}
diff --git a/php-react-cache.spec b/php-react-cache.spec
index 34cb179..6115c61 100644
--- a/php-react-cache.spec
+++ b/php-react-cache.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-react-cache
#
-# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2018 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner reactphp
%global github_name cache
-%global github_version 0.4.1
-%global github_commit 558f614891341b1d817a8cdf9a358948ec49638f
+%global github_version 0.5.0
+%global github_commit 7d7da7fb7574d471904ba357b39bbf110ccdbf66
%global composer_vendor react
%global composer_project cache
@@ -32,13 +32,13 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 2%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Async caching
Group: Development/Libraries
License: MIT
-URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+URL: https://reactphp.org/cache/
+Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
BuildArch: noarch
# Tests
@@ -46,9 +46,13 @@ BuildArch: noarch
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(react/promise) >= %{react_promise_min_ver} with php-composer(react/promise) < %{react_promise_max_ver})
+%else
BuildRequires: php-composer(react/promise) < %{react_promise_max_ver}
BuildRequires: php-composer(react/promise) >= %{react_promise_min_ver}
-## phpcompatinfo (computed from version 0.4.1)
+%endif
+## phpcompatinfo (computed from version 0.5.0)
# <none>
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -56,9 +60,13 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(react/promise) >= %{react_promise_min_ver} with php-composer(react/promise) < %{react_promise_max_ver})
+%else
Requires: php-composer(react/promise) < %{react_promise_max_ver}
Requires: php-composer(react/promise) >= %{react_promise_min_ver}
-# phpcompatinfo (computed from version 0.4.1)
+%endif
+# phpcompatinfo (computed from version 0.5.0)
# <none>
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -113,16 +121,15 @@ require '%{buildroot}%{phpdir}/React/Cache/autoload.php';
BOOTSTRAP
: Upstream tests
-%{_bindir}/phpunit --verbose --bootstrap bootstrap.php
-
-: Upstream tests with SCLs if available
-SCL_RETURN_CODE=0
-for SCL in %{?rhel:php54 php55} php56 php70 php71; do
- if which $SCL; then
- $SCL %{_bindir}/phpunit --verbose --bootstrap bootstrap.php || SCL_RETURN_CODE=1
+RETURN_CODE=0
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in "" %{?rhel:php54 php55} php70 php71 php72 php73; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
+ || RETURN_CODE=1
fi
done
-exit $SCL_RETURN_CODE
+exit $RETURN_CODE
%else
: Tests skipped
%endif
@@ -137,6 +144,11 @@ exit $SCL_RETURN_CODE
%changelog
+* Sun Jul 01 2018 Shawn Iwinski <shawn@iwin.ski> - 0.5.0-1
+- Update to 0.5.0 (RHBZ #1528619)
+- Add range version dependencies for Fedora >= 27 || RHEL >= 8
+- Add composer.json to repo
+
* Tue Jan 24 2017 Remi Collet <remi@remirepo.net> - 0.4.1-2
- backport for remi repo