summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-01-02 15:31:39 +0100
committerRemi Collet <remi@php.net>2023-01-02 15:31:39 +0100
commit7d593abfd09085526a9ef965f3431d824febd9eb (patch)
treec019f8dd0f0a4018f62891bbf3c25f1ee88ff7db
parent356a8edf0d6ac92f4feb654c6eef5fcd1a3ec7e2 (diff)
update to 4.7.1
allow ramsey/collection 2
-rw-r--r--composer.json2
-rw-r--r--php-ramsey-uuid.spec14
2 files changed, 10 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 82b0555..86bccac 100644
--- a/composer.json
+++ b/composer.json
@@ -12,7 +12,7 @@
"php": "^8.0",
"ext-json": "*",
"brick/math": "^0.8.8 || ^0.9 || ^0.10",
- "ramsey/collection": "^1.2"
+ "ramsey/collection": "^1.2 || ^2.0"
},
"require-dev": {
"captainhook/captainhook": "^5.10",
diff --git a/php-ramsey-uuid.spec b/php-ramsey-uuid.spec
index 85eb2a3..fc70772 100644
--- a/php-ramsey-uuid.spec
+++ b/php-ramsey-uuid.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 5ed9ad582647bbc3864ef78db34bdc1afdcf9b49
+%global gh_commit a1acf96007170234a8399586a6e2ab8feba109d1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner ramsey
%global gh_project uuid
@@ -22,7 +22,7 @@
%global ns_project Uuid
Name: php-%{pk_vendor}-%{pk_name}
-Version: 4.7.0
+Version: 4.7.1
Release: 1%{?dist}
Summary: Library for generating and working with UUIDs
@@ -64,7 +64,7 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(brick/math) >= 0.8.8 with php-composer(brick/math) < 1)
-BuildRequires: (php-composer(ramsey/collection) >= 1.2 with php-composer(ramsey/collection) < 2)
+BuildRequires: (php-composer(ramsey/collection) >= 1.2 with php-composer(ramsey/collection) < 3)
BuildRequires: (php-composer(mockery/mockery) >= 1.3 with php-composer(mockery/mockery) < 2)
BuildRequires: (php-composer(php-mock/php-mock) >= 2.2 with php-composer(php-mock/php-mock) < 3)
# remirepo:6
@@ -84,13 +84,13 @@ BuildRequires: php-fedora-autoloader-devel
# "php": "^8.0",
# "ext-json": "*",
# "brick/math": "^0.8.8 || ^0.9 || ^0.10",
-# "ramsey/collection": "^1.2",
+# "ramsey/collection": "^1.2 || ^2.0",
Requires: php(language) >= 8.0
Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(brick/math) >= 0.8.8 with php-composer(brick/math) < 1)
-Requires: (php-composer(ramsey/collection) >= 1.2 with php-composer(ramsey/collection) < 2)
+Requires: (php-composer(ramsey/collection) >= 1.2 with php-composer(ramsey/collection) < 3)
# remirepo:4
%else
Requires: php-brick-math >= 0.8.8
@@ -188,6 +188,10 @@ exit $ret
%changelog
+* Mon Jan 2 2023 Remi Collet <remi@remirepo.net> - 4.7.1-1
+- update to 4.7.1
+- allow ramsey/collection 2
+
* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 4.7.0-1
- update to 4.7.0
- raise dependency on ramsey/collection 1.2