summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-20 16:03:30 +0100
committerRemi Collet <remi@php.net>2022-12-20 16:03:30 +0100
commit356a8edf0d6ac92f4feb654c6eef5fcd1a3ec7e2 (patch)
tree6d47d671fd0216a9ceb16934571b010db7236ec9
parent901a20cc93555b1cf29867b9226ccf91f4e18730 (diff)
update to 4.7.0
raise dependency on ramsey/collection 1.2
-rw-r--r--composer.json2
-rw-r--r--php-ramsey-uuid.spec18
2 files changed, 12 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 74490af..82b0555 100644
--- a/composer.json
+++ b/composer.json
@@ -12,7 +12,7 @@
"php": "^8.0",
"ext-json": "*",
"brick/math": "^0.8.8 || ^0.9 || ^0.10",
- "ramsey/collection": "^1.0"
+ "ramsey/collection": "^1.2"
},
"require-dev": {
"captainhook/captainhook": "^5.10",
diff --git a/php-ramsey-uuid.spec b/php-ramsey-uuid.spec
index 8c9f553..85eb2a3 100644
--- a/php-ramsey-uuid.spec
+++ b/php-ramsey-uuid.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit ad63bc700e7d021039e30ce464eba384c4a1d40f
+%global gh_commit 5ed9ad582647bbc3864ef78db34bdc1afdcf9b49
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner ramsey
%global gh_project uuid
@@ -22,7 +22,7 @@
%global ns_project Uuid
Name: php-%{pk_vendor}-%{pk_name}
-Version: 4.6.0
+Version: 4.7.0
Release: 1%{?dist}
Summary: Library for generating and working with UUIDs
@@ -64,13 +64,13 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(brick/math) >= 0.8.8 with php-composer(brick/math) < 1)
-BuildRequires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
+BuildRequires: (php-composer(ramsey/collection) >= 1.2 with php-composer(ramsey/collection) < 2)
BuildRequires: (php-composer(mockery/mockery) >= 1.3 with php-composer(mockery/mockery) < 2)
BuildRequires: (php-composer(php-mock/php-mock) >= 2.2 with php-composer(php-mock/php-mock) < 3)
# remirepo:6
%else
BuildRequires: php-brick-math >= 0.8.8
-BuildRequires: php-ramsey-collection >= 1.0
+BuildRequires: php-ramsey-collection >= 1.2
BuildRequires: php-mockery >= 1.3
BuildRequires: php-mock2 >= 2.2
%endif
@@ -84,17 +84,17 @@ BuildRequires: php-fedora-autoloader-devel
# "php": "^8.0",
# "ext-json": "*",
# "brick/math": "^0.8.8 || ^0.9 || ^0.10",
-# "ramsey/collection": "^1.0",
+# "ramsey/collection": "^1.2",
Requires: php(language) >= 8.0
Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(brick/math) >= 0.8.8 with php-composer(brick/math) < 1)
-Requires: (php-composer(ramsey/collection) >= 1.0 with php-composer(ramsey/collection) < 2)
+Requires: (php-composer(ramsey/collection) >= 1.2 with php-composer(ramsey/collection) < 2)
# remirepo:4
%else
Requires: php-brick-math >= 0.8.8
-Requires: php-ramsey-collection >= 1.0
+Requires: php-ramsey-collection >= 1.2
%endif
# From phpcompatifo report for 4.6.0
Requires: php-date
@@ -188,6 +188,10 @@ exit $ret
%changelog
+* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 4.7.0-1
+- update to 4.7.0
+- raise dependency on ramsey/collection 1.2
+
* Mon Nov 7 2022 Remi Collet <remi@remirepo.net> - 4.6.0-1
- update to 4.6.0