summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-07 12:35:29 +0100
committerRemi Collet <remi@php.net>2022-11-07 12:35:29 +0100
commit901a20cc93555b1cf29867b9226ccf91f4e18730 (patch)
treeffad6868da7ba3efaf8336f5bf9a9239d4c9c0fd
parent1923d8b373feb64032ebf3226eb97e8ff1e73424 (diff)
update to 4.6.0
-rw-r--r--composer.json6
-rw-r--r--php-ramsey-uuid.spec12
2 files changed, 8 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 9653cad..74490af 100644
--- a/composer.json
+++ b/composer.json
@@ -10,7 +10,6 @@
],
"require": {
"php": "^8.0",
- "ext-ctype": "*",
"ext-json": "*",
"brick/math": "^0.8.8 || ^0.9 || ^0.10",
"ramsey/collection": "^1.0"
@@ -42,7 +41,6 @@
},
"suggest": {
"ext-bcmath": "Enables faster math with arbitrary-precision integers using BCMath.",
- "ext-ctype": "Enables faster processing of character classification using ctype functions.",
"ext-gmp": "Enables faster math with arbitrary-precision integers using GMP.",
"ext-uuid": "Enables the use of PeclUuidTimeGenerator and PeclUuidRandomGenerator.",
"paragonie/random-lib": "Provides RandomLib for use with the RandomLibAdapter",
@@ -92,8 +90,8 @@
"phpcbf": "phpcbf -vpw --cache=build/cache/phpcs.cache",
"phpcs": "phpcs --cache=build/cache/phpcs.cache",
"phpstan": [
- "phpstan analyse --no-progress",
- "phpstan analyse -c phpstan-tests.neon --no-progress"
+ "phpstan analyse --no-progress --memory-limit=1G",
+ "phpstan analyse -c phpstan-tests.neon --no-progress --memory-limit=1G"
],
"phpunit": "phpunit --verbose --colors=always",
"phpunit-coverage": "phpunit --verbose --colors=always --coverage-html build/coverage",
diff --git a/php-ramsey-uuid.spec b/php-ramsey-uuid.spec
index 3f26e84..8c9f553 100644
--- a/php-ramsey-uuid.spec
+++ b/php-ramsey-uuid.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit a161a26d917604dc6d3aa25100fddf2556e9f35d
+%global gh_commit ad63bc700e7d021039e30ce464eba384c4a1d40f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner ramsey
%global gh_project uuid
@@ -22,7 +22,7 @@
%global ns_project Uuid
Name: php-%{pk_vendor}-%{pk_name}
-Version: 4.5.1
+Version: 4.6.0
Release: 1%{?dist}
Summary: Library for generating and working with UUIDs
@@ -35,7 +35,6 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 8.0
-BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-hash
BuildRequires: php-json
@@ -83,12 +82,10 @@ BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": "^8.0",
-# "ext-ctype": "*",
# "ext-json": "*",
# "brick/math": "^0.8.8 || ^0.9 || ^0.10",
# "ramsey/collection": "^1.0",
Requires: php(language) >= 8.0
-Requires: php-ctype
Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -99,7 +96,7 @@ Requires: (php-composer(ramsey/collection) >= 1.0 with php-composer(r
Requires: php-brick-math >= 0.8.8
Requires: php-ramsey-collection >= 1.0
%endif
-# From phpcompatifo report for 4.1.1
+# From phpcompatifo report for 4.6.0
Requires: php-date
Requires: php-hash
Requires: php-pcre
@@ -191,6 +188,9 @@ exit $ret
%changelog
+* Mon Nov 7 2022 Remi Collet <remi@remirepo.net> - 4.6.0-1
+- update to 4.6.0
+
* Fri Sep 16 2022 Remi Collet <remi@remirepo.net> - 4.5.1-1
- update to 4.5.1