summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json13
-rw-r--r--phpunit8-rpm.patch62
-rw-r--r--phpunit8.spec87
3 files changed, 127 insertions, 35 deletions
diff --git a/composer.json b/composer.json
index 8bcd2a9..e5aad89 100644
--- a/composer.json
+++ b/composer.json
@@ -17,7 +17,8 @@
}
],
"support": {
- "issues": "https://github.com/sebastianbergmann/phpunit/issues"
+ "issues": "https://github.com/sebastianbergmann/phpunit/issues",
+ "security": "https://github.com/sebastianbergmann/phpunit/security/policy"
},
"prefer-stable": true,
"require": {
@@ -36,10 +37,10 @@
"phpunit/php-file-iterator": "^2.0.4",
"phpunit/php-text-template": "^1.2.1",
"phpunit/php-timer": "^2.1.2",
- "sebastian/comparator": "^3.0.2",
+ "sebastian/comparator": "^3.0.5",
"sebastian/diff": "^3.0.2",
"sebastian/environment": "^4.2.3",
- "sebastian/exporter": "^3.1.2",
+ "sebastian/exporter": "^3.1.5",
"sebastian/global-state": "^3.0.0",
"sebastian/object-enumerator": "^3.0.3",
"sebastian/resource-operations": "^2.0.1",
@@ -54,9 +55,9 @@
"sort-packages": true
},
"suggest": {
- "phpunit/php-invoker": "^2.0.0",
- "ext-soap": "*",
- "ext-xdebug": "*"
+ "phpunit/php-invoker": "To allow enforcing time limits",
+ "ext-soap": "To be able to generate mocks based on WSDL files",
+ "ext-xdebug": "PHP extension that provides line coverage as well as branch and path coverage"
},
"bin": [
"phpunit"
diff --git a/phpunit8-rpm.patch b/phpunit8-rpm.patch
index 2fe8780..07bbbb6 100644
--- a/phpunit8-rpm.patch
+++ b/phpunit8-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2021-12-30 08:58:05.000000000 +0100
-+++ ./phpunit 2021-12-30 09:01:08.095425016 +0100
+--- ./phpunit.rpm 2024-03-06 09:33:13.000000000 +0100
++++ ./phpunit 2024-04-05 08:00:14.044636630 +0200
@@ -62,27 +62,11 @@ if (isset($GLOBALS['_composer_autoload_p
define('PHPUNIT_COMPOSER_INSTALL', $GLOBALS['_composer_autoload_path']);
@@ -33,20 +33,60 @@ diff -up ./phpunit.rpm ./phpunit
}
$options = getopt('', array('prepend:'));
-@@ -95,4 +79,8 @@ unset($options);
+@@ -95,4 +79,13 @@ unset($options);
require PHPUNIT_COMPOSER_INSTALL;
-PHPUnit\TextUI\Command::main();
-+if (class_exists('PHPUnit_TextUI_Command')) {
-+ PHPUnit_TextUI_Command::main(); // PHPUnit v5 or older
++if (class_exists('PHPUnit\\TextUI\\Application')) {
++ // PHPUnit v10 or newer
++ exit((new PHPUnit\TextUI\Application)->run($_SERVER['argv']));
++} else if (class_exists('PHPUnit_TextUI_Command')) {
++ // PHPUnit v5 or older
++ PHPUnit_TextUI_Command::main();
+} else {
-+ PHPUnit\TextUI\Command::main(); // PHPUnit v6 or newer
++ // PHPUnit v6 to v9
++ PHPUnit\TextUI\Command::main();
+}
+diff -up ./src/TextUI/Command.php.rpm ./src/TextUI/Command.php
+--- ./src/TextUI/Command.php.rpm 2024-03-06 09:33:13.000000000 +0100
++++ ./src/TextUI/Command.php 2024-04-05 08:01:23.626251144 +0200
+@@ -1144,13 +1144,13 @@ class Command
+ $this->printVersionString();
+
+ $latestVersion = file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit');
+- $latestCompatibleVersion = file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit-' . explode('.', Version::series())[0]);
++ $latestCompatibleVersion = file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit-' . $major=explode('.', Version::series())[0]);
+
+ $notLatest = version_compare($latestVersion, Version::id(), '>');
+ $notLatestCompatible = version_compare($latestCompatibleVersion, Version::id(), '>');
+
+ if ($notLatest || $notLatestCompatible) {
+- print 'You are not using the latest version of PHPUnit.' . PHP_EOL;
++ print 'You are not using the latest version of PHPUnit.' . PHP_EOL . PHP_EOL;
+ } else {
+ print 'You are using the latest version of PHPUnit.' . PHP_EOL;
+ }
+@@ -1161,6 +1161,7 @@ class Command
+ Version::id(),
+ $latestCompatibleVersion
+ );
++ printf('Try a system update for new phpunit%s package.' . PHP_EOL . PHP_EOL, $major);
+ }
+
+ if ($notLatest) {
+@@ -1168,6 +1169,7 @@ class Command
+ 'The latest version is PHPUnit %s.' . PHP_EOL,
+ $latestVersion
+ );
++ printf('Try to install and use the phpunit%s command.' . PHP_EOL . PHP_EOL, explode('.', $latestVersion)[0]);
+ }
+
+ exit(TestRunner::SUCCESS_EXIT);
diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
---- ./src/Util/Configuration.php.rpm 2021-12-30 08:58:05.000000000 +0100
-+++ ./src/Util/Configuration.php 2021-12-30 08:58:11.290733945 +0100
-@@ -929,7 +929,7 @@ final class Configuration
+--- ./src/Util/Configuration.php.rpm 2024-03-06 09:33:13.000000000 +0100
++++ ./src/Util/Configuration.php 2024-04-05 08:00:14.044636630 +0200
+@@ -932,7 +932,7 @@ final class Configuration
private function validateConfigurationAgainstSchema(): void
{
$original = libxml_use_internal_errors(true);
@@ -56,8 +96,8 @@ diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
if (defined('__PHPUNIT_PHAR_ROOT__')) {
$xsdFilename = __PHPUNIT_PHAR_ROOT__ . '/phpunit.xsd';
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2021-12-30 08:58:05.000000000 +0100
-+++ ./tests/bootstrap.php 2021-12-30 08:58:11.290733945 +0100
+--- ./tests/bootstrap.php.rpm 2024-03-06 09:33:13.000000000 +0100
++++ ./tests/bootstrap.php 2024-04-05 08:00:14.044636630 +0200
@@ -9,8 +9,8 @@
*/
const TEST_FILES_PATH = __DIR__ . DIRECTORY_SEPARATOR . '_files' . DIRECTORY_SEPARATOR;
diff --git a/phpunit8.spec b/phpunit8.spec
index 263a200..f194a9e 100644
--- a/phpunit8.spec
+++ b/phpunit8.spec
@@ -1,17 +1,18 @@
# remirepo/fedora spec file for phpunit8
#
-# Copyright (c) 2010-2022 Remi Collet
+# Copyright (c) 2010-2024 Remi Collet
#
-# License: CC-BY-SA
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
+# remirepo:2
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit e8c563c47a9a303662955518ca532b022b337f4d
+%global gh_commit 1ecad678646c817a29e55a32c930f3601c3f5a8c
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -25,7 +26,7 @@
%global ver_major 8
%global ver_minor 5
-%global upstream_version 8.5.29
+%global upstream_version 8.5.38
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -33,7 +34,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}
Summary: The PHP Unit Testing framework version %{ver_major}
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{upstream_version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -54,10 +55,10 @@ BuildRequires: (php-composer(phpunit/php-code-coverage) >= 7.0.12 with php-c
BuildRequires: (php-composer(phpunit/php-file-iterator) >= 2.0.4 with php-composer(phpunit/php-file-iterator) < 3)
BuildRequires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
BuildRequires: (php-composer(phpunit/php-timer) >= 2.1.2 with php-composer(phpunit/php-timer) < 3)
-BuildRequires: (php-composer(sebastian/comparator) >= 3.0.2 with php-composer(sebastian/comparator) < 4)
+BuildRequires: (php-composer(sebastian/comparator) >= 3.0.5 with php-composer(sebastian/comparator) < 4)
BuildRequires: (php-composer(sebastian/diff) >= 3.0.2 with php-composer(sebastian/diff) < 4)
BuildRequires: (php-composer(sebastian/environment) >= 4.2.3 with php-composer(sebastian/environment) < 5)
-BuildRequires: (php-composer(sebastian/exporter) >= 3.1.2 with php-composer(sebastian/exporter) < 4)
+BuildRequires: (php-composer(sebastian/exporter) >= 3.1.5 with php-composer(sebastian/exporter) < 4)
BuildRequires: (php-composer(sebastian/global-state) >= 3.0.0 with php-composer(sebastian/global-state) < 4)
BuildRequires: (php-composer(sebastian/object-enumerator) >= 3.0.3 with php-composer(sebastian/object-enumerator) < 4)
BuildRequires: (php-composer(sebastian/resource-operations) >= 2.0.1 with php-composer(sebastian/resource-operations) < 3)
@@ -75,10 +76,10 @@ BuildRequires: php-phpunit-php-code-coverage7 >= 7.0.12
BuildRequires: php-phpunit-php-file-iterator2 >= 2.0.4
BuildRequires: php-phpunit-Text-Template >= 1.2.1
BuildRequires: php-phpunit-php-timer2 >= 2.1.2
-BuildRequires: php-sebastian-comparator3 >= 3.0.2
+BuildRequires: php-sebastian-comparator3 >= 3.0.5
BuildRequires: php-sebastian-diff3 >= 3.0.2
BuildRequires: php-sebastian-environment4 >= 4.2.3
-BuildRequires: php-sebastian-exporter3 >= 3.1.2
+BuildRequires: php-sebastian-exporter3 >= 3.1.5
BuildRequires: php-sebastian-global-state3
BuildRequires: php-sebastian-object-enumerator3 >= 3.0.3
BuildRequires: php-sebastian-resource-operations2 >= 2.0.1
@@ -111,10 +112,10 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "phpunit/php-file-iterator": "^2.0.4",
# "phpunit/php-text-template": "^1.2.1",
# "phpunit/php-timer": "^2.1.2",
-# "sebastian/comparator": "^3.0.2",
+# "sebastian/comparator": "^3.0.5",
# "sebastian/diff": "^3.0.2",
# "sebastian/environment": "^4.2.3",
-# "sebastian/exporter": "^3.1.2",
+# "sebastian/exporter": "^3.1.5",
# "sebastian/global-state": "^3.0.0",
# "sebastian/object-enumerator": "^3.0.3",
# "sebastian/resource-operations": "^2.0.1",
@@ -139,10 +140,10 @@ Requires: (php-composer(phpunit/php-code-coverage) >= 7.0.12 with php-c
Requires: (php-composer(phpunit/php-file-iterator) >= 2.0.4 with php-composer(phpunit/php-file-iterator) < 3)
Requires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
Requires: (php-composer(phpunit/php-timer) >= 2.1.2 with php-composer(phpunit/php-timer) < 3)
-Requires: (php-composer(sebastian/comparator) >= 3.0.2 with php-composer(sebastian/comparator) < 4)
+Requires: (php-composer(sebastian/comparator) >= 3.0.5 with php-composer(sebastian/comparator) < 4)
Requires: (php-composer(sebastian/diff) >= 3.0.2 with php-composer(sebastian/diff) < 4)
Requires: (php-composer(sebastian/environment) >= 4.2.3 with php-composer(sebastian/environment) < 5)
-Requires: (php-composer(sebastian/exporter) >= 3.1.2 with php-composer(sebastian/exporter) < 4)
+Requires: (php-composer(sebastian/exporter) >= 3.1.5 with php-composer(sebastian/exporter) < 4)
Requires: (php-composer(sebastian/global-state) >= 3.0.0 with php-composer(sebastian/global-state) < 4)
Requires: (php-composer(sebastian/object-enumerator) >= 3.0.3 with php-composer(sebastian/object-enumerator) < 4)
Requires: (php-composer(sebastian/resource-operations) >= 2.0.1 with php-composer(sebastian/resource-operations) < 3)
@@ -155,6 +156,10 @@ Requires: (php-composer(sebastian/version) >= 2.0.1 with php-c
Requires: (php-composer(phpunit/php-invoker) >= 2.0.0 with php-composer(phpunit/php-invoker) < 3)
Suggests: php-soap
Suggests: php-xdebug
+# recommends latest versions
+Recommends: phpunit9
+Recommends: phpunit10
+Recommends: phpunit11
# remirepo:21
%else
Requires: php-doctrine-instantiator >= 1.3.1
@@ -166,10 +171,10 @@ Requires: php-phpunit-php-code-coverage7 >= 7.0.12
Requires: php-phpunit-php-file-iterator2 >= 2.0.4
Requires: php-phpunit-Text-Template >= 1.2.1
Requires: php-phpunit-php-timer2 >= 2.1.2
-Requires: php-sebastian-comparator3 >= 3.0.2
+Requires: php-sebastian-comparator3 >= 3.0.5
Requires: php-sebastian-diff3 >= 3.0.2
Requires: php-sebastian-environment4 >= 4.2.3
-Requires: php-sebastian-exporter3 >= 3.1.2
+Requires: php-sebastian-exporter3 >= 3.1.5
Requires: php-sebastian-global-state3
Requires: php-sebastian-object-enumerator3 >= 3.0.3
Requires: php-sebastian-resource-operations2 >= 2.0.1
@@ -187,6 +192,11 @@ Requires: php-pcre
Requires: php-phar
Requires: php-spl
+%if 0%{?fedora} >= 39 || 0%{?rhel} >= 10
+Provides: php-composer(phpunit/phpunit) = %{version}
+Provides: phpunit = %{version}-%{release}
+%endif
+
%description
PHPUnit is a programmer-oriented testing framework for PHP.
@@ -200,7 +210,9 @@ Documentation: https://phpunit.readthedocs.io/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p0 -b .rpm
+%patch -P0 -p0 -b .rpm
+
+#find . -name \*.rpm -delete -print
%build
@@ -216,7 +228,6 @@ cat << 'EOF' | tee -a src/autoload.php
'%{php_home}/Text/Template/Autoload.php',
'%{php_home}/SebastianBergmann/CodeCoverage7/autoload.php',
'%{php_home}/SebastianBergmann/Timer/autoload.php',
- '%{php_home}/Prophecy/autoload.php',
'%{php_home}/SebastianBergmann/Diff3/autoload.php', // Before comparator which may load v2
'%{php_home}/SebastianBergmann/Comparator3/autoload.php',
'%{php_home}/SebastianBergmann/Environment4/autoload.php',
@@ -231,6 +242,8 @@ cat << 'EOF' | tee -a src/autoload.php
'%{php_home}/SebastianBergmann/Invoker/autoload.php',
'%{php_home}/PharIo/Manifest2/autoload.php',
'%{php_home}/PharIo/Version3/autoload.php',
+ // May load Comparator/RecursionContext bad version
+ '%{php_home}/Prophecy/autoload.php',
]);
// Extensions
\Fedora\Autoloader\Dependencies::optional(
@@ -263,7 +276,7 @@ sed -e 's:@PATH@:%{buildroot}%{php_home}/%{ns_vendor}:' -i tests/bootstrap.php
sed -e 's:%{php_home}/%{ns_vendor}:%{buildroot}%{php_home}/%{ns_vendor}:' -i phpunit
ret=0
-for cmd in php php74 php80 php81 php82; do
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd ./phpunit $OPT --verbose || ret=1
fi
@@ -282,6 +295,44 @@ exit $ret
%changelog
+* Fri Apr 5 2024 Remi Collet <remi@remirepo.net> - 8.5.38-1
+- update to 8.5.38 (no change)
+
+* Wed Mar 6 2024 Remi Collet <remi@remirepo.net> - 8.5.37-2
+- improve --check-version for RPM
+
+* Wed Mar 6 2024 Remi Collet <remi@remirepo.net> - 8.5.37-1
+- update to 8.5.37
+
+* Fri Dec 22 2023 Remi Collet <remi@remirepo.net> - 8.5.36-2
+- fix possible autoloader issue with phpspec/prophecy
+
+* Sat Dec 2 2023 Remi Collet <remi@remirepo.net> - 8.5.36-1
+- update to 8.5.36 (no change)
+
+* Fri Dec 1 2023 Remi Collet <remi@remirepo.net> - 8.5.35-1
+- update to 8.5.35 (no change)
+
+* Tue Sep 19 2023 Remi Collet <remi@remirepo.net> - 8.5.34-1
+- update to 8.5.34
+
+* Tue Feb 28 2023 Remi Collet <remi@remirepo.net> - 8.5.33-1
+- update to 8.5.33
+
+* Sat Feb 4 2023 Remi Collet <remi@remirepo.net> - 8.5.32-2
+- adapt launcher for phpunit10
+
+* Thu Jan 26 2023 Remi Collet <remi@remirepo.net> - 8.5.32-1
+- update to 8.5.32
+
+* Fri Oct 28 2022 Remi Collet <remi@remirepo.net> - 8.5.31-1
+- update to 8.5.31
+
+* Sun Sep 25 2022 Remi Collet <remi@remirepo.net> - 8.5.30-1
+- update to 8.5.30
+- raise dependency on sebastian/comparator 3.0.2
+- raise dependency on sebastian/exporter 3.1.5
+
* Tue Aug 30 2022 Remi Collet <remi@remirepo.net> - 8.5.29-1
- update to 8.5.29
- keep dependency on phpspec/prophecy (optional)