summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-04-05 08:17:30 +0200
committerRemi Collet <remi@php.net>2024-04-05 08:17:30 +0200
commitf59489d140651770f58a14b19243fdabf97a0236 (patch)
treee25cf713491ff3a55d05421879abbd4dea169238
parent30a3580b7fb3be0b7933399c624a4abd703718b6 (diff)
update to 8.5.38 (no change)HEADmaster
-rw-r--r--phpunit8-rpm.patch23
-rw-r--r--phpunit8.spec11
2 files changed, 22 insertions, 12 deletions
diff --git a/phpunit8-rpm.patch b/phpunit8-rpm.patch
index 700bc8a..07bbbb6 100644
--- a/phpunit8-rpm.patch
+++ b/phpunit8-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
--- ./phpunit.rpm 2024-03-06 09:33:13.000000000 +0100
-+++ ./phpunit 2024-03-06 10:01:01.286282118 +0100
++++ ./phpunit 2024-04-05 08:00:14.044636630 +0200
@@ -62,27 +62,11 @@ if (isset($GLOBALS['_composer_autoload_p
define('PHPUNIT_COMPOSER_INSTALL', $GLOBALS['_composer_autoload_path']);
@@ -49,9 +49,9 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main();
+}
diff -up ./src/TextUI/Command.php.rpm ./src/TextUI/Command.php
---- ./src/TextUI/Command.php.rpm 2024-03-06 10:01:47.658055200 +0100
-+++ ./src/TextUI/Command.php 2024-03-06 10:07:26.195999614 +0100
-@@ -1144,7 +1144,7 @@ class Command
+--- ./src/TextUI/Command.php.rpm 2024-03-06 09:33:13.000000000 +0100
++++ ./src/TextUI/Command.php 2024-04-05 08:01:23.626251144 +0200
+@@ -1144,13 +1144,13 @@ class Command
$this->printVersionString();
$latestVersion = file_get_contents('https://phar.phpunit.de/latest-version-of/phpunit');
@@ -60,11 +60,18 @@ diff -up ./src/TextUI/Command.php.rpm ./src/TextUI/Command.php
$notLatest = version_compare($latestVersion, Version::id(), '>');
$notLatestCompatible = version_compare($latestCompatibleVersion, Version::id(), '>');
+
+ if ($notLatest || $notLatestCompatible) {
+- print 'You are not using the latest version of PHPUnit.' . PHP_EOL;
++ print 'You are not using the latest version of PHPUnit.' . PHP_EOL . PHP_EOL;
+ } else {
+ print 'You are using the latest version of PHPUnit.' . PHP_EOL;
+ }
@@ -1161,6 +1161,7 @@ class Command
Version::id(),
$latestCompatibleVersion
);
-+ printf('Try a system update for new phpunit%s package.' . PHP_EOL, $major);
++ printf('Try a system update for new phpunit%s package.' . PHP_EOL . PHP_EOL, $major);
}
if ($notLatest) {
@@ -72,13 +79,13 @@ diff -up ./src/TextUI/Command.php.rpm ./src/TextUI/Command.php
'The latest version is PHPUnit %s.' . PHP_EOL,
$latestVersion
);
-+ printf('Try to install and use the phpunit%s command.' . PHP_EOL, explode('.', $latestVersion)[0]);
++ printf('Try to install and use the phpunit%s command.' . PHP_EOL . PHP_EOL, explode('.', $latestVersion)[0]);
}
exit(TestRunner::SUCCESS_EXIT);
diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
--- ./src/Util/Configuration.php.rpm 2024-03-06 09:33:13.000000000 +0100
-+++ ./src/Util/Configuration.php 2024-03-06 10:01:01.286282118 +0100
++++ ./src/Util/Configuration.php 2024-04-05 08:00:14.044636630 +0200
@@ -932,7 +932,7 @@ final class Configuration
private function validateConfigurationAgainstSchema(): void
{
@@ -90,7 +97,7 @@ diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
$xsdFilename = __PHPUNIT_PHAR_ROOT__ . '/phpunit.xsd';
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
--- ./tests/bootstrap.php.rpm 2024-03-06 09:33:13.000000000 +0100
-+++ ./tests/bootstrap.php 2024-03-06 10:01:01.286282118 +0100
++++ ./tests/bootstrap.php 2024-04-05 08:00:14.044636630 +0200
@@ -9,8 +9,8 @@
*/
const TEST_FILES_PATH = __DIR__ . DIRECTORY_SEPARATOR . '_files' . DIRECTORY_SEPARATOR;
diff --git a/phpunit8.spec b/phpunit8.spec
index 59fdc05..f194a9e 100644
--- a/phpunit8.spec
+++ b/phpunit8.spec
@@ -12,7 +12,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit fce30f306cee78be33ba00c8f9a853f41db0491b
+%global gh_commit 1ecad678646c817a29e55a32c930f3601c3f5a8c
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -26,12 +26,12 @@
%global ver_major 8
%global ver_minor 5
-%global upstream_version 8.5.37
+%global upstream_version 8.5.38
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: The PHP Unit Testing framework version %{ver_major}
License: BSD-3-Clause
@@ -212,7 +212,7 @@ Documentation: https://phpunit.readthedocs.io/
%setup -q -n %{gh_project}-%{gh_commit}
%patch -P0 -p0 -b .rpm
-find . -name \*.rpm -delete -print
+#find . -name \*.rpm -delete -print
%build
@@ -295,6 +295,9 @@ exit $ret
%changelog
+* Fri Apr 5 2024 Remi Collet <remi@remirepo.net> - 8.5.38-1
+- update to 8.5.38 (no change)
+
* Wed Mar 6 2024 Remi Collet <remi@remirepo.net> - 8.5.37-2
- improve --check-version for RPM