summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-27 11:45:53 +0100
committerRemi Collet <remi@remirepo.net>2020-10-27 11:45:53 +0100
commit7eb586569dfc7c998bca8fe8cef7a9c86492365e (patch)
tree0d5f864acbcc9fc09d4c2f331806fcc099680f4d
parenta4ddacc3b089f3df8bb8c1121b4bf6348d55e1e2 (diff)
add patch for test suite on 32-bit from
https://github.com/sebastianbergmann/php-timer/pull/36
-rw-r--r--36.patch97
-rw-r--r--php-phpunit-php-timer5.spec13
2 files changed, 105 insertions, 5 deletions
diff --git a/36.patch b/36.patch
new file mode 100644
index 0000000..1520ede
--- /dev/null
+++ b/36.patch
@@ -0,0 +1,97 @@
+From b6cd6cc52ef13dc996d3e19d3d78bd1bf1eb6bce Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 27 Oct 2020 11:38:32 +0100
+Subject: [PATCH] Fix #34 test failing on 32-bit
+
+---
+ tests/DurationTest.php | 70 +++++++++++++++++++++---------------------
+ 1 file changed, 35 insertions(+), 35 deletions(-)
+
+diff --git a/tests/DurationTest.php b/tests/DurationTest.php
+index d8ba2a0..2129757 100644
+--- a/tests/DurationTest.php
++++ b/tests/DurationTest.php
+@@ -43,7 +43,7 @@ public function testCanBeCreatedFromMicroseconds(): void
+ * @dataProvider durationProvider
+ * @testdox Formats $microseconds microseconds as "$string"
+ */
+- public function testCanBeFormattedAsString(string $string, int $microseconds): void
++ public function testCanBeFormattedAsString(string $string, float $microseconds): void
+ {
+ $duration = Duration::fromMicroseconds($microseconds);
+
+@@ -53,40 +53,40 @@ public function testCanBeFormattedAsString(string $string, int $microseconds): v
+ public function durationProvider(): array
+ {
+ return [
+- ['00:00', (int) round((0 * 1000000))],
+- ['00:00.001', (int) round((.001 * 1000000))],
+- ['00:00.010', (int) round((.01 * 1000000))],
+- ['00:00.100', (int) round((.1 * 1000000))],
+- ['00:00.999', (int) round((.999 * 1000000))],
+- ['00:00.999', (int) round((.9999 * 1000000))],
+- ['00:01', (int) round((1 * 1000000))],
+- ['00:02', (int) round((2 * 1000000))],
+- ['00:59.900', (int) round((59.9 * 1000000))],
+- ['00:59.990', (int) round((59.99 * 1000000))],
+- ['00:59.999', (int) round((59.999 * 1000000))],
+- ['00:59.999', (int) round((59.9999 * 1000000))],
+- ['00:59.001', (int) round((59.001 * 1000000))],
+- ['00:59.010', (int) round((59.01 * 1000000))],
+- ['01:00', (int) round((60 * 1000000))],
+- ['01:01', (int) round((61 * 1000000))],
+- ['02:00', (int) round((120 * 1000000))],
+- ['02:01', (int) round((121 * 1000000))],
+- ['59:59.900', (int) round((3599.9 * 1000000))],
+- ['59:59.990', (int) round((3599.99 * 1000000))],
+- ['59:59.999', (int) round((3599.999 * 1000000))],
+- ['59:59.999', (int) round((3599.9999 * 1000000))],
+- ['59:59.001', (int) round((3599.001 * 1000000))],
+- ['59:59.010', (int) round((3599.01 * 1000000))],
+- ['01:00:00', (int) round((3600 * 1000000))],
+- ['01:00:01', (int) round((3601 * 1000000))],
+- ['01:00:01.900', (int) round((3601.9 * 1000000))],
+- ['01:00:01.990', (int) round((3601.99 * 1000000))],
+- ['01:00:01.999', (int) round((3601.999 * 1000000))],
+- ['01:00:01.999', (int) round((3601.9999 * 1000000))],
+- ['01:00:59.999', (int) round((3659.9999 * 1000000))],
+- ['01:00:59.001', (int) round((3659.001 * 1000000))],
+- ['01:00:59.010', (int) round((3659.01 * 1000000))],
+- ['01:59:59.999', (int) round((7199.9999 * 1000000))],
++ ['00:00', round((0 * 1000000))],
++ ['00:00.001', round((.001 * 1000000))],
++ ['00:00.010', round((.01 * 1000000))],
++ ['00:00.100', round((.1 * 1000000))],
++ ['00:00.999', round((.999 * 1000000))],
++ ['00:00.999', round((.9999 * 1000000))],
++ ['00:01', round((1 * 1000000))],
++ ['00:02', round((2 * 1000000))],
++ ['00:59.900', round((59.9 * 1000000))],
++ ['00:59.990', round((59.99 * 1000000))],
++ ['00:59.999', round((59.999 * 1000000))],
++ ['00:59.999', round((59.9999 * 1000000))],
++ ['00:59.001', round((59.001 * 1000000))],
++ ['00:59.010', round((59.01 * 1000000))],
++ ['01:00', round((60 * 1000000))],
++ ['01:01', round((61 * 1000000))],
++ ['02:00', round((120 * 1000000))],
++ ['02:01', round((121 * 1000000))],
++ ['59:59.900', round((3599.9 * 1000000))],
++ ['59:59.990', round((3599.99 * 1000000))],
++ ['59:59.999', round((3599.999 * 1000000))],
++ ['59:59.999', round((3599.9999 * 1000000))],
++ ['59:59.001', round((3599.001 * 1000000))],
++ ['59:59.010', round((3599.01 * 1000000))],
++ ['01:00:00', round((3600 * 1000000))],
++ ['01:00:01', round((3601 * 1000000))],
++ ['01:00:01.900', round((3601.9 * 1000000))],
++ ['01:00:01.990', round((3601.99 * 1000000))],
++ ['01:00:01.999', round((3601.999 * 1000000))],
++ ['01:00:01.999', round((3601.9999 * 1000000))],
++ ['01:00:59.999', round((3659.9999 * 1000000))],
++ ['01:00:59.001', round((3659.001 * 1000000))],
++ ['01:00:59.010', round((3659.01 * 1000000))],
++ ['01:59:59.999', round((7199.9999 * 1000000))],
+ ];
+ }
+ }
diff --git a/php-phpunit-php-timer5.spec b/php-phpunit-php-timer5.spec
index 2697b6d..9e08e30 100644
--- a/php-phpunit-php-timer5.spec
+++ b/php-phpunit-php-timer5.spec
@@ -25,7 +25,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 5.0.3
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: PHP Utility class for timing, version %{major}
License: BSD
@@ -33,6 +33,8 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/sebastianbergmann/php-timer/pull/36.patch
+
BuildArch: noarch
BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
@@ -60,6 +62,7 @@ component.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
%build
@@ -81,14 +84,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-if [ $(php -r 'echo PHP_INT_SIZE;') -lt 8 ]; then
- filter="--filter '^((?!(testCanBeFormattedAsString)).)*$'"
-fi
for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit9 \
- $filter \
--verbose || ret=1
fi
done
@@ -107,6 +106,10 @@ exit $ret
%changelog
+* Tue Oct 27 2020 Remi Collet <remi@remirepo.net> - 5.0.3-2
+- add patch for test suite on 32-bit from
+ https://github.com/sebastianbergmann/php-timer/pull/36
+
* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 5.0.3-1
- update to 5.0.3
- open https://github.com/sebastianbergmann/php-timer/issues/34