summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-26 15:52:47 +0100
committerRemi Collet <remi@remirepo.net>2020-10-26 15:52:47 +0100
commita4ddacc3b089f3df8bb8c1121b4bf6348d55e1e2 (patch)
tree45722fc18ea5ce92919095f9ec95d2181df63cca
parent7371157eec6270c000b88b48a8cddc5cc460ca82 (diff)
fix arch detection
-rw-r--r--php-phpunit-php-timer5.spec7
1 files changed, 4 insertions, 3 deletions
diff --git a/php-phpunit-php-timer5.spec b/php-phpunit-php-timer5.spec
index 60dc025..2697b6d 100644
--- a/php-phpunit-php-timer5.spec
+++ b/php-phpunit-php-timer5.spec
@@ -81,13 +81,14 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
+if [ $(php -r 'echo PHP_INT_SIZE;') -lt 8 ]; then
+ filter="--filter '^((?!(testCanBeFormattedAsString)).)*$'"
+fi
for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit9 \
-%if %{__isa_bits} < 64
- --filter '^((?!(testCanBeFormattedAsString)).)*$' \
-%endif
+ $filter \
--verbose || ret=1
fi
done