summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-12-28 09:33:34 +0100
committerRemi Collet <fedora@famillecollet.com>2014-12-28 09:33:34 +0100
commita3e8bd8d223b7a97d1539337e77f87522b78141b (patch)
tree5700ca827fce2b96cc3a05efb64d7b1dd7ee8334
parent0fa35a7a84b75eb6bb07b283f0f3f2f83afdb38f (diff)
php-phpunit-PHPUnit: 4.4.1
-rw-r--r--php-phpunit-PHPUnit.spec7
-rw-r--r--phpunit-rpm.patch17
2 files changed, 14 insertions, 10 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index 7538a59..440ce0d 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit bbe7bcb83b6ec1a9eaabbe1b70d4795027c53ee0
+%global gh_commit 6a5e49a86ce5e33b8d0657abe145057fc513543a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -17,7 +17,7 @@
%global pear_channel pear.phpunit.de
Name: php-phpunit-PHPUnit
-Version: 4.4.0
+Version: 4.4.1
Release: 1%{?dist}
Summary: The PHP Unit Testing framework
@@ -200,6 +200,9 @@ fi
%changelog
+* Sun Dec 28 2014 Remi Collet <remi@fedoraproject.org> - 4.4.1-1
+- Update to 4.4.1
+
* Fri Dec 5 2014 Remi Collet <remi@fedoraproject.org> - 4.4.0-1
- Update to 4.4.0
- add dependency on sebastian/global-state
diff --git a/phpunit-rpm.patch b/phpunit-rpm.patch
index ea37f78..f1a1173 100644
--- a/phpunit-rpm.patch
+++ b/phpunit-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2014-12-05 07:49:03.000000000 +0100
-+++ ./phpunit 2014-12-05 09:19:29.774284886 +0100
+--- ./phpunit.rpm 2014-12-28 08:57:05.000000000 +0100
++++ ./phpunit 2014-12-28 09:30:07.294714996 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/env php
+#!/usr/bin/php
@@ -8,7 +8,7 @@ diff -up ./phpunit.rpm ./phpunit
/* PHPUnit
*
@@ -39,24 +39,7 @@ if (!ini_get('date.timezone')) {
- ini_set('date.timezone', 'UTC');
+ ini_set('date.timezone', 'UTC');
}
-foreach (array(__DIR__ . '/../../autoload.php', __DIR__ . '/../vendor/autoload.php', __DIR__ . '/vendor/autoload.php') as $file) {
@@ -34,15 +34,16 @@ diff -up ./phpunit.rpm ./phpunit
PHPUnit_TextUI_Command::main();
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2014-12-05 07:49:03.000000000 +0100
-+++ ./tests/bootstrap.php 2014-12-05 09:18:19.614014475 +0100
-@@ -1,5 +1,8 @@
+--- ./tests/bootstrap.php.rpm 2014-12-28 09:28:16.402309771 +0100
++++ ./tests/bootstrap.php 2014-12-28 09:28:45.638416606 +0100
+@@ -1,6 +1,9 @@
<?php
+ // Needed for isolated tests
-require __DIR__ . '/../vendor/autoload.php';
+require __DIR__ . '/../src/Framework/Assert/Functions.php';
+require __DIR__ . '/_files/CoveredFunction.php';
+require __DIR__ . '/../src/Autoload.php';
+require __DIR__ . '/autoload.php';
- if (!ini_get('date.timezone') && !defined('HHVM_VERSION')) {
- echo PHP_EOL . 'Error: PHPUnit\'s test suite requires the "date.timezone" runtime configuration to be set. Please check your php.ini.' . PHP_EOL;
+ ini_set('precision', 14);
+ ini_set('serialize_precision', 14);