summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-12-05 09:28:50 +0100
committerRemi Collet <fedora@famillecollet.com>2014-12-05 09:28:50 +0100
commit0fa35a7a84b75eb6bb07b283f0f3f2f83afdb38f (patch)
treed6e51d40616d4a4d92777152f4182a2477d9ba91
parentdadb12858e6d7104186b7e86fe896fbe8f5cfc07 (diff)
PHPUnit 4.4.0
-rw-r--r--Autoload.php.in1
-rw-r--r--php-phpunit-PHPUnit.spec19
-rw-r--r--phpunit-colors.patch47
-rw-r--r--phpunit-rpm.patch28
4 files changed, 25 insertions, 70 deletions
diff --git a/Autoload.php.in b/Autoload.php.in
index c95ad17..6c8355a 100644
--- a/Autoload.php.in
+++ b/Autoload.php.in
@@ -13,6 +13,7 @@ require_once 'SebastianBergmann/Environment/autoload.php';
require_once 'SebastianBergmann/Exporter/autoload.php';
require_once 'SebastianBergmann/Version/autoload.php';
require_once 'SebastianBergmann/Comparator/autoload.php';
+require_once 'SebastianBergmann/GlobalState/autoload.php';
$vendorDir = '/usr/share/php';
require_once $vendorDir . '/Symfony/Component/ClassLoader/UniversalClassLoader.php';
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index 93f6277..7538a59 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2dab9d593997db4abcf58d0daf798eb4e9cecfe1
+%global gh_commit bbe7bcb83b6ec1a9eaabbe1b70d4795027c53ee0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -17,7 +17,7 @@
%global pear_channel pear.phpunit.de
Name: php-phpunit-PHPUnit
-Version: 4.3.5
+Version: 4.4.0
Release: 1%{?dist}
Summary: The PHP Unit Testing framework
@@ -31,8 +31,6 @@ Source1: Autoload.php.in
# Fix command for autoload
Patch0: %{gh_project}-rpm.patch
-# https://github.com/sebastianbergmann/phpunit/pull/1458
-Patch1: %{gh_project}-colors.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -47,6 +45,7 @@ BuildRequires: php-composer(sebastian/comparator) >= 1.0
BuildRequires: php-composer(sebastian/diff) >= 1.1
BuildRequires: php-composer(sebastian/environment) >= 1.1
BuildRequires: php-composer(sebastian/exporter) >= 1.0
+BuildRequires: php-composer(sebastian/global-state) >= 1.0
BuildRequires: php-composer(sebastian/version) >= 1.0
BuildRequires: php-composer(symfony/yaml) >= 2.0
BuildRequires: php-composer(symfony/class-loader) >= 2.0
@@ -64,6 +63,7 @@ BuildRequires: php-composer(phpunit/php-invoker) >= 1.1.0
# "sebastian/diff": "~1.1",
# "sebastian/environment": "~1.1",
# "sebastian/exporter": "~1.0",
+# "sebastian/global-state": "~1.0",
# "sebastian/version": "~1.0",
# "ext-dom": "*",
# "ext-json": "*",
@@ -89,6 +89,8 @@ Requires: php-composer(sebastian/environment) >= 1.1
Requires: php-composer(sebastian/environment) < 2
Requires: php-composer(sebastian/exporter) >= 1.0
Requires: php-composer(sebastian/exporter) < 2
+Requires: php-composer(sebastian/global-state) >= 1.0
+Requires: php-composer(sebastian/global-state) < 2
Requires: php-composer(sebastian/version) >= 1.0
Requires: php-composer(sebastian/version) < 2
Requires: php-composer(symfony/yaml) >= 2.0
@@ -140,11 +142,6 @@ for the creation, execution and analysis of Unit Tests.
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0 -b .rpm
-%patch1 -p1
-
-# https://github.com/sebastianbergmann/phpunit/pull/1500
-chmod -x src/Util/Blacklist.php \
- src/Util/GlobalState.php
%build
@@ -203,6 +200,10 @@ fi
%changelog
+* Fri Dec 5 2014 Remi Collet <remi@fedoraproject.org> - 4.4.0-1
+- Update to 4.4.0
+- add dependency on sebastian/global-state
+
* Tue Nov 11 2014 Remi Collet <remi@fedoraproject.org> - 4.3.5-1
- Update to 4.3.5
- define date.timezone in phpunit command to avoid warning
diff --git a/phpunit-colors.patch b/phpunit-colors.patch
deleted file mode 100644
index 9c0a8f9..0000000
--- a/phpunit-colors.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 3d56c46afb9ed10b0d248fb0ea698aa22d939421 Mon Sep 17 00:00:00 2001
-From: Sebastian Bergmann <sb@sebastian-bergmann.de>
-Date: Tue, 7 Oct 2014 11:29:29 +0200
-Subject: [PATCH] Rework 591efd8fad55a526f021cad9c6cbcd9081df8969
-
----
- composer.json | 2 +-
- src/TextUI/ResultPrinter.php | 6 +++++-
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/composer.json b/composer.json
-index 9dc9950..ae6ff27 100644
---- a/composer.json
-+++ b/composer.json
-@@ -30,7 +30,7 @@
- "symfony/yaml": "~2.0",
- "sebastian/comparator": "~1.0",
- "sebastian/diff": "~1.1",
-- "sebastian/environment": "~1.0",
-+ "sebastian/environment": "~1.1",
- "sebastian/exporter": "~1.0",
- "sebastian/version": "~1.0",
- "ext-dom": "*",
-diff --git a/src/TextUI/ResultPrinter.php b/src/TextUI/ResultPrinter.php
-index ca16c8a..e701e33 100644
---- a/src/TextUI/ResultPrinter.php
-+++ b/src/TextUI/ResultPrinter.php
-@@ -43,6 +43,8 @@
- * @since File available since Release 2.0.0
- */
-
-+use SebastianBergmann\Environment\Console;
-+
- /**
- * Prints the result of a TextUI TestRunner run.
- *
-@@ -147,7 +149,9 @@ public function __construct($out = null, $verbose = false, $colors = false, $deb
- }
-
- if (is_bool($colors)) {
-- $this->colors = $colors;
-+ $console = new Console;
-+
-+ $this->colors = $colors && $console->hasColorSupport();
- } else {
- throw PHPUnit_Util_InvalidArgumentHelper::factory(3, 'boolean');
- }
diff --git a/phpunit-rpm.patch b/phpunit-rpm.patch
index a0ec349..ea37f78 100644
--- a/phpunit-rpm.patch
+++ b/phpunit-rpm.patch
@@ -1,41 +1,41 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2014-10-03 07:17:00.000000000 +0200
-+++ ./phpunit 2014-10-03 11:09:31.304175626 +0200
+--- ./phpunit.rpm 2014-12-05 07:49:03.000000000 +0100
++++ ./phpunit 2014-12-05 09:19:29.774284886 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/env php
+#!/usr/bin/php
<?php
/* PHPUnit
*
-@@ -35,22 +35,10 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
+@@ -39,24 +39,7 @@ if (!ini_get('date.timezone')) {
+ ini_set('date.timezone', 'UTC');
+ }
+
-foreach (array(__DIR__ . '/../../autoload.php', __DIR__ . '/../vendor/autoload.php', __DIR__ . '/vendor/autoload.php') as $file) {
- if (file_exists($file)) {
- define('PHPUNIT_COMPOSER_INSTALL', $file);
- break;
- }
-+if (!ini_get('date.timezone')) {
-+ ini_set('date.timezone', 'UTC');
- }
+-}
-
-unset($file);
-
-if (!defined('PHPUNIT_COMPOSER_INSTALL')) {
-- echo 'You need to set up the project dependencies using the following commands:' . PHP_EOL .
+- fwrite(STDERR,
+- 'You need to set up the project dependencies using the following commands:' . PHP_EOL .
- 'wget http://getcomposer.org/composer.phar' . PHP_EOL .
-- 'php composer.phar install' . PHP_EOL;
+- 'php composer.phar install' . PHP_EOL
+- );
- die(1);
-}
-
+define ('PHPUNIT_COMPOSER_INSTALL', stream_resolve_include_path('PHPUnit/Autoload.php'));
require PHPUNIT_COMPOSER_INSTALL;
-
+
PHPUnit_TextUI_Command::main();
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2014-08-17 17:36:46.325953778 +0200
-+++ ./tests/bootstrap.php 2014-08-17 17:37:54.634043416 +0200
+--- ./tests/bootstrap.php.rpm 2014-12-05 07:49:03.000000000 +0100
++++ ./tests/bootstrap.php 2014-12-05 09:18:19.614014475 +0100
@@ -1,5 +1,8 @@
<?php
-require __DIR__ . '/../vendor/autoload.php';