summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-05-17 15:56:33 +0200
committerRemi Collet <remi@php.net>2023-05-17 15:56:33 +0200
commit13d4a2c242d7efe9e8dde76aa315c5409c60ce4d (patch)
tree49ce96e6874e58eb3e76b3e140332e7578b033d9
parent9ae2d1f727a1ccc415c3f4d23f8560cf6ff20265 (diff)
update to 1.21.0
-rw-r--r--composer.json1
-rw-r--r--php-phpstan-phpdoc-parser.spec16
2 files changed, 13 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index 3b902ae..30b879b 100644
--- a/composer.json
+++ b/composer.json
@@ -6,6 +6,7 @@
"php": "^7.2 || ^8.0"
},
"require-dev": {
+ "nikic/php-parser": "^4.15",
"php-parallel-lint/php-parallel-lint": "^1.2",
"phpstan/extension-installer": "^1.0",
"phpstan/phpstan": "^1.5",
diff --git a/php-phpstan-phpdoc-parser.spec b/php-phpstan-phpdoc-parser.spec
index a38eb17..bfa0425 100644
--- a/php-phpstan-phpdoc-parser.spec
+++ b/php-phpstan-phpdoc-parser.spec
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit 7d568c87a9df9c5f7e8b5f075fc469aa8cb0a4cd
+%global gh_commit 6df62b08faef4f899772bc7c3bbabb93d2b7a21c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpstan
%global gh_project phpdoc-parser
@@ -19,7 +19,7 @@
%global major %nil
Name: php-%{gh_owner}-%{gh_project}%{major}
-Version: 1.20.4
+Version: 1.21.0
Release: 1%{?dist}
Summary: PHPDoc parser with support for nullable, intersection and generic types
@@ -36,6 +36,7 @@ BuildRequires: php(language) >= 7.2
BuildRequires: php-json
BuildRequires: php-pcre
# From composer, "require-dev": {
+# "nikic/php-parser": "^4.15",
# "php-parallel-lint/php-parallel-lint": "^1.2",
# "phpstan/extension-installer": "^1.0",
# "phpstan/phpstan": "^1.5",
@@ -82,13 +83,17 @@ cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}%{major}
%check
%if %{with tests}
mkdir vendor
-phpab --template fedora --output vendor/autoload.php tests
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}\\%{library}\\', dirname(__DIR__) . '/tests/%{namespace}');
+EOF
: ignore tests using symfony/process
rm tests/PHPStan/Parser/FuzzyTest.php
: upstream test suite
-# use auto_prepend_file to ensure we use new version
+# use auto_prepend_file to ensure we use new version (not old one pulled by PHPUnit)
ret=0
for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
@@ -117,6 +122,9 @@ exit $ret
%changelog
+* Wed May 17 2023 Remi Collet <remi@remirepo.net> - 1.21.0-1
+- update to 1.21.0
+
* Wed May 3 2023 Remi Collet <remi@remirepo.net> - 1.20.4-1
- update to 1.20.4