summaryrefslogtreecommitdiffstats
path: root/php-phpstan-phpdoc-parser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpstan-phpdoc-parser.spec')
-rw-r--r--php-phpstan-phpdoc-parser.spec16
1 files changed, 12 insertions, 4 deletions
diff --git a/php-phpstan-phpdoc-parser.spec b/php-phpstan-phpdoc-parser.spec
index a38eb17..bfa0425 100644
--- a/php-phpstan-phpdoc-parser.spec
+++ b/php-phpstan-phpdoc-parser.spec
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit 7d568c87a9df9c5f7e8b5f075fc469aa8cb0a4cd
+%global gh_commit 6df62b08faef4f899772bc7c3bbabb93d2b7a21c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpstan
%global gh_project phpdoc-parser
@@ -19,7 +19,7 @@
%global major %nil
Name: php-%{gh_owner}-%{gh_project}%{major}
-Version: 1.20.4
+Version: 1.21.0
Release: 1%{?dist}
Summary: PHPDoc parser with support for nullable, intersection and generic types
@@ -36,6 +36,7 @@ BuildRequires: php(language) >= 7.2
BuildRequires: php-json
BuildRequires: php-pcre
# From composer, "require-dev": {
+# "nikic/php-parser": "^4.15",
# "php-parallel-lint/php-parallel-lint": "^1.2",
# "phpstan/extension-installer": "^1.0",
# "phpstan/phpstan": "^1.5",
@@ -82,13 +83,17 @@ cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}%{major}
%check
%if %{with tests}
mkdir vendor
-phpab --template fedora --output vendor/autoload.php tests
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}\\%{library}\\', dirname(__DIR__) . '/tests/%{namespace}');
+EOF
: ignore tests using symfony/process
rm tests/PHPStan/Parser/FuzzyTest.php
: upstream test suite
-# use auto_prepend_file to ensure we use new version
+# use auto_prepend_file to ensure we use new version (not old one pulled by PHPUnit)
ret=0
for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
@@ -117,6 +122,9 @@ exit $ret
%changelog
+* Wed May 17 2023 Remi Collet <remi@remirepo.net> - 1.21.0-1
+- update to 1.21.0
+
* Wed May 3 2023 Remi Collet <remi@remirepo.net> - 1.20.4-1
- update to 1.20.4