summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-03 13:57:06 +0100
committerRemi Collet <remi@remirepo.net>2020-11-03 13:57:06 +0100
commitb2ec5c99411b2b4debc9b85d1dad245b798930c3 (patch)
tree0842a453ba3de6a822b629e3653098e64fb55fa1
parent4fc92c3fe73975ae5f9a8abb2bd75262368ed4d0 (diff)
update to 7.0.0
raise dependency on PHP 7.3 raise dependency on Symfony 4.4
-rw-r--r--composer.json16
-rw-r--r--php-phpspec.spec38
2 files changed, 29 insertions, 25 deletions
diff --git a/composer.json b/composer.json
index f1735c0..90150a3 100644
--- a/composer.json
+++ b/composer.json
@@ -22,15 +22,15 @@
],
"require": {
- "php": "^7.2, <7.5",
+ "php": "^7.3 || 8.0.*",
"phpspec/prophecy": "^1.9",
"phpspec/php-diff": "^1.0.0",
- "sebastian/exporter": "^1.0 || ^2.0 || ^3.0 || ^4.0",
- "symfony/console": "^3.4 || ^4.0 || ^5.0",
- "symfony/event-dispatcher": "^3.4 || ^4.0 || ^5.0",
- "symfony/process": "^3.4 || ^4.0 || ^5.0",
- "symfony/finder": "^3.4 || ^4.0 || ^5.0",
- "symfony/yaml": "^3.4 || ^4.0 || ^5.0",
+ "sebastian/exporter": "^3.0 || ^4.0",
+ "symfony/console": "^3.4 || ^4.4 || ^5.0",
+ "symfony/event-dispatcher": "^3.4 || ^4.4 || ^5.0",
+ "symfony/process": "^3.4 || ^4.4 || ^5.0",
+ "symfony/finder": "^3.4 || ^4.4 || ^5.0",
+ "symfony/yaml": "^3.4 || ^4.4 || ^5.0",
"doctrine/instantiator": "^1.0.5",
"ext-tokenizer": "*"
},
@@ -65,7 +65,7 @@
"extra": {
"branch-alias": {
- "dev-master": "6.2.x-dev"
+ "dev-main": "7.0.x-dev"
}
}
diff --git a/php-phpspec.spec b/php-phpspec.spec
index 33fddff..e5fe779 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -13,7 +13,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 90c4758976af797d485e1f5b8e65df8de981c561
+%global gh_commit 9b82625c790d9092d3b9a50358358834d4713766
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
@@ -22,11 +22,11 @@
# Only allow a single Symfony version
# to ensure components consistency
%global symfony_ns Symfony4
-%global symfony_min 4.0
+%global symfony_min 4.4
%global symfony_max 5
Name: php-phpspec
-Version: 6.2.2
+Version: 7.0.0
Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
@@ -40,7 +40,7 @@ Source1: %{gh_project}-autoload.php
Patch0: %{gh_project}-4-rpm.patch
BuildArch: noarch
-BuildRequires: php(language) >= 7.2
+BuildRequires: php(language) >= 7.3
%if %{with tests}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -65,30 +65,26 @@ BuildRequires: php-symfony4-yaml >= %{symfony_min}
# "symfony/filesystem": "^3.4 || ^4.0 || ^5.0",
# "phpunit/phpunit": "^8.0 || ^9.0",
BuildRequires: php-symfony4-filesystem >= %{symfony_min}
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
%global phpunit %{_bindir}/phpunit9
-%else
-%global phpunit %{_bindir}/phpunit8
-%endif
BuildRequires: %{phpunit}
%endif
# Autoloader
BuildRequires: php-composer(fedora/autoloader) >= 1
# From composer.json, require
-# "php": "^7.2, <7.5",
+# "php": "^7.3 || 8.0.*",
# "phpspec/prophecy": "^1.9",
# "phpspec/php-diff": "^1.0.0",
-# "sebastian/exporter": "^1.0 || ^2.0 || ^3.0 || ^4.0",
-# "symfony/console": "^3.2 || ^4.0 || ^5.0",
-# "symfony/event-dispatcher": "^3.2 || ^4.0 || ^5.0",
-# "symfony/process": "^3.2 || ^4.0 || ^5.0",
-# "symfony/finder": "^3.2 || ^4.0 || ^5.0",
-# "symfony/yaml": "^3.2 || ^4.0 || ^5.0",
+# "sebastian/exporter": "^3.0 || ^4.0",
+# "symfony/console": "^3.4 || ^4.4 || ^5.0",
+# "symfony/event-dispatcher": "^3.4 || ^4.4 || ^5.0",
+# "symfony/process": "^3.4 || ^4.4 || ^5.0",
+# "symfony/finder": "^3.4 || ^4.4 || ^5.0",
+# "symfony/yaml": "^3.4 || ^4.4 || ^5.0",
# "doctrine/instantiator": "^1.0.5"
# "ext-tokenizer": "*"
-Requires: php(language) >= 7.2
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpspec/prophecy) >= 1.9 with php-composer(phpspec/prophecy) < 2)
@@ -168,7 +164,7 @@ rm spec/PhpSpec/NamespaceProvider/ComposerPsrNamespaceProviderSpec.php
sed -e 's/it_compare_array_of_objects_to_and_displays_its_properties/skipit1/' \
-i spec/PhpSpec/Formatter/Presenter/Differ/ArrayEngineSpec.php
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=1G -d include_path=.:%{buildroot}%{_datadir}/php \
@@ -193,6 +189,14 @@ done
%changelog
+* Tue Nov 3 2020 Remi Collet <remi@remirepo.net> - 7.0.0-1
+- update to 7.0.0
+- raise dependency on PHP 7.3
+- raise dependency on Symfony 4.4
+
+* Mon Nov 2 2020 Remi Collet <remi@remirepo.net> - 6.3.0-1
+- update to 6.3.0
+
* Thu Oct 29 2020 Remi Collet <remi@remirepo.net> - 6.2.2-1
- update to 6.2.2
- switch to phpunit9