summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-29 08:33:45 +0100
committerRemi Collet <remi@remirepo.net>2020-10-29 08:33:45 +0100
commit4fc92c3fe73975ae5f9a8abb2bd75262368ed4d0 (patch)
tree6f1556c41895d443b7c2ecd2fa5ecae1d2b4d432
parent547850eaf0f6e0bc51f95d0778062fc2693e96d2 (diff)
update to 6.2.2
switch to phpunit9
-rw-r--r--.gitignore2
-rw-r--r--composer.json2
-rw-r--r--php-phpspec.spec31
3 files changed, 24 insertions, 11 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index 631c495..f1735c0 100644
--- a/composer.json
+++ b/composer.json
@@ -38,7 +38,7 @@
"require-dev": {
"behat/behat": "^3.3",
"symfony/filesystem": "^3.4 || ^4.0 || ^5.0",
- "phpunit/phpunit": "^7.0"
+ "phpunit/phpunit": "^8.0 || ^9.0"
},
"suggest": {
diff --git a/php-phpspec.spec b/php-phpspec.spec
index b2c2dda..33fddff 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -7,16 +7,17 @@
# Please, preserve the changelog entries
#
+# passes in local build, fails in mock
+%bcond_with tests
+
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit a40d53c8564f97eca75919769f93410dd3dba5e8
+%global gh_commit 90c4758976af797d485e1f5b8e65df8de981c561
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
#global prever beta3
-# passes in local build, fails in mock
-%bcond_with tests
# Only allow a single Symfony version
# to ensure components consistency
@@ -25,7 +26,7 @@
%global symfony_max 5
Name: php-phpspec
-Version: 6.2.1
+Version: 6.2.2
Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
@@ -62,9 +63,14 @@ BuildRequires: php-symfony4-yaml >= %{symfony_min}
# From composer.json, require-dev
# "behat/behat": "^3.3",
# "symfony/filesystem": "^3.4 || ^4.0 || ^5.0",
-# "phpunit/phpunit": "^7.0",
+# "phpunit/phpunit": "^8.0 || ^9.0",
BuildRequires: php-symfony4-filesystem >= %{symfony_min}
-BuildRequires: phpunit7
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+%else
+%global phpunit %{_bindir}/phpunit8
+%endif
+BuildRequires: %{phpunit}
%endif
# Autoloader
BuildRequires: php-composer(fedora/autoloader) >= 1
@@ -162,13 +168,14 @@ rm spec/PhpSpec/NamespaceProvider/ComposerPsrNamespaceProviderSpec.php
sed -e 's/it_compare_array_of_objects_to_and_displays_its_properties/skipit1/' \
-i spec/PhpSpec/Formatter/Presenter/Differ/ArrayEngineSpec.php
-for cmd in php php72 php73 php74; do
- if which $cmd; then
- $cmd -d memory_limit=1G -d include_path=.:%{buildroot}%{_datadir}/php \
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 -d memory_limit=1G -d include_path=.:%{buildroot}%{_datadir}/php \
bin/phpspec \
run --format pretty --verbose --no-ansi
- $cmd %{_bindir}/phpunit7 \
+ $1 ${2:-%{_bindir}/phpunit9} \
--verbose \
--bootstrap %{buildroot}%{_datadir}/php/PhpSpec/autoload.php
fi
@@ -186,6 +193,10 @@ done
%changelog
+* Thu Oct 29 2020 Remi Collet <remi@remirepo.net> - 6.2.2-1
+- update to 6.2.2
+- switch to phpunit9
+
* Wed Jul 8 2020 Remi Collet <remi@remirepo.net> - 6.2.1-1
- update to 6.2.1