summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-08 18:18:21 +0200
committerRemi Collet <remi@remirepo.net>2020-07-08 18:18:21 +0200
commit547850eaf0f6e0bc51f95d0778062fc2693e96d2 (patch)
tree84ad7afc73a2fbdcf7e1c0c18105eb6e21d5d6d1
parentb85a117ff5a09f6eb2eecb49c55dbd050c707f2f (diff)
update to 6.2.1
-rw-r--r--composer.json4
-rw-r--r--php-phpspec.spec27
-rw-r--r--phpspec-autoload.php5
3 files changed, 23 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index e665867..631c495 100644
--- a/composer.json
+++ b/composer.json
@@ -25,7 +25,7 @@
"php": "^7.2, <7.5",
"phpspec/prophecy": "^1.9",
"phpspec/php-diff": "^1.0.0",
- "sebastian/exporter": "^1.0 || ^2.0 || ^3.0",
+ "sebastian/exporter": "^1.0 || ^2.0 || ^3.0 || ^4.0",
"symfony/console": "^3.4 || ^4.0 || ^5.0",
"symfony/event-dispatcher": "^3.4 || ^4.0 || ^5.0",
"symfony/process": "^3.4 || ^4.0 || ^5.0",
@@ -65,7 +65,7 @@
"extra": {
"branch-alias": {
- "dev-master": "6.1.x-dev"
+ "dev-master": "6.2.x-dev"
}
}
diff --git a/php-phpspec.spec b/php-phpspec.spec
index 5217599..b2c2dda 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpspec
#
-# Copyright (c) 2015-2019 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,13 +10,13 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 486aaa736e9e24f3e22a6545f6affb88f98e2602
+%global gh_commit a40d53c8564f97eca75919769f93410dd3dba5e8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
#global prever beta3
# passes in local build, fails in mock
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
# Only allow a single Symfony version
# to ensure components consistency
@@ -25,7 +25,7 @@
%global symfony_max 5
Name: php-phpspec
-Version: 6.1.1
+Version: 6.2.1
Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
@@ -40,12 +40,12 @@ Patch0: %{gh_project}-4-rpm.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.2
-%if %{with_tests}
+%if %{with tests}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(phpspec/prophecy) >= 1.9 with php-composer(phpspec/prophecy) < 2)
BuildRequires: (php-composer(phpspec/php-diff) >= 1.0.0 with php-composer(phpspec/php-diff) < 2)
-BuildRequires: (php-composer(sebastian/exporter) >= 3 with php-composer(sebastian/exporter) < 4)
+BuildRequires: (php-composer(sebastian/exporter) >= 3 with php-composer(sebastian/exporter) < 5)
BuildRequires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 2)
# remirepo:6
%else
@@ -73,7 +73,7 @@ BuildRequires: php-composer(fedora/autoloader) >= 1
# "php": "^7.2, <7.5",
# "phpspec/prophecy": "^1.9",
# "phpspec/php-diff": "^1.0.0",
-# "sebastian/exporter": "^1.0 || ^2.0 || ^3.0",
+# "sebastian/exporter": "^1.0 || ^2.0 || ^3.0 || ^4.0",
# "symfony/console": "^3.2 || ^4.0 || ^5.0",
# "symfony/event-dispatcher": "^3.2 || ^4.0 || ^5.0",
# "symfony/process": "^3.2 || ^4.0 || ^5.0",
@@ -87,7 +87,7 @@ Requires: php(language) >= 7.2
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpspec/prophecy) >= 1.9 with php-composer(phpspec/prophecy) < 2)
Requires: (php-composer(phpspec/php-diff) >= 1.0.0 with php-composer(phpspec/php-diff) < 2)
-Requires: (php-composer(sebastian/exporter) >= 3 with php-composer(sebastian/exporter) < 4)
+Requires: (php-composer(sebastian/exporter) >= 3 with php-composer(sebastian/exporter) < 5)
Requires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 2)
# remirepo:6
%else
@@ -151,7 +151,7 @@ install -Dpm755 bin/phpspec %{buildroot}%{_bindir}/phpspec
%check
-%if %{with_tests}
+%if %{with tests}
export LANG=C.UTF-8
# Ignore this test which use bossa/phpspec2-expect
@@ -162,7 +162,7 @@ rm spec/PhpSpec/NamespaceProvider/ComposerPsrNamespaceProviderSpec.php
sed -e 's/it_compare_array_of_objects_to_and_displays_its_properties/skipit1/' \
-i spec/PhpSpec/Formatter/Presenter/Differ/ArrayEngineSpec.php
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd -d memory_limit=1G -d include_path=.:%{buildroot}%{_datadir}/php \
bin/phpspec \
@@ -186,6 +186,13 @@ done
%changelog
+* Wed Jul 8 2020 Remi Collet <remi@remirepo.net> - 6.2.1-1
+- update to 6.2.1
+
+* Wed Jun 17 2020 Remi Collet <remi@remirepo.net> - 6.2.0-1
+- update to 6.2.0
+- allow sebastian/exporter 4
+
* Thu Dec 19 2019 Remi Collet <remi@remirepo.net> - 6.1.1-1
- update to 6.1.1
diff --git a/phpspec-autoload.php b/phpspec-autoload.php
index b7858c6..c65711c 100644
--- a/phpspec-autoload.php
+++ b/phpspec-autoload.php
@@ -20,5 +20,8 @@ if (is_dir(getcwd().'/spec')) {
'phpspec/php-diff/autoload.php',
'Prophecy/autoload.php',
'Doctrine/Instantiator/autoload.php',
- 'SebastianBergmann/Exporter3/autoload.php',
+ [
+ 'SebastianBergmann/Exporter4/autoload.php',
+ 'SebastianBergmann/Exporter3/autoload.php',
+ ],
]);