summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-06 08:06:17 +0100
committerRemi Collet <remi@remirepo.net>2020-03-06 08:06:17 +0100
commita9efe3f80b96b29ea090ace4a64b53d8f2069578 (patch)
tree527a36153c48d2be2210043d851abac0f69e822e
parentad686690e323de5c5ac0dd4a87fb7df133618821 (diff)
update to 1.10.3
allow phpdocumentor/reflection-docblock 5.0
-rw-r--r--php-phpspec-prophecy-autoload.php4
-rw-r--r--php-phpspec-prophecy.spec10
2 files changed, 10 insertions, 4 deletions
diff --git a/php-phpspec-prophecy-autoload.php b/php-phpspec-prophecy-autoload.php
index b844b2a..f4b72b2 100644
--- a/php-phpspec-prophecy-autoload.php
+++ b/php-phpspec-prophecy-autoload.php
@@ -9,7 +9,9 @@ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
// Dependencies
require_once 'Doctrine/Instantiator/autoload.php';
-if ($dep = stream_resolve_include_path('phpDocumentor/Reflection/DocBlock4/autoload.php')) {
+if ($dep = stream_resolve_include_path('phpDocumentor/Reflection/DocBlock5/autoload.php')) {
+ require_once $dep;
+} else if ($dep = stream_resolve_include_path('phpDocumentor/Reflection/DocBlock4/autoload.php')) {
require_once $dep;
} else if ($dep = stream_resolve_include_path('phpDocumentor/Reflection/DocBlock/autoload.php')) {
require_once $dep;
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index 47ec721..f3dab27 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit b4400efc9d206e83138e2bb97ed7f5b14b831cd9
+%global gh_commit 451c3cd1418cf640de218914901e51b064abb093
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -19,7 +19,7 @@
%endif
Name: php-phpspec-prophecy
-Version: 1.10.2
+Version: 1.10.3
Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
@@ -49,7 +49,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "sebastian/recursion-context": "^1.0|^2.0|^3.0|^4.0"
Requires: php(language) >= 5.3
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(phpdocumentor/reflection-docblock) >= 2.0 with php-composer(phpdocumentor/reflection-docblock) < 5)
+Requires: (php-composer(phpdocumentor/reflection-docblock) >= 2.0 with php-composer(phpdocumentor/reflection-docblock) < 6)
Requires: (php-composer(sebastian/comparator) >= 1.2.3 with php-composer(sebastian/comparator) < 5)
# recursion-context will be pulled by phpspec or phpunit or phpunit6
#Requires: (php-composer(sebastian/recursion-context) >= 1.0 with php-composer(sebastian/recursion-context) < 4)
@@ -139,6 +139,10 @@ exit $ret
# not yet packaged
%changelog
+* Fri Mar 6 2020 Remi Collet <remi@remirepo.net> - 1.10.3-1
+- update to 1.10.3
+- allow phpdocumentor/reflection-docblock 5.0
+
* Tue Jan 21 2020 Remi Collet <remi@remirepo.net> - 1.10.2-1
- update to 1.10.2
- allow sebastian/comparator 4 and sebastian/recursion-context 4