summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-21 08:32:20 +0100
committerRemi Collet <remi@remirepo.net>2020-01-21 08:32:20 +0100
commitad686690e323de5c5ac0dd4a87fb7df133618821 (patch)
tree6211f3365cea856c8e184893bb41108a62971fe0
parent5f86da8f95df7e963c896eb96e7bc34713dd45a1 (diff)
update to 1.10.2
allow sebastian/comparator 4 and sebastian/recursion-context 4
-rw-r--r--composer.json4
-rw-r--r--php-phpspec-prophecy-autoload.php9
-rw-r--r--php-phpspec-prophecy.spec14
3 files changed, 17 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index d54ef7a..7151160 100644
--- a/composer.json
+++ b/composer.json
@@ -20,9 +20,9 @@
"require": {
"php": "^5.3|^7.0",
"phpdocumentor/reflection-docblock": "^2.0|^3.0.2|^4.0|^5.0",
- "sebastian/comparator": "^1.2.3|^2.0|^3.0",
+ "sebastian/comparator": "^1.2.3|^2.0|^3.0|^4.0",
"doctrine/instantiator": "^1.0.2",
- "sebastian/recursion-context": "^1.0|^2.0|^3.0"
+ "sebastian/recursion-context": "^1.0|^2.0|^3.0|^4.0"
},
"require-dev": {
diff --git a/php-phpspec-prophecy-autoload.php b/php-phpspec-prophecy-autoload.php
index 3a2b120..b844b2a 100644
--- a/php-phpspec-prophecy-autoload.php
+++ b/php-phpspec-prophecy-autoload.php
@@ -22,10 +22,13 @@ if ($dep = stream_resolve_include_path('phpDocumentor/Reflection/DocBlock4/autol
unset($dep);
if (!class_exists('SebastianBergmann\\Comparator\\Comparator')) { // v2 from phpunit, v1 from phpspec
- require_once (stream_resolve_include_path('SebastianBergmann/Comparator3/autoload.php') ?:
+ require_once (stream_resolve_include_path('SebastianBergmann/Comparator4/autoload.php') ?:
+ (stream_resolve_include_path('SebastianBergmann/Comparator3/autoload.php') ?:
(stream_resolve_include_path('SebastianBergmann/Comparator2/autoload.php') ?:
- 'SebastianBergmann/Comparator/autoload.php'));
+ 'SebastianBergmann/Comparator/autoload.php')));
}
if (!class_exists('SebastianBergmann\\RecursionContext\\Context')) { // v3 from phpunit, v2 from phpspec (via exporter)
- require_once (stream_resolve_include_path('SebastianBergmann/RecursionContext3/autoload.php') ?: 'SebastianBergmann/RecursionContext/autoload.php');
+ require_once (stream_resolve_include_path('SebastianBergmann/RecursionContext4/autoload.php') ?:
+ (stream_resolve_include_path('SebastianBergmann/RecursionContext3/autoload.php') ?:
+ 'SebastianBergmann/RecursionContext/autoload.php'));
}
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index d1960c3..47ec721 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit cbe1df668b3fe136bcc909126a0f529a78d4cbbc
+%global gh_commit b4400efc9d206e83138e2bb97ed7f5b14b831cd9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -19,7 +19,7 @@
%endif
Name: php-phpspec-prophecy
-Version: 1.10.1
+Version: 1.10.2
Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
@@ -44,13 +44,13 @@ BuildRequires: php-composer(fedora/autoloader)
# from composer.json, "requires": {
# "php": "^5.3|^7.0",
# "phpdocumentor/reflection-docblock": "^2.0|^3.0.2|^4.0|^5.0",
-# "sebastian/comparator": "^1.2.3|^2.0|^3.0",
+# "sebastian/comparator": "^1.2.3|^2.0|^3.0|^4.0",
# "doctrine/instantiator": "^1.0.2",
-# "sebastian/recursion-context": "^1.0|^2.0|^3.0"
+# "sebastian/recursion-context": "^1.0|^2.0|^3.0|^4.0"
Requires: php(language) >= 5.3
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpdocumentor/reflection-docblock) >= 2.0 with php-composer(phpdocumentor/reflection-docblock) < 5)
-Requires: (php-composer(sebastian/comparator) >= 1.2.3 with php-composer(sebastian/comparator) < 4)
+Requires: (php-composer(sebastian/comparator) >= 1.2.3 with php-composer(sebastian/comparator) < 5)
# recursion-context will be pulled by phpspec or phpunit or phpunit6
#Requires: (php-composer(sebastian/recursion-context) >= 1.0 with php-composer(sebastian/recursion-context) < 4)
# use 1.0.4 to ensure we have the autoloader
@@ -139,6 +139,10 @@ exit $ret
# not yet packaged
%changelog
+* Tue Jan 21 2020 Remi Collet <remi@remirepo.net> - 1.10.2-1
+- update to 1.10.2
+- allow sebastian/comparator 4 and sebastian/recursion-context 4
+
* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 1.10.1-1
- update to 1.10.1