summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-03 08:55:00 +0100
committerRemi Collet <remi@php.net>2023-02-03 08:55:00 +0100
commit51a0e0d2c39b85f0ccda27603b6d12f42558e3fa (patch)
treea02b78ef64ca8fa5f27d890cffd53daf0c16eaf0
parenta23448543b27e0371818736a4ac09c72a8ca904a (diff)
update to 1.17.0
allow doctrine/instantiator v2
-rw-r--r--composer.json6
-rw-r--r--php-phpspec-prophecy.spec26
2 files changed, 21 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 551da0c..5a27095 100644
--- a/composer.json
+++ b/composer.json
@@ -21,12 +21,13 @@
"php": "^7.2 || 8.0.* || 8.1.* || 8.2.*",
"phpdocumentor/reflection-docblock": "^5.2",
"sebastian/comparator": "^3.0 || ^4.0",
- "doctrine/instantiator": "^1.2",
+ "doctrine/instantiator": "^1.2 || ^2.0",
"sebastian/recursion-context": "^3.0 || ^4.0"
},
"require-dev": {
"phpspec/phpspec": "^6.0 || ^7.0",
+ "phpstan/phpstan": "^1.9",
"phpunit/phpunit": "^8.0 || ^9.0"
},
@@ -38,7 +39,8 @@
"autoload-dev": {
"psr-4": {
- "Fixtures\\Prophecy\\": "fixtures"
+ "Fixtures\\Prophecy\\": "fixtures",
+ "Tests\\Prophecy\\": "tests"
}
},
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index 32cbe4f..8c8f1db 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-phpspec-prophecy
#
-# Copyright (c) 2015-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit be8cac52a0827776ff9ccda8c381ac5b71aeb359
+%global gh_commit 15873c65b207b07765dbc3c95d20fdf4a320cbe2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -14,7 +14,7 @@
%bcond_without tests
Name: php-phpspec-prophecy
-Version: 1.16.0
+Version: 1.17.0
Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
@@ -31,7 +31,7 @@ BuildRequires: php(language) >= 7.2
BuildRequires: (php-composer(phpdocumentor/reflection-docblock) >= 5.2 with php-composer(phpdocumentor/reflection-docblock) < 6)
BuildRequires: (php-composer(sebastian/comparator) >= 3.0 with php-composer(sebastian/comparator) < 5)
BuildRequires: (php-composer(sebastian/recursion-context) >= 3.0 with php-composer(sebastian/recursion-context) < 5)
-BuildRequires: (php-composer(doctrine/instantiator) >= 1.2 with php-composer(doctrine/instantiator) < 2)
+BuildRequires: (php-composer(doctrine/instantiator) >= 1.2 with php-composer(doctrine/instantiator) < 3)
# remirepo:6
%else
BuildRequires: php-phpdocumentor-reflection-docblock5 >= 5.2
@@ -41,6 +41,7 @@ BuildRequires: php-doctrine-instantiator >= 1.2
%endif
# from composer.json, "require-dev": {
# "phpspec/phpspec": "^6.0 | ^7.0"
+# "phpstan/phpstan": "^1.9",
# "phpunit/phpunit": "^8.0 || ^9.0"
BuildRequires: php-composer(phpspec/phpspec) >= 6.0
%global phpunit %{_bindir}/phpunit9
@@ -53,7 +54,7 @@ BuildRequires: php-fedora-autoloader-devel
# "php": "^7.2 || 8.0.* || 8.1.* || 8.2.*",
# "phpdocumentor/reflection-docblock": "^5.2",
# "sebastian/comparator": "^3.0|^4.0",
-# "doctrine/instantiator": "^1.2",
+# "doctrine/instantiator": "^1.2 || ^2.0",
# "sebastian/recursion-context": "^3.0|^4.0"
Requires: php(language) >= 7.2
# remirepo:1
@@ -61,7 +62,7 @@ Requires: php(language) >= 7.2
Requires: (php-composer(phpdocumentor/reflection-docblock) >= 5.2 with php-composer(phpdocumentor/reflection-docblock) < 6)
Requires: (php-composer(sebastian/comparator) >= 3.0 with php-composer(sebastian/comparator) < 5)
Requires: (php-composer(sebastian/recursion-context) >= 3.0 with php-composer(sebastian/recursion-context) < 5)
-Requires: (php-composer(doctrine/instantiator) >= 1.2 with php-composer(doctrine/instantiator) < 2)
+Requires: (php-composer(doctrine/instantiator) >= 1.2 with php-composer(doctrine/instantiator) < 3)
# remirepo:6
%else
Requires: php-phpdocumentor-reflection-docblock5 >= 5.2
@@ -96,7 +97,10 @@ phpab --template fedora --output src/Prophecy/autoload.php src
cat << 'EOF' | tee -a src/Prophecy/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{_datadir}/php/Doctrine/Instantiator/autoload.php',
+ [
+ '%{_datadir}/php/Doctrine/Instantiator2/autoload.php',
+ '%{_datadir}/php/Doctrine/Instantiator/autoload.php',
+ ],
'%{_datadir}/php/phpDocumentor/Reflection/DocBlock5/autoload.php',
]);
if (!class_exists('SebastianBergmann\\Comparator\\Comparator')) { // v2 from phpunit, v1 from phpspec
@@ -127,7 +131,7 @@ cp -pr src/* %{buildroot}%{_datadir}/php
%if %{with tests}
: Dev autoloader
mkdir vendor
-phpab --output vendor/autoload.php fixtures
+phpab --output vendor/autoload.php fixtures tests
cat << 'EOF' | tee -a vendor/autoload.php
require_once '%{buildroot}%{_datadir}/php/Prophecy/autoload.php';
@@ -169,6 +173,10 @@ exit $ret
%changelog
+* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 1.17.0-1
+- update to 1.17.0
+- allow doctrine/instantiator v2
+
* Thu Dec 1 2022 Remi Collet <remi@remirepo.net> - 1.16.0-1
- update to 1.16.0