summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-01 11:28:37 +0100
committerRemi Collet <remi@php.net>2022-12-01 11:28:37 +0100
commita23448543b27e0371818736a4ac09c72a8ca904a (patch)
tree9e737e61a11b0f94acec845fa83fb39e0c6f721e
parent72dbb3fb4885c87b142faff6ffd1dee89ba422c1 (diff)
update to 1.16.0
-rw-r--r--composer.json2
-rw-r--r--php-phpspec-prophecy.spec13
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 129a4cf..551da0c 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
],
"require": {
- "php": "^7.2 || ~8.0, <8.2",
+ "php": "^7.2 || 8.0.* || 8.1.* || 8.2.*",
"phpdocumentor/reflection-docblock": "^5.2",
"sebastian/comparator": "^3.0 || ^4.0",
"doctrine/instantiator": "^1.2",
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index 961590c..32cbe4f 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-phpspec-prophecy
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit bbcd7380b0ebf3961ee21409db7b38bc31d69a13
+%global gh_commit be8cac52a0827776ff9ccda8c381ac5b71aeb359
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -14,7 +14,7 @@
%bcond_without tests
Name: php-phpspec-prophecy
-Version: 1.15.0
+Version: 1.16.0
Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
@@ -50,7 +50,7 @@ BuildRequires: %{phpunit}
BuildRequires: php-fedora-autoloader-devel
# from composer.json, "requires": {
-# "php": "^7.2 || ~8.0, <8.2",
+# "php": "^7.2 || 8.0.* || 8.1.* || 8.2.*",
# "phpdocumentor/reflection-docblock": "^5.2",
# "sebastian/comparator": "^3.0|^4.0",
# "doctrine/instantiator": "^1.2",
@@ -141,7 +141,7 @@ phpspec --version
ret=0
# ignore it_can_not_double_an_enum on all version. Not ready
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 -d auto_prepend_file=vendor/autoload.php \
@@ -169,6 +169,9 @@ exit $ret
%changelog
+* Thu Dec 1 2022 Remi Collet <remi@remirepo.net> - 1.16.0-1
+- update to 1.16.0
+
* Wed Dec 8 2021 Remi Collet <remi@remirepo.net> - 1.15.0-1
- update to 1.15.0