summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-07 17:45:43 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-07 17:45:43 +0200
commitb50343047e76871ffaa83451d0a22d22f7fa14cf (patch)
tree22d4b33cfd54213ce41b28401001aeef0aad6253
parent8b17204b380fa7569faf15b9a7b3c90c06c6d654 (diff)
php-phpseclib-*: 0.3.7
-rw-r--r--php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch16
-rw-r--r--php-phpseclib-net-ssh2.spec16
2 files changed, 19 insertions, 13 deletions
diff --git a/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch b/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch
index 893222a..a8d9776 100644
--- a/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch
+++ b/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch
@@ -1,16 +1,16 @@
-diff -up Net_SSH2-0.3.6/SSH2.php.orig Net_SSH2-0.3.6/SSH2.php
---- Net_SSH2-0.3.6/SSH2.php.orig 2014-02-26 18:06:35.698241870 +0100
-+++ Net_SSH2-0.3.6/SSH2.php 2014-02-26 18:17:42.433603190 +0100
-@@ -1060,7 +1060,7 @@ class Net_SSH2
+diff -up Net_SSH2-0.3.7/SSH2.php.orig Net_SSH2-0.3.7/SSH2.php
+--- Net_SSH2-0.3.7/SSH2.php.orig 2014-07-07 17:36:06.047391436 +0200
++++ Net_SSH2-0.3.7/SSH2.php 2014-07-07 17:38:56.852300410 +0200
+@@ -1147,7 +1147,7 @@ class Net_SSH2
array('twofish128-ctr', 'twofish192-ctr', 'twofish256-ctr', 'twofish128-cbc', 'twofish192-cbc', 'twofish256-cbc', 'twofish-cbc')
);
}
-- if (!$this->_is_includable('Crypt/Blowfish.php')) {
-+ if (!$this->_is_includable('Crypt/Blowfish-phpseclib.php')) {
+- if (phpseclib_resolve_include_path('Crypt/Blowfish.php') === false) {
++ if (phpseclib_resolve_include_path('Crypt/Blowfish-phpseclib.php') === false) {
$encryption_algorithms = array_diff(
$encryption_algorithms,
array('blowfish-ctr', 'blowfish-cbc')
-@@ -1428,14 +1428,14 @@ class Net_SSH2
+@@ -1515,14 +1515,14 @@ class Net_SSH2
break;
case 'blowfish-cbc':
if (!class_exists('Crypt_Blowfish')) {
@@ -27,7 +27,7 @@ diff -up Net_SSH2-0.3.6/SSH2.php.orig Net_SSH2-0.3.6/SSH2.php
}
$this->encrypt = new Crypt_Blowfish(CRYPT_BLOWFISH_MODE_CTR);
$this->encrypt_block_size = 8;
-@@ -1504,14 +1504,14 @@ class Net_SSH2
+@@ -1591,14 +1591,14 @@ class Net_SSH2
break;
case 'blowfish-cbc':
if (!class_exists('Crypt_Blowfish')) {
diff --git a/php-phpseclib-net-ssh2.spec b/php-phpseclib-net-ssh2.spec
index d29dec8..2835ff0 100644
--- a/php-phpseclib-net-ssh2.spec
+++ b/php-phpseclib-net-ssh2.spec
@@ -2,7 +2,7 @@
%global pear_name Net_SSH2
Name: php-phpseclib-net-ssh2
-Version: 0.3.6
+Version: 0.3.7
Release: 1%{?dist}
Summary: Pure-PHP implementation of SSHv2
@@ -17,10 +17,12 @@ Patch0: php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
+BuildRequires: php-channel(phpseclib.sourceforge.net)
Requires(post): %{__pear}
Requires(postun): %{__pear}
Requires: php-pear(PEAR)
+Requires: php-channel(phpseclib.sourceforge.net)
Requires: php-pear(phpseclib.sourceforge.net/Math_BigInteger) >= 0.3.0
Requires: php-pear(phpseclib.sourceforge.net/Crypt_Random) >= 0.3.0
Requires: php-pear(phpseclib.sourceforge.net/Crypt_Hash) >= 0.3.0
@@ -29,25 +31,26 @@ Requires: php-pear(phpseclib.sourceforge.net/Crypt_RC4) >= 0.3.0
Requires: php-pear(phpseclib.sourceforge.net/Crypt_AES) >= 0.3.0
Requires: php-pear(phpseclib.sourceforge.net/Crypt_Twofish) >= 0.3.0
Requires: php-pear(phpseclib.sourceforge.net/Crypt_Blowfish) >= 0.3.0
-Provides: php-pear(phpseclib.sourceforge.net/Net_SSH2) = %{version}
-BuildRequires: php-channel(phpseclib.sourceforge.net)
-Requires: php-channel(phpseclib.sourceforge.net)
# phpcompatinfo, generated from 0.3.5
Requires: php-pcre
Requires: php-xml
+Provides: php-pear(phpseclib.sourceforge.net/Net_SSH2) = %{version}
+
+
%description
Pure-PHP implementation of SSHv2.
%prep
%setup -q -c
-pushd %{pear_name}-%{version}
+cd %{pear_name}-%{version}
# Fix line endings of file we're about to patch
sed -e 's/\r//' -i SSH2.php
%patch0 -p1
# Drop md5sum of patched file from the PEAR manifest (or else it'll complain)
sed -e '/SSH2.php/s/md5sum="[^"]*"//' \
../package.xml >%{name}.xml
+touch -r ../package.xml %{name}.xml
%build
@@ -90,6 +93,9 @@ fi
%changelog
+* Mon Jul 07 2014 Remi Collet <remi@fedoraproject.org> - 0.3.7-1
+- Update to 0.3.7
+
* Wed Feb 26 2014 Remi Collet <remi@fedoraproject.org> - 0.3.6-1
- Update to 0.3.6