summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-02-26 18:25:38 +0100
committerRemi Collet <fedora@famillecollet.com>2014-02-26 18:25:38 +0100
commit8b17204b380fa7569faf15b9a7b3c90c06c6d654 (patch)
tree2700bde5ed1a0a5b13ccac7e8775e304727e2fae
parent0ccebfde4cd12eb77321d1af0e66f0575ae939d1 (diff)
php-phpseclib-*: 0.3.6
-rw-r--r--php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch41
-rw-r--r--php-phpseclib-net-ssh2.spec23
2 files changed, 35 insertions, 29 deletions
diff --git a/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch b/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch
index e5f8f2d..893222a 100644
--- a/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch
+++ b/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch
@@ -1,43 +1,46 @@
-Description: Fix Crypt_Blowfish conflict
- Rename Crypt/Blowfish.php into Crypt/Blowfish-phpseclib.php so it can
- be co-installed with Crypt_Blowfish from PEAR (php-crypt-blowfish
- package).
-Author: David Prévot <taffit@tilapin.org>
-Bug: https://github.com/phpseclib/phpseclib/issues/125
-Last-Update: 2013-06-29
---- a/Net/SSH2.php
-+++ b/Net/SSH2.php
-@@ -1329,14 +1329,14 @@
+diff -up Net_SSH2-0.3.6/SSH2.php.orig Net_SSH2-0.3.6/SSH2.php
+--- Net_SSH2-0.3.6/SSH2.php.orig 2014-02-26 18:06:35.698241870 +0100
++++ Net_SSH2-0.3.6/SSH2.php 2014-02-26 18:17:42.433603190 +0100
+@@ -1060,7 +1060,7 @@ class Net_SSH2
+ array('twofish128-ctr', 'twofish192-ctr', 'twofish256-ctr', 'twofish128-cbc', 'twofish192-cbc', 'twofish256-cbc', 'twofish-cbc')
+ );
+ }
+- if (!$this->_is_includable('Crypt/Blowfish.php')) {
++ if (!$this->_is_includable('Crypt/Blowfish-phpseclib.php')) {
+ $encryption_algorithms = array_diff(
+ $encryption_algorithms,
+ array('blowfish-ctr', 'blowfish-cbc')
+@@ -1428,14 +1428,14 @@ class Net_SSH2
break;
case 'blowfish-cbc':
if (!class_exists('Crypt_Blowfish')) {
-- require_once('Crypt/Blowfish.php');
-+ require_once('Crypt/Blowfish-phpseclib.php');
+- include_once 'Crypt/Blowfish.php';
++ include_once 'Crypt/Blowfish-phpseclib.php';
}
$this->encrypt = new Crypt_Blowfish();
$this->encrypt_block_size = 8;
break;
case 'blowfish-ctr':
if (!class_exists('Crypt_Blowfish')) {
-- require_once('Crypt/Blowfish.php');
-+ require_once('Crypt/Blowfish-phpseclib.php');
+- include_once 'Crypt/Blowfish.php';
++ include_once 'Crypt/Blowfish-phpseclib.php';
}
$this->encrypt = new Crypt_Blowfish(CRYPT_BLOWFISH_MODE_CTR);
$this->encrypt_block_size = 8;
-@@ -1405,14 +1405,14 @@
+@@ -1504,14 +1504,14 @@ class Net_SSH2
break;
case 'blowfish-cbc':
if (!class_exists('Crypt_Blowfish')) {
-- require_once('Crypt/Blowfish.php');
-+ require_once('Crypt/Blowfish-phpseclib.php');
+- include_once 'Crypt/Blowfish.php';
++ include_once 'Crypt/Blowfish-phpseclib.php';
}
$this->decrypt = new Crypt_Blowfish();
$this->decrypt_block_size = 8;
break;
case 'blowfish-ctr':
if (!class_exists('Crypt_Blowfish')) {
-- require_once('Crypt/Blowfish.php');
-+ require_once('Crypt/Blowfish-phpseclib.php');
+- include_once 'Crypt/Blowfish.php';
++ include_once 'Crypt/Blowfish-phpseclib.php';
}
$this->decrypt = new Crypt_Blowfish(CRYPT_BLOWFISH_MODE_CTR);
$this->decrypt_block_size = 8;
diff --git a/php-phpseclib-net-ssh2.spec b/php-phpseclib-net-ssh2.spec
index 25d22ca..d29dec8 100644
--- a/php-phpseclib-net-ssh2.spec
+++ b/php-phpseclib-net-ssh2.spec
@@ -1,9 +1,9 @@
-%{!?__pear: %global __pear %{_bindir}/pear}
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Net_SSH2
Name: php-phpseclib-net-ssh2
-Version: 0.3.5
-Release: 3%{?dist}
+Version: 0.3.6
+Release: 1%{?dist}
Summary: Pure-PHP implementation of SSHv2
Group: Development/Libraries
@@ -44,7 +44,7 @@ Pure-PHP implementation of SSHv2.
pushd %{pear_name}-%{version}
# Fix line endings of file we're about to patch
sed -e 's/\r//' -i SSH2.php
-%patch0 -p2
+%patch0 -p1
# Drop md5sum of patched file from the PEAR manifest (or else it'll complain)
sed -e '/SSH2.php/s/md5sum="[^"]*"//' \
../package.xml >%{name}.xml
@@ -56,20 +56,20 @@ cd %{pear_name}-%{version}
%install
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
cd %{pear_name}-%{version}
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%clean
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
%post
@@ -90,6 +90,9 @@ fi
%changelog
+* Wed Feb 26 2014 Remi Collet <remi@fedoraproject.org> - 0.3.6-1
+- Update to 0.3.6
+
* Sat Jan 25 2014 Remi Collet <rpms@famillecollet.com> - 0.3.5-3
- backport for remi repo