summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-25 07:29:45 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-25 07:29:45 +0100
commit0ccebfde4cd12eb77321d1af0e66f0575ae939d1 (patch)
tree3305702bb46b84aadd6aec6c472d0e0f898d1e11
parent25e27f195eb7b65a920c35ef249389980e5d38ba (diff)
php-phpseclib-net-ssh2: backport
-rw-r--r--Makefile4
-rw-r--r--php-phpseclib-net-ssh2.spec13
2 files changed, 15 insertions, 2 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-phpseclib-net-ssh2.spec b/php-phpseclib-net-ssh2.spec
index 4e721f4..25d22ca 100644
--- a/php-phpseclib-net-ssh2.spec
+++ b/php-phpseclib-net-ssh2.spec
@@ -1,5 +1,4 @@
-%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Net_SSH2
Name: php-phpseclib-net-ssh2
@@ -15,6 +14,7 @@ Source0: http://phpseclib.sourceforge.net/get/%{pear_name}-%{version}.tgz
# library to avoid conflict with php-pear-Crypt-Blowfish
Patch0: php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
@@ -56,6 +56,7 @@ cd %{pear_name}-%{version}
%install
+rm -rf $RPM_BUILD_ROOT
cd %{pear_name}-%{version}
%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
@@ -67,6 +68,10 @@ mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
%post
%{__pear} install --nodeps --soft --force --register-only \
%{pear_xmldir}/%{name}.xml >/dev/null || :
@@ -79,11 +84,15 @@ fi
%files
+%defattr(-, root, root, -)
%{pear_xmldir}/%{name}.xml
%{pear_phpdir}/Net
%changelog
+* Sat Jan 25 2014 Remi Collet <rpms@famillecollet.com> - 0.3.5-3
+- backport for remi repo
+
* Thu Jan 16 2014 Adam Williamson <awilliam@redhat.com> - 0.3.5-3
- fix up the patch for crypt_blowfish rename per review